SmartThings Community

Alexa Helper - Change mode or phrase with a switch toggle

#143

I am new to this. I added and published the coded date 11/17/15 via IDE. Try to install it from ST mobile app but when I tap on creating a new scenario, the message “smartthing has crashed …” popup and the smarthings app is restarted. What I am doing wrong ? Thanks.

(Micheal ) #144

Actually, I just did a major upgrade. Please read here: [RELEASE] Alexa Helper

In summary, there are two versions now…Version 2.2.2 which is a stand alone app that will no longer be supported (Now called Alexa Helper-Original).

The new version has two parts (a parent and child app). This is version 3.0.0 and available in the link above. It sounds like you installed the Parent app and are missing the child app. Please note…on the child app do NOT publish it…just save it.

#145

Thanks Michaels. I added both versions to mysmartapps. For testing, I used version 2.2.2 and got the door lock to lock/unlock according to the virtual switch on/off state. However, Alexa only response to command turn on/off the door instead of open/close (or lock/unlock: is this possible ? ). What I need to do for Alexa to response to open/close words ?

(Micheal ) #146

Unfortunately that is controlled by Amazon. There are certain key words that mean different things to Alexa and as such, she doesn’t respond well to them. For example, I set up a virtual switch called ‘sleep in’ that puts the house into a different mode than a normal weekday so the Talking Alarm Clock (my app) doesn’t go off…Spent an hour with different combinations only to find out Alexa doesn’t like a switch called ‘Sleep’ as it is one of her key words. Another key word she doesn’t like is ‘wake’…Oh well…I now call sleeping in (no alarm) ‘Holiday Mode’.

(Sully) #147

So just a question, now that Trigger Happy is out there, is this still needed for Mode changes to work with Alexa? Is it a better option?

I wasn’t sure if this was doing something specifically related to Alexa or if this was just the same method for interacting with Alexa to get mode changes to happen using a Virtual Button Device?

I’m trying to keep my list of custom SmartApps manageable. The app has worked well, in my testing. I’m just trying to see what the best options are. Thanks!

(Micheal ) #148

It really depends on what you are attempting to accomplish. Trigger Happy (from my assumption since I don’t have it installed) is that you can have a variety things happen when you trigger something (i.e. a virtual switch).

For me, I have a set of routines that I want to trigger on a normal basis. These routines lock the doors, turn off lights, set the mode, turn on the alarm, etc. Another app could do that…the routines are just built in so that works well for me. That is the beauty of community built apps…they serve a purpose for some folks, and someone else will come up with another app to appeal to someone else.

However, to give my app a shameless plug, I am not sure Trigger Happy can set the thermostat to a specific temp like mine can :slight_smile: (newest version just posted this weekend). All joking aside, I make no money by creating my apps so there is actually no incentive to do it outside of the love of HA.

New Version : [RELEASE] Alexa Helper

2 Likes
(Sully) #149

No need for a plug to be shameless. I completely appreciate the work you’ve put in on it. What you said was exactly what I’m looking for. I haven’t really gotten into Trigger Happy, either. I’m just trying to look at options. Again thanks for the work on this app.

(Micheal ) #150

Thanks…Like you I want to keep my app count down and ‘keep it simple’…That is why I created my own apps. However, as ST has evolved I have actually scuttled many of them in lieu of built in apps…a good example is the Smart Lighting App…It literally replaced 2 or 3 of my independent apps…Again, I have had my apps published by ST, but this is for fun and not for profit, so it comes down to what ever works.

The Alexa app is the same way…if you want something that just triggers a routine or changes temperature on a thermostat, this is your app. If you don’t use routines and want various unique things to happen when you trigger a virtual switch, than Rule or Trigger Happy may be the solution.

Gotta love some of the aspects of the open ST model…there is never a right answer…there are multiple right answers depending on your situation.

3 Likes
(JP) #151

I am on V2 hub and just setup version 3.2 of the Alexa Helper. When I click on “Create new Alexa Scenario” it does nothing. Am I missing something? I tried to quicky read through the posts here, but from what I see it should work.

(Micheal ) #152

You should have all 3 pieces (code above in this thread):

Alexa Helper-Parent: Sounds like you have done this
Alexa Helper-Scenario: You may be missing this code. You will SAVE it, but don’t publish it
Virtual Dimmer Code: You will only need this if you want to use the thermostat or speaker functionality. This is not an app, but a new device.

Let me know if you installed all of these.

2 Likes
(JP) #153

@MichaelS thanks for the quick help. I missed the copy of the helper-scenario. All good now. Thanks Again!

#154

Michael? Can you help me please? When I select “Create New Alexa Scenario…” nothing happens. Thermostat and Speaker Controls both go to the configuration options (next screen). Am I missing something?

(Micheal ) #155

Are you sure you have the 3 pieces installed:

Alexa Helper-Parent: Sounds like you have done this
Alexa Helper-Scenario: You will SAVE it, but don’t publish it
Virtual Dimmer Code: You will only need this if you want to use the thermostat or speaker functionality. This is not an app, but a new device.

Let me know…also, I am releasing new code today. This should not affect you, but you may want to go to the official thread for this and ensure you have the latest versions.

#156

Michael - that worked. Sorry for the oversight on my part. I do see where you previously posted this same answer to another posting that had the same exact question as mine. Thanks for your patience.

(Micheal ) #157

No worries…I am asking members of the community to help me document the functions of this app so I can create a dedicated web site for it. If that person isn’t you, but you know someone who loves formatting and documenting, send them my way!

2 Likes
#158

What about adding your app info to the new wiki site as being discussed in Announcing ThingsThatAreSmart.wiki?

(Micheal ) #159

I actually have most of the text and screen shots done, so I can easily migrate it to a site if necessary. Either way, however, I will have a manual for the app.

3 Likes
(Nate House) #160

Is there a way for virtual buttons/dimmers/switches to refresh based on current state of an associated device? I see people getting around this with momentary switches for single actions but would rather have a single device handle both on and off actions.

(Micheal ) #161

Not directly…if you associate a simulated switch with a device in something like Alexa Helper, you need to think of the switch as one way…in other words if you turn off the simulated switch, the automation would turn off the respective linked device. But if you turn on the device manually, you would not turn on the simulated switch unless that was built into the logic. For items that refresh (poll) on a quick basis, that is not an issue. However, for thermostats (particularly Nest) and Speakers, since they are not connected via ZWave or Zigbee, their refresh could be minutes or hours. That is why I personally don’t link them in the code as you get all kinds of weird things happening when you attempt syncing.

(Alexander E Jones) #162

Michael,

Great app! I’m just getting started with SmartThings and Alexa. I installed the app and the child app (not publishing child). When I try to setup a Scenario Type that changes modes (I just want to tell Alexa to do Good Night routine), it hangs me up on the Control Switch (On/Off, Momentary). When I tap to set the control switch, it says “no options available.” I can change all the other options (like change to mode, perform routine, etc…), but I can’t save it because the control switch isn’t set. (I looked through all your app’s posts but couldn’t find someone with a similar problem.)

Thanks!
-Alex