After Sunset Routine?

routine director allows this :smile:

Excellent. Now where do I find Routine Director…

I’ve been through all the SmartApps available on the Android App and there isn’t one called Routine Director.

Under Presence and Modes in Marketplace on SmartApps tab…

It’s not there. Just to emphasise, I’m in the UK.

I’ve given up and had to contact support. They’ve given me the below solution:

  1. Go to Routines > Tap the 3 dots in the top right corner
  2. Tap Add Routine > Add a new action e.g “I’m Back After Sunset”
  3. Select ‘Turn on these lights or switches’ and select the lights you want to turn on > Done
  4. Select ‘Set Smart Home Monitor to’ and select ‘Disarm’ > Done
  5. Tap ‘Change the mode to’ > Home > Done
  6. Scroll down to Additional Settings > 'Automatically perform “I’m Back After Sunset”
  7. Hit ‘Someone arrives’ > Select your Presence Sensors
  8. Select At sunrise or sunset > Sunset > Done
  9. Go onto the Additional settings’ > ‘Don’t automatically do this if I am in one of these modes’
  10. Select ‘Home’ (this prevents it from firing if you do get home before Sunset) > Done

I’ve been considering adding i’m back after sunset as well.

But wouldn’t you need to restrict your old “I’m back” routine to before sunset? Otherwise both “I’m back” and “I’m back after sunset” would still meet the requirements for automatically happening when you arrive after sunset. I’m not sure what would make one take precedence over the other.

I think the ‘Don’t automatically do this if I am in one of these modes’ is the key to all of this.

Maybe I just have my modes set up differently, but if I come home before sunset the mode was away. If I come home after sunset the mode was still away.

So restricting to not happen if mode was home would only apply if I came home before sunset but someone was already home.

You need to split your ‘away’. Add a new mode ‘away at night’, which switches automatically from ‘away’ to away at night. Same goes for ‘Good bye’

Just want to confirm that the above routine has worked for me…

Modes: Away, Home, Morning & Night
Routines: Good Morning, Good Night, I’m Away, I’m Home - Day, I’m Home - Night.

I’m Away

After 5 minutes of both presence sensors being away it switches off the lights, sets the SHM to Arm (Away) and changes the mode to Away

I’m Home - Day

When one of the prescence sensors arrives home, it sets the SHM to Disarm and changes the mode to Home

I’m Home - Night

When one of the prescence sensors arrives home after sunset it runs the I’m Home - Day routine first, then fires up the I’m Home - Night one which turns on the lights, sets the SHM to Disarm and changes the mode to Home.

It’s not ideal because it still runs the I’m Home - Day routine first, but it does work.

This is what I was getting at. I think if you edit your I’m back Day routine to end at sunset you won’t have this issue, right?

I’ve amended the routine this morning to accommodate just that and I’ll let you know how I get on.

1 Like

I’ve been advised to do something different by SmartThings support:

  1. Open up ‘Home - Night’ > Additional settings > Automatically perform ‘Home - Night’ when…
  2. Additional settings > Don’t automatically do this if I am in one of these modes > Select ‘Away’ and ‘Home’ > Done
  3. Go back to Routines > ‘Good Night’ > Change the mode to > ‘Night’ > At sunrise or sunset
  4. Either sunrise or sunset > Tap to set > Sunset > Done

Feels like I’m chasing my tail here. The advice from support has actually made more harm than good. Coming home on an evening after sunset fires the “I’m Home - Day” routine and doesn’t turn on the lights.

That is because you restricted it to not fire if mode was away. :wink:

Hey here is my set up that does exactly what you are trying to do:

When someone is home:

Daytime Mode - automatically changes at sunrise only if in Evening Mode
Evening Mode - automatically changes at sunset only if in Daytime Mode

When we leave:

Away Mode - changes when everyone leaves only if in Daytime Mode
Away at Night - changes when everyone leaves if in Evening Mode OR at sunset if in Away Mode

When we come back:

Routine ‘I am back’ - runs automatically when someone arrives only if in Away Mode
Routine ‘I am back at Night’ - runs automatically when someone arrives only if in ‘Away at Night’ Mode

When in vacation

Routine ‘Vacation’ - changes to Away Mode at sunrise only if in Away at Night ( to avoid changing to Daytime if we are in vacation)

This set up never failed ( well never say never, it fails occasionally when ST has scheduling issues, but that is fairly rare)

I might just try that after the next fix that SmartThings support have offered me.

Seems to be going ok so far. When I woke up it put it into morning mode, when we both left it put it into away mode, and when i came home just now it’s put it into “Home - Day” mode.

Let’s see what happens tonight!

The recommendation from SmartThings supports seems to be hit and miss. It fixes one scenario but breaks another…

@SBDOBRESCU The above sounds exactly what I’m after but do you think you could break it down even further for an idiot like myself i.e. What are the modes you have set up? What routines do you have set up? How do you create a routine which checks for 2 things i.e. if in Evening mode, or at Sunset in Away mode - don’t you need 2 routines to do that?

You may feel like the above explains things (and I apologise massively) but I’m still seriously struggling to understand how I need to set it up in the SmartThings app.

My set up is more complex, or else I would have taken screenshots. But I’ll try to be as detailed as possible.

Here we go:

• Daytime
• Evening
• Away
• Away at Night
• Vacation

• Good Morning
• Good Evening
• Good bye
• I’m back
• I’m back at Night
• Vacation

By making your home change the mode automatically, based on sun state AND current mode.

******************************** When everyone is home: ********************************

A. Create a routine called Good Morning

Settings

1 . Change the mode to: select Daytime
2 . Additional settings… “Automatically perform “Good Morning” at”: Sunrise (ONLY if in Evening Mode)
Note: to achieve the ONLY if mode, you need to select ALL but Evening under section "Don’t
automatically do this if I am in one of these modes - see pic #3 below)

Here is how it looks on Android:

Pic 1 This is the main page that shows the automatically perform Good Morning at sunrise (changing the mode to Morning- Daytime in your case)

Pic 2 This is where you should see all but Evening Mode.

Pic 3 …and this is how you restrict the routine to run ONLY if in Evening Mode

Once you get a hang of this setting, the rest are just replicas of the same logic …aka …rinse and repeat.

B. Create a routine called Good Evening, set it to be performed at sunset ONLY if in Daytime Mode - (check all modes but Daytime).

Above two routines are taking care of the situation where someone is home. Next, we need to set up routines for when everyone leaves…

******************************** When everyone leaves ********************************

C. Create a routine called Good Bye, which changes the mode to Away and runs automatically when everyone leaves ONLY when in Daytime mode (check all modes but Daytime)

D. Create Away at Night, which changes mode to Away at Night, at sunset, ONLY in Away Mode (check all modes but Away)
Note: this one is the only one you need to manually push if everyone leaves after sunset (it happens rarely in my home so I didn’t really bother to find a way to automate this part)

These 2 take care of the home when no one is home, next will take care of the routines when someone arrives.

******************************** When someone arrives ********************************

E. create a routine called “I’m Back”, which runs automatically when someone arrives, ONLY in Away Mode (check all modes but Away)

F. create a routine called “I’m back at Night”, which runs automatically when someone arrives ONLY when mode is Away at Night

******************************** When everyone is out of town: ********************************

G. create a routine called ”Vacation”, which runs automatically at sunrise ONLY if mode is Away at Night

ALTERNATIVELY. …you could use Bruce’s new Rule app, which should get you there much faster. It didn’t exist when I created my set up, and I am way deep to convert it now.

Let me know if something is not clear…Good luck

8 Likes

I can’t begin to say how much this has helped me @SBDOBRESCU

It’s given me the basis to build other routines around it i.e. turning lights off when it gets quiet on an evening etc… This should definitely be stickied in my opinion because it’s one of the most common set ups people would like to use.

4 Likes