Aeotec Smartthings motion sensor - No new command at constant movement?

So; i have a question about the official Aeotec Smartthings Motion sensor.

I got two of them set up to turn on the lights on the staircase (one in the hallway downstairs and one in the hallway upstairs so they detect movement early have enough time to turn on the lights). I set the lights to be on for 1 minute and then automaticaly turn off.

The thing i found out. When you walk past either one of the motion sensors … it works fine.
The lights turn on; and off after a minute.

However; if you trigger the light and keep moving for the whole minute in range of the motion sensor… The lights will turn off (like they are suposed to after 1 minute)… but then the lights do not turn on again. You gotta step out of the motion sensor range for a bit… then the lights trigger again.

Is this some kind of setting / baked in protection?, it can be usefull or not usefull at all in some cases. The ideal thing would be for the lights to just remain on as long as there is movement. And when the movement stops they turn off after a minute.

You may want to try using two routines… one to turn on and the other set to “no motion detected for 1 minute” and see if that works better for you. Of course, the light will stay on slightly longer than the auto turnoff after 1 minute if that matters.

Others may have other options for you such as using virtual switches. :slight_smile:


Almost all Home automation sensors in the price range that most smartthings customers are looking for have a built in “cool down“ period After motion is initially detected during which any other movement is ignored. This cooldown period Is most commonly set at three minutes. The reason is primarily to extend the battery life by limiting the number of extra notifications sent to the hub. So that’s what usually causes this issue.

As @jkp said, The usual workaround is to separate your logic into two different routines. One that turns it on after movement detected and another that turns it off after a set period of no movement detected.

There are motion sensors that allow you to change the length of the cooldown period, even down to just a second or two, but doing so will significantly reduce the battery life. So it just depends on what your use case is.

Using two routines is usually the best solution for most people, but if you do want a more configurable motion sensor, and you’re willing to change the batteries every two or three months, or leave it plugged in if it has that option, let us know and we can make some suggestions. We will need to know what country you are in, as the device selection does vary. :thinking:

1 Like

I think perhaps you are battling against both the motion sensor and SmartThings. The actual behaviour is more like this:

When the sensor detects motion this is reported to the hub and the device handler/driver will process it and set the motion attribute of the motion sensor capability to active. You can then use that in e.g. a Routine to perhaps set a light on.

The sensor will now stop checking for motion for a period of time. I believe it may be 30 seconds on this one. Let’s assume I read an accurate thread and it is. After that 30 seconds is up, if there is still motion it will report it as before (and stop looking again). The motion attribute will be set to active again, but because it hasn’t changed, SmartThings probably won’t bother propagating this information around. This is what leads to the need you found to move outside the detection area. You need the motion to be set to inactive (below) before another active is seen.

On the other hand, if there is no motion after the 30 seconds the sensor will report that and the motion attribute gets set to inactive. Not all models of sensors report when motion stops. With those that don’t the handlers/drivers will use a timer to set inactive if an motion detected report isn’t heard for a period of time. I think this model does report though.

It is really the inactive report you want to work with if you plan on turning lights off. You either turn the lights off immediately motion is inactive or if you want a bit more of a delay you make the condition motion remaining inactive for e.g. a minute.

Don’t be concerned that this results in separate Routines for turning lights on and off. There is nothing wrong with that.


Hi @ChrisV,

Aeotec sensor have a 30 sec movement reset.

I am using 3 of those sensors to control the lights of a 3-flight staircase and the only way I found to make it work well every time and not stay in the dark and not waste energy, is to use 2 routines without timers.

  1. Turn on the lights if any of the 3 sensors detect movement.
  2. Turn off the lights when all 3 sensors do not detect movement.

If you stop and the light goes out, as soon as you make a slight movement it turns on again.

If you set any timer to turn on or off, it is no longer guaranteed to turn on again as soon as you move.
The timers in smartthings routines are a double edged sword, you know when they trigger the first time but you never know when it stops or has been reset.


Right; i made 2 routines now.

Now it’s time to test the new setup and dance down the staircase like a nutcase for a few minutes.

Maybe i can do a Joker impresson :thinking:


If you need to add any extra time, I would add it in the shutdown automation If part.
That timer is normally reset with sensor status changes.

So i used the following routines now.

  • Turn the lights on if any of the sensors detect motion.
  • Turn the lights off if none of the sensors detect motion for more than 1 minute.

The lights work fine now. When there is movement the lights stay on.
However the tradeoff is that the lights take (way) longer than 1 minute to turn off after movement ended. But i take that over non working lights sometimes!

Thank you all for the help; learning someting every day.

P.s. Even Philips Hue has the problem i discribed in the starting post. I just noticed the front door sensor did the same; and that one is linked right to the Hue hub. Also still have to connect that one straight to the smartthings hub.

I actually use motion sensors all over the house, I have my kitchen come on if there is motion in the kitchen and turn off if there is no motion in the kitchen, but motion in one of the other rooms, that way if i’m eating dinner, and not moving enough for the motion sensor to detect it, the lights won’t turn off, until I leave the kitchen. BTW, I live alone, so with more people here it may turn lights off when you don’t want them to.

I use Smart Lightings for movements detector(smarthing brand) . They detect movements and if there is no other movements within 2 min(example), they are shutting my lights. At each movements in the 2 min period, it is extending the period for 2 minutes.

If there is no other movement in the 2 minutes period, the light is shutting. After the light shutting, if there is another movement, the lights open. No cooldown period. That’s why I prefer Smart Automation fonction instead of using 2 scenes.

FYI… for those users who might not be aware… Smart Lighting is a legacy groovy app that will be phased out on the ST platform when support ends for groovy. Any use of Smart Lighting at this point should be considered short-term so you will eventually need to migrate to Routines.