Aeon MultiSensor 6 - Reporting 0 Lux

I’m trying to use the illuminance sensor on the Aeon MultiSensor 6 and it starts to report 0 Lux when there is plenty of light - for example on an overcast day. I haven’t seen it report more than 19 Lux actually.

Is this a known issue? Do I have a bad sensor? It’s been quite frustrating

I am working on a custom device type for this and saw the same thing for awhile now It reports up to 1800 … recommend you leave it for a few hours in the dark, I have a feeling it self calibrates… at least that is what mine did after leaving over night…

re here is my device type.

I’m new to device types. Can you point me to the differences between yours and the Robert Vandervoot one? Thanks for the reply, btw!

So I tested out the sensor a bit more. Shining a bright flashlight pretty directly at the sensor did get it to show 10,000+ Lux. If shone slightly less directly, it would do sensible things like respond with 1,500 Lux or something similar.

However, with ambient lighting in our room (by no means dark), it fell quickly back to 0. This is also what it ends up reporting on an overcast day where we don’t even need to switch on lights in the room. Far from the 50-100 Lux that it should be ( Having all the lights on in the room brings it up to 12-13 Lux.

Seems to me like the sensor is just plain inaccurate and lacking in sensitivity on the lower end of the spectrum. I doubt a device handler is going to fix whatever issue it is having - but I hope I’m wrong. As it stands, I’m most likely going to try and return it.

Note that I have also tried setting a luminance offset of 100 Lux - hoping that maybe the calibration was wrong and negative numbers never get sent back. That didn’t work. It stayed at a 100 Lux in pitch darkness. So clearly, it is having trouble distinguishing between darkness and some light. Really only seems to work in really bright light.

Just not very sensitive to light and uV.

Have you had a chance to play with the Fibaro one? Do you know if it is any better?

some observations…

  1. cannot get the reporting interval to work when on battery regardless of settings it seems to report hourly.

  2. widely inaccurate device… I have one on battery 1 on usb in exactly same location
    temp is off by 10 degrees , humidity off by 10% and lux off by 2-3 lux between the two devices…

anyone else care to comment

Regarding the reporting interval – I have seen documentation somewhere that states that the reporting interval cannot be lower than 60 minutes on battery power. So that, at least, is expected.

I’m almost ok with some inaccuracy here. What I’m not ok with is how quickly the sensor starts reporting 0 Lux — even on cloudy days during the daytime when I don’t even need to switch on lights. That’s super frustrating to me :confused:

Hey, just to let yo know I tried to install you device handler to check it out but when I would go to update the device I would get an internal server error.

you need to edit the device first and make sure all parameters are set

So you can’t just overwrite the device type? What settings would need to be edited?

IF it had another custom device type you need to exclude it first then remove the other custom device type. Then add back. Sometimes there are conflicts between them.

I also am interested in the lux reporting (reason why I got the sensor). I set it up today with overcast and I am also getting 0 value. I turned on a couple of lamps and I got a 1 lol. Still trying to figure out how often it reports. I’m using another device driver from the multi gen 6 thread, not Robert’s… I forget the username :slight_smile:

After communicating with Aeon service folks, I’m now reasonably convinced that this sensor is just not very capable of detecting light well. It does not appear to be a software problem - so no amount of Device Type tweaking is going to fix this. Their only recommendation to me was to have the source of light be able to hit the sensor more directly. Which is not really feasible in most cases. I’m pretty disappointed to say the least…

1 Like

Thanks for the info.

That sucks. I initially purchased it for humidity, which seems to work well. I was hoping to set some rules with Lux but its always near 0.

I observed the reported lux values over a couple of days and just went by those numbers. In my case, below 6 lux I turn on the lamps and off at other times.

Latest Smartthings hub update told us that these sensors would now run support locally so I guess that may fix the delay issue I experience over the Smartthings motion detector

And they released a firmware update for them in December too:
It includes “Improved accuracy of lighting sensor”. I wonder if this will help us with this query.

I guess we cannot do over the air updates to this device from our hubs? Or maybe this will come as part of the hub firmware update…

As I write, it’s about 40 mins after sunrise on a gloomy day and I’m waiting for a lux level I can use to set as my trigger for turning-off the lights in the morning. I have 1 lux at present. I am guessing the level of 6 suggested above may be about right…

I bought one of these and had it in my garage for quite some time and I was very happy with it. So I then decided to get a few more…they showed up yesterday…and now I find myself here reading this thread as the Lux reporting is wildly different on the new ones that I just purchased. I even setup a little “test lab” on the window sill in my kitchen. Right now I’ve got a backyard covered in white snow, and a white fence and it’s just about noon…so it’s rather bright outside. Even my camera was struggling with the contrast to take this picture.

But here’s what they are reading…

There’s one not shown in the picture which is a few feet away… The Garage is the first one listed. The temperature range is mildly annoying I suppose…with them being only a few inches away from each other. But the Lux readings are entirely unacceptable. They should all be in the thousands…not barely over 100.

I’m not sure what to do here either. I may just let them sit in the window all day and see how it goes.