200 Device limit - How to proceed from here?

Aaaand here we go. For the first time I am getting a message about limits when I tried to add back in a motion sensor that keeps dropping offline. And here’s the fun part - the msaage says can’t add more than 300 devices.

I’m on iOS.

UPDATE: Well, that message was on an iPad. No such problem on my iPhone. :man_shrugging:t3:


You couldn’t make this up. Have you tried hiding devices to get below 300 ?

Maybe you should open a new thread. This one is for the 300 device limited


I haven’t as I can still do what I need via the phone. And since the sensor issue I’ve added a further 4 hue devices as well with no issues, again via the phone.

Perhaps the new plan is for the limit to increase inversely in proportion to the amount of wonga they can make getting you to upgrade to a more powerful device performance of the device and Apple fancied some of that and asked for a slice asked if the same thoughtful consideration could apply to their customers too.

Yeah, it must be that.

FYI, the latest release of the Android app ( has the 200 device limit, at least for those of us who didn’t have it before.

I hit the limit notification today after the app updated.

1 Like

I wish they would make up their minds. Every time the bring in a new version of the app they have a different rule. I think their app development team are using a random number generator.

Log it with their service desk.

What servers are you connected to ?


I’m not sure how to tell anymore without the old IDE. I was using graph1 (one of the original servers).

I’ve updated an Android device to the latest version of the app and I’m getting a 300 device limit. Still no limit on iOS. But at least when the devices are hidden they still don’t count towards the number of devices.

1 Like

Well then what in the world is going on with this crazy app?

So I forced stopped and cleared cache, and now I’m able to add more devices without getting any error message when going through the main “landing” page for the app or by going into a Room and adding a device.

An hour ago I could not add back in a Zigbee switch because I was getting a 200 device limit, but now i’m having no issues. Dang it, this crazy app…


Perhaps a communications breakdown between development groups? IIRC, when we cut over to the “new” app some years back wasn’t there discussion that indicated it was a different, more (Samsung) product-oriented app of which SmartThings was just one component? Add global diversity and stir… :wink:


Back in 2016, Samsung had separate apps for their smart televisions, smart appliances, accessory devices, like earbuds, and the hubs.

After they acquired Harman Kardon, that brought in some car stuff as well. There was one announcement which said that a group of engineers from Harmon was going to help with creating a “one app“ to combine all of those various apps, but I’m not sure that part of the project actually happened.

But in any case, in 2018 they did combine all those multiple apps into one under the smartthings name.

1 Like

I think that’s why the mobile app is the biggest weakness in SmartThings. The Classic app had its flaws but it was an honest app and was very much the reference admin and control client it appeared to be.

The ‘new’ app is dishonest. It is very much a Samsung app built alongside and on top of the SmartThings APIs but then adding layers of its own and making a right old mess of it in places. Yet developers are obliged to treat it as the reference client however broken it is.


I am on IOS and there is a 300 devices limit now


That works mate thank you. :ok_hand:

Do anyone have this issue? In order not to exceed the devices limit, i have unclick some of the devices not in use under managed devices but currently all my buttons are not able to assign actions.
It is now asking me to add all devices back in order to assign actions? Not sure why i must have all devices added back for actions can be assigned? Have already so many other active devices. Is this a bug?

Any one face the same issue? Can help to check if same issue? Thanks. Note: Am running on IOS app latest ver at

Updated: seems like its a bug. On my other IOS phone running an older ver at Of the smartthings app, without the feature of manage devices, all my button are allowed to assign actions.
See below

Any idea for android , the devices limit of 300 consider those devices that is not select to use? Not sure why i have unselect devices to have less than 300 devices but its still shows “can’t add more than 300 devices” when trying to add.

IOS do not have this issue, except when it has really more than 300 devices selected

@Jeff_Gallagher do you have any idea on this?

I’ve not updated my Android device yet. I’ll try it this evening

Thanks. Been trying to solve the map view issuezz
Seems like my android is always showing error of 300 device limit regardless how many devices i unselect. Not sure if this is the reason why the map view is not working when i login to my account and not my wife account where she do not have any devices.