ZXT-120 Wave to AC IR extender--does configuring work? (Fujitsu Halcyon Minisplits)


(Boris Tsipenyuk) #1

Hello, I know there are a number of threads and device handlers, does anybody have a fully working configuration file for Fujitsu Halcyon Minisplits (aka does configuring the values within the device handler actually work?) or does it all have to be done via learning mode, and if so - maybe it’s just having a senior moment, can someone walk me through how they did it with their Fujitsu remotes - thank you


(Mark) #2

I’m not sure if I’m 100% understanding what you’re asking for, but here’s a link to @Ron’s github repository.

The SmartThings device handler for the zxt-120 isn’t specific to any one type of a/c. Check the zxt-120 manual for the codes for your a/c manufacturer. Then enter the code in the configuration screen for the device in your ST mobile, and tap the configure button.


(Ron) #3

I know you are looking specifically for Fujitsu so I can’t really help. I have a Mitsubishi system which is working well. Just look at the list of codes that was included with the device and find the codes for fujitsu. Then try them one at a time to see if they work. Unfortunately that is the only way. I did this for my Mitsubishi and found that most of the code actually worked which bothers me a little because it makes me wonder which is correct. The Mitsubishi system also has no feedback when the remote sends request and there is no display on the units so I can never be sure if it is “exactly” what I requested. But that said I find that the AC, Heat, and Dry modes work and the fans adjust as requested so I think it’s fine.

Some things to make sure you do.

  1. Make sure device is in always listening mode before you include.
  2. make sure you press the button on the device before you press configure when you change the code in preferences
  3. make sure you see the tile which shows the current code change to your newly configured value before you start testing so you are sure the unit received the new code. This tile is updated when the zxt-120 reports it’s current code setting back to the device handler.

As far as learning goes the manual that came with the device explains what you need to do.

The technique is

  1. set code to 000 (learning code) (will display in tile as 0)
  2. set the number of the heat/cool temp you are configuring using the learning code slider
  3. press the learn button (red light will flash once)
  4. put remote near zxt-120 and press button to be learned. zxt-120 will flash twice if successful, it will flash 4 times if not

(Boris Tsipenyuk) #4

thanks for both of your replies - I’m not trying to be dense - I looked at the instructions via - https://www.remotec.com.hk/wp-content/uploads/2016/06/F-BW8377xx-ZXT-120xx_User_Manual_V1.8_printing-version_20140515.pdf - found ANOTHER document that has a list of a bunch of manufacturers - and I swear I feel like I should have enough technical know how to get this working as so many others have:

the temperature slider says “0” is off - that’s all I’m trying to program
0 - double check device is in always listening mode and add to st with device handler

1 - 000

2 - configure button in device handler

3 - 250 (off in the temperature list)

4 - configure button in device handler

5 - press the big middle button and aim the remote at it and press. on /off

I never get the single/flashing confirmation/denial. if you can push me through whatever add blockage I am having, it would be greatly appreciated

and I have no clue despite re-reading the manual 10 times as to how I’m supposed to use the manufacturer’s code ?

thanks so much


(Ron) #5

I am confused by your post. Let me try to understand what you are saying.

“the temperature slider says “0” is off” what is “the temperature slider” ?

I am assuming 0-5 are step numbers so you I have quesitons
1 - 000
Where did you enter 000, you entered this in preferences for the “Remoted code” right?

2 - configure button in device handler
Did you confirm that the “Config# XXX” tile displayed “Config# 0” ?

3 - 250 (off in the temperature list)
I don’t know what this line means. The Temp mapping table on on page 11 says to use parameter value 0. What is 250? What are you doing with this number (not changing the Remote code I hope, that needs to stay 000 for learning mode.

4 - configure button
This step is wrong

5 - press the big middle button and aim remote…
This step is wrong

==================

Let me review my instructions again

  1. set code to 000 (learning code) (will display in tile as 0)

Enter preferences and change remote code to 000. Save this and any other preferences. Click on the zxt-120 button to wake it. Press the config button in DH. Confirm the “Config #XXX” tile, displays “Config #0” to confirm zxt-120 was configured with remote code 0.

  1. set the number of the heat/cool temp you are configuring using the learning code slider

View page 11-12 of the manual and acquire the correct parameter setting for the temp you want to learn. In your case “off” = 0.
Move the “Learn Mode Parameter Slider” in DH to position 0.

  1. press the learn button (red light will flash once)

Press the learn button in the DH, red light should flash once

  1. put remote near zxt-120 and press button to be learned. zxt-120 will flash twice if successful, it will flash 4 times

Point remote toward top of zxt-120 2-3 inches away from device and press but button you want to learn, in your case “off”. zxt-120 should flash twice for success. 4 times means it failed or timed out.

Here are two key screen shots to help you visualize what I am describing.

  1. Settings screen (I am using remote code 176, you want 000 for learn mode)

  1. DH Learning tiles (lower half off tiles)

To enter the remaining learned codes simply move the slider to temps to be learned, press learn, press remote, see flash…repeat. In other words steps 2-4 are repeated for each temp to be learned.

Learn mode positions are
0 = off
1 = on - resume
2 = 67F cool

22 = dry mode

Does that help ?


(Boris Tsipenyuk) #6

thanks for your patience - let’s go back one step, what device handler are you using cause mine has all the buttons already in place for head/cool so forth.

I had no idea about the sliders - so that already got me way further than any other instructions I was able to find - I think I got as far as it learning off - two flashes - however (neither) off button on the dh does anything

thanks


(Ron) #7

@Boris_Tsipenyuk that is the correct DH I modified the “scale: 2” to “scale: 0” to make the icons larger so you could see them better in my screen shots. I had just changed the DH to use scale:2 and I liked it at first but decided it is just much easier to use with the larger tiles. If you grab the latest code from my DH github you will get the larger tiles (or just change the scale in your ide).

On your version the slider in the second to last row is the learning slider.

The zxt-120 instructions will not mention the sliders because they didn’t write the DH, I did, sorry it’s not documented well.

There is only one “off” button. It’s the green off button. The 4th tile on the screen tells me the DH issued the off command. I can’t help with why the learned off command isn’t working. Are you sure you have the zxt-120 close enough to the AC unit and facing the unit correctly?

Perhaps try learning one of the temp settings and see if that works.

I can’t really debug more than that. What I see is

  1. you have 0 in the “Config# 0” tile so that’s correct.
  2. you have the learn slider set to 0, which should be the correct setting for “off”
  3. you said the unit flashed twice after learning off, so that’s a good sign

When you press the Green “off” button does the zxt-120 flash red once? It should when sending the off signal.


(Mike King) #8

Just jumping in. I too have Fujitsu Halcyon Minisplits. Did you ever find a code that works, or did you go the learning route?


(Boris Tsipenyuk) #9

Hi, as an update I decided to suck it up and go the “official” fujitsu route which is hard wiring the intesishome hardware - the main reason is that for obvious reasons no IR based solution receives any info from the unit itself so you have no way to know what it’s actually doing. Also it supports ifttt.it costs about $225 per unit which is obviously more expensive than the IR route.