ZWN-SC7 Enerwave 7 Button Scene Controller

Hello, sorry to message you in this thread, but can’t figure out how to contact you in the ZRC-90 thread. Several of us have had that controller quick working in the last week or so. Your device handler seems to be working fine, but the enhanced button controller does not work. Did you write that? Any suggestions for us? Thanks for all your great work!
Brent

I did not write that app. Smart Lighting is what I would usually use with button devices.

1 Like

Thanks for the reply. Looks like smart Lighting provides on/off, but doesn’t provide light level control. I was using it to be able to set a lamp to variable brightnesses.

I had device handler and button controler loaded for several years working fine, then upgraded to new app a few months ago, then just had a hub update and now the controller is dead.

Cleared it from new ST app, factory reset cont ZWN-SC7 (hold big button till flashing, then top right, middle right, then bottom right, then big button, it flashes and should be reset).

Pick the + button from the new app to add, then scan nearby option (cause it don’t show up as a recognized device), then put device into inclusion mode (big button till flashing, then top left, middle left, then bottom left, all show flashing slow), app says scanning, but controler won’t connect?

Lastest drivers:

ZWN-SC7 Enerwave 7 Button Scene Controller
Date Created: 2014-12-18
Last Updated: 2017-05-10 update DT to support pushed as @ady624

Button Controller App for ZWN-SC7
Date Created: 2014-12-18
Last Updated: 2015-11-14

After clearing smart app and device handler and all copies of the device from the new app, factory reseting the app, powering it’s circuit breaker off for 30 secs, then loading the base device handler and smart app from the mfg, it did recognize good, but it only assignes button 1, all other buttons will not program.

No other smart app or device handler would recognize, heres the ones that worked for button 1 only:

sent email to company for support…

Is there any multiple switch on the market like this that works with ST?

I’m in the same quandary. I keep thinking about the Brilliant device as a replacement, but the cost is a bit salty…

Well, looks like you did write the enhanced button controller…but you’ve written so many you forgot!

Button Controller - Enhanced Lighting
*

@BrentB LOL, yeah I did create that. I thought you were talking about ABC (Advanced Button Controller) for some reason. I haven’t used Button Controller - Enhanced Lighting for years as I have been using the SmartThings provided “Smart Lighting”.

Re: # Enerwave ZWN-SC7 Z-Wave Scene Controller 7-Button Switch

So, I’ve got five of these installed and been working for years @ approx $25 each I’d like to know if smartthings has just made them obsolete with the new fantastic app?

I’ve spent a ton of money and years of time in three houses with smartthings are now all a complete joke. Trying to get things barely working is now a full time job.

Thanks Smartthings, not sure how your programming team sleeps at night knowing how much of a disaster this “upgraded” app is compared to the classic app. +1 for bug fixing job security. All you new users will never know how great it was and will just think THIS is as good as smarthomes get. With New smartthings, Answer is yes until the next time the rug is pulled under our feet.

So sad.

If anyone has a solution to get my 7 button scene controllers back online I’ll happily send you a Starbucks GC

Similar frustration with the ZRC-90, fortunately I only have one of these, now half working thanks to the forum members and many hours trying to get this and my Hue remotes working again.

What is the issue with Samsung and these buttons, I noticed only 2 officially supported devices, Samsungs own button and Aurora AU-A1ZBRC

Yep, last app and Hub update killed mine. As I mentioned above, I got only button 1 to work with the default handler and smart app provided in the mfg’s doc. All the new and updated handlers never allow any buttons to be assigned.

So for now, it’s a single button switch.

Actually, was playing around in the IDE and not sure if when I reselected custom device handler, but all is working again, resent the button programing and back to normal with the factory driver and app. Not sure if ST fixed anything in background, but all good.

When bad, only button 1 worked, all other buttons just flashed fast, now all flash once and work, except for big button just works, no blink on led.

I’ve got eight ZWN-SC7 controllers that stopped working after the new ST “upgrade”.
After removing and adding, the device registers button presses in the RECENTLY section of the app but does not switch on lights as programmed in the ZWN-SC7 Button Controller SmartApp.
I’d be happy to pay $50 to anyone with a solution.

I’m trying to install a ZWN-SC7 into my SmartThings setup. I followed the instructions above (though I created the SmartApp before connecting to the device.) It showed up in the SmartThings iPhone app when I scanned for devices and automatically added (I’ve tried deleting and repairing and the process is sporadic - sometimes the device is added without any notification.) I found no way to “Configure” the device. And when I click on its button in the SmartThings app, it says it can’t connect to the device.

The live logging doesn’t seem to indicate a button press and every button but the top left one makes every LED flash on and off several times. Pressing the top left button causes its LED to flash several times, then stay lit. Pressing it again does the same, always stay lit until I press another button, then all the LEDs flash several times and then all stay solidly lit.

Logging for the top left button press indicates “Parsing 'zw device: 15, command: 2B01, payload: 01 FF '” sometimes.

Logging for the other buttons sporadically gives differing messages/error messages.

Lastly, I noticed that in the ‘Devices’ list in the SmartThings web portal, this device is connected to the hub through another SmartThings device (an outlet.) All the other devices are connected directly to the hub.

@EHarch and @Jack_Cohen

This is a longshot but I tried to update this handler. I don’t have the device and have no way to verify it this update works or not. I’ve updated a lot of other button devices for the new app successfully, but this one is unique and uses older zwave command classes so I’m not sure if it will work.

Try and use it with the original smartapp, and if that doesn’t work, give it a try with the smartlighting app or webcore.

1 Like