ZWN-SC7 Enerwave 7 Button Scene Controller

Hi, I have the ZWN-SC7 Button Controller which has been installed for about a year and half. I am starting to add SmartTiles and an Echo Dot in my apartment. I have one issue with this ZWN-SC7. When I haven’t used it for a few hours I have to push the button I have programed twice. I push it once and wait 1 second and push it again than my lights it is controlling turn on or off. Is there a fix for this? I can’t figure it out. Is it asleep? Am i waking it up it up with the first push and the second I am controlling the lights?

OK folks which Dvice type and Smart App for just ZWN-SC7 on and off of devices?

Any luck with this @jimmay3? I haven’t been able to get this to work either.

I was never able to get the Github integration to work for the Matt’s device handler and smartapp. I wonder if it is because of the manner in which the smartapp and device handler is setup on his GitHub page.

Ultimately it doesn’t prevent the ability to follow the instructions on the beginning of this post and other areas throughout the thread to get the handler to function and get a functional smartapp.

I have three of these scene controllers in my house. I have had an occasional problem with them working but can usually get them back up and running by removing power (turning off the circuit breaker) which restarts the device.

1 Like

@scottashell,
Just to clear up, the Handler works fine, just the Github auto update/notification in IDE fails, works for all my other devices on the list, just not this item (Listed as Green, not in repository). It must just not be entered right, cause it’s the only one different on the pull-down list, see pick…

I’m not suggesting that the Handler isn’t working as it should. I’m suggesting that Matt’s GitHub repository isn’t setup in a way that the handler is able to understand as it is setup differently then other repositories I’ve seen.

1 Like

I have successfully added the code for ZWN-SC7.SmartApp.groovy but cannot add it for ZWN-SC7.DeviceType.groovy. I keep getting the following error messages, i have tried excluding the top lines with the asterisk but it just changed the error message.

when i paste everything this is the error i get

No signature of method: script1486153153841501889250.metadata() is applicable for argument types: (script1486153153841501889250$_run_closure1) values: [script1486153153841501889250$_run_closure1@6af995fd] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

when i exclude the top portion with the asterisks this is what i get

startup failed: script1486153231881332644882.groovy: 1: unexpected token: * @ line 1, column 2. * ZWN-SC7 Enerwave 7 Button Scene Controller ^ 1 error

any and all help is appreciated :confused:

@mattjfrank,

What am I doing wrong with your github integration setup? Keeps coming up green (Not Found)…

I’m not sure but you aren’t the first one to say that. If it helps you can just copy and paste it in, I don’t plan to ever make anymore changes as I havent used the switch since I got alexa.

I tried everything, yours ( mattjfrank:ZWN-SC7 Button Controller) and notoriousbdg:BatteryMonitor I just can’t get to show they are actually comparing/checking.

Hi guys,

A) I was using an older version of this DTH from around March 2016 (whatever was the latest then). Recently I noticed I was getting multiple push events triggered in webCoRE for the same button. IOW I’d push button 1 first and it would receive one push even, and then a 2nd one just a second later. Was that a known issue? I’ve updated to the latest DTH in the Github and that seems to have stopped so that is good, unless this is just a coincidence and the issue will start up again?

B) Also after updating to this version of the DTH I noticed that instead of just a “pushed” trigger in webCoRE, I know have a “held” trigger. That’s great. However I can’t get the trigger to fire for held. I tried holding as long as 10 seconds but it never fired. Can someone explain this capability? Ideally I’d like to define held as being say 1.5 seconds, if its configurable?

C) Is there a way in webCoRE to do something like “if button 7 is pushed TWICE within 2 Seconds THEN”?

Thanks!

Update to my prior post: In some situations I still get two back to back push events on the same key when just pushing it once. Anyone know why?

I currently don’t use one of these, but I did do a lot of work in the past on a software debounce but I believe it was implemented at a SmartApp level for reasons I can’t remember. A couple of my SmartApps have it in there I think. So yes, the double press problem is a known issue.

The device doesn’t support “held” events as far as I know. Not sure why you are seeing those. It would be extremely hard to program the thing you are requesting in C because of the timing of things being processed in the cloud.

i just got this and im unable to get it to connect to my ST Hub. any help would be greatly appreciated.

I’m wondering if anyone experienced hub issues caused by this device?

My zwave devices stopped responding to commands around 6 weeks ago - they were updating/polling correctly, but any commands sent from the app were not executing, eg manually pressing my wall switches updated in the app, but they would not actuate when controlled from the app. Also the hub was not responding to utility commands, eg reboots & network repairs were not showing up in the logs.

I had no choice but to get a new hub and migrate my whole setup, testing each device as I added it in. When I got to transferring the enerwave scene controllers (I have 4) - boom - the hub issues came up again instantly. So I excluded all 4 of them, and voila, everything was fine again.

So how to troubleshoot this? I’ve had these controllers a good 2 years until something must have changed sometime in December - is this a hub firmware change that suddenly stopped playing nice with legacy dth? I’ve been using @mattjfrank DTH. But is it really that this 1 device (or the DTH) can screw up the hub?

Recently I started getting THREE button press events when a button is pressed just one time. I worked around the problem from June of last year (discussed above) by adding a delay and ignoring any button events that happen within 2 seconds of another one. But now that delay is no longer enough. I can increase it to 5 seconds, but this is pretty cludgy. Wondering if there is a better approach here, or perhaps a newer/updated Enerwave 7 zone scene controller. Or perhaps there are now better options in the market that I could replace this with?

I haven’t used the ZWN-SC7 for a long time. They were going to release a follow up 8-button version, but it didn’t make it to market.

Inovelli (who I now work for) has an in-wall solution that we will be releasing in the next few months. So keep an eye on the forums. :slight_smile:

3 Likes

Thanks. The Inovelli website says that some scene controllers will be available within the next week or two. Any pictures of these available? What will be out in the next few months then, if those are coming out any moment? 6, 7, 8 button versions?

Some general questions please:

  1. Will these have their own device type or work of the generic SmartThings device types?

  2. Will these support double-presses? What type of configuration options will there be?

  3. Will it be available in black? I have a black rectangle square face plate, but I’m more concerned about the buttons. Definitely need black in my case. If not available in black, do you think the buttons could be spray painted? I wonder how well that would hold up over time with people pressing the buttons.

  4. Will there be one over-sized button? I really like that about the Enerwave. I use the large button at the bottom as a on/off toggle, and then have the other 6 buttons set up to do various functions via webCORE pistons.

Thank you.

Please start a new thread under connected things to discuss the Inovelli devices. Thanks. :sunglasses:

https://community.smartthings.com/c/devices-integrations/connected-things

2 Likes

When I send configuration to ZWN-SC7 using the custom handlers mattjfrankMatt, it shows in the log to always send the same data/string even if I change the config. It’s sending:

[7204, delay 100, 8505, delay 100, 2D01010100, delay 100, 2D01020200, delay 100, 2D01030300, delay 100, 2D01040400, delay 100, 2D01050500, delay 100, 2D01060600, delay 100, 2D01070700, delay 100]

Of course, then when I click a button on the device nothing happen, also cannot see any trace of the click in the log. Please advice.