ZWN-SC7 Enerwave 7 Button Scene Controller

I can’t read the detailed screenshots, but “unexpected error occurred” usually means one of two things.

One) there’s a known issue with the android mobile app, other people can comment more on that if it applies

Two) there’s database corruption and the cloud and the hub are out of sync. This can happen. The first thing to do is go in through the iDE and see if you get another error there. If you do, make sure that the device has been assigned to a room/location. If the device has been assigned to a room/location, but you’re still getting errors, you just have to report it to support.

Sorry I don’t have a better fix.

1 Like

So I know this won’t help but you might find it interesting.

In Live Logging, each time I get to my error screen in the ap, it shows a list of all my routines, like the code is trying to tell the ap to post a list of my routines so they can be attached to the different buttons.

The list after the tag “trace” is all my routines.

Support ticket opened. (I think). Albeit, isn’t this an unsupported device?

The device isn’t officially supported, but if there’s database corruption they can help you figure that out.

Trying to get all my devices/apps on GitHub Repository Integration, all seem good but this one? Is there something special to add it or?

Support told me it was related to pressing the back button during installation. That was as specific as they would get. Which back button at which time I don’t know.

Tried it again today and no luck. Removed the device, the handler and the smartapp and did over without pressing back at any time. Still just get the error message when you get to the screen where you would assign scenes to buttons.

Frustrating.

I had an awful time getting this thing added to my network. I originally tried to add it while it was hanging out of a switch box about 20 ft. from the hub in another room. After countless interminable iterations of resetting, excluding, and adding (and failing), I finally wired the controller up to a receptacle plug. Once I plugged it into the outlet nearest my hub, I was instantly able to add it. After that I was able to install the thing back at its original location and everything seems good.

Also of note, the controller has a tag on the ground wire which indicates it will not function if not grounded. I have experimentally determined that this, mercifully, is untrue. My house was built in the early 60s and so all of the lighting circuits are ungrounded. (The house also has neutral-less switch loops for all the lights, and while it’s only a moderately huge hassle to replace the 14/2 switch loop with 14/3 to add a conductor for neutral, there’s obviously no legal/correct way to add a ground without rewiring the entire circuit).

HI All,

I’ve scanned and searched the ~650 messages in the forum here and have not quite seen the same issue that I’m having. With lucky someone can point me in the right direction.

Thanks to the developers who wrote this device integration, great to have.

I have two of these installed, one by the front door and one by the rear door. The front work is working perfectly. The rear one is being a pain. The devices look identical in the IDE, fingerprint, numButtons, etc. I’ve programmed the rear one several times and the behavior is the same. Button 1 works, any other button press causes the unit to flash all the buttons. Looking at the live logging in the IDE I can see presses for button 1 and the actions happens. Live Logging does not report any other button presses. I’ve run the z-wave repair to no effect.

Not knowing much about ST device development, I’m assuming I only need the one device handler for both. I’m also assuming that having more then one ZWN-SC7 in the mesh is possible.

Thanks!

It seems as though this is a configuration error.

Basically the Scene Controller is connected to the hub but it is only recognizing a button 1. I’ve this happen and in fact have 3 of these running and have it happen to more than one of them.

Fortunately you should be able to reconfigure the SC7 without having to disconnect and reconnect it from the hub.

To fix it you should be able to press one of the other buttons (I usually press button 7, which is the big one) and then press the configure button (in the app for the scene controller).

I’m not sure I understand completely but from what I can tell this re-sends a configuration request between the device and the hub and usually will get it to recognize the correct number of buttons.

I hope this helps and if it doesn’t work then I hope someone else can help troubleshoot it…

Who is maintaining this DTH now (or is there a newer version I can’t find somewhere?)

The DTH at the top of the thread does not have the debounce I see in some screenshots (not necessary, but weird), AND it does not send events according to specifications. I’d like to fork/help fix it for use in CoRE.

thanks for any and all help!

1 Like

Any luck with this? I’m running into the same thing. I was thinking perhaps I’m using old code…

Nope, no luck. Tried again a few days ago. Going forward, I guess these are dead in the water.

Mine just installed in wall two floors away from hub. If that gives you hope.

The DTH issue I mention wouldn’t affect installation.

Can you please give me a link to the DTH code? I’ll make the adjustments.

Check this post out, @iamjallen complained about it first, and fixed it too… CoRE - Get peer assistance here with setting up Pistons

@ady624 Here’s a link to the Github repository for the DTH for the Enerwave

Scott

@scottashell, @bridaus Can you guys please test https://github.com/ady624/ZWN-SC7-Enerwave-7-Button-Scene-Controller/blob/master/ZWN-SC7.DeviceType.groovy ?

I can’t imagine that’s completely true - enough people are posting here about having gotten it working recently that I’m sure it’s still possible.

The debounce was added because this device has a tendency to send double button presses. When people have a “toggle” action setup on a button press, it used to turn the light on and then off with a single “physical” press of the button. If you are not toggling things then it doesn’t matter.

Maybe Enerwave fixed that issue, but it was a huge problem for this device in the past.

1 Like

the problem I’m having is adding the smartapp - the device itself seemed to have installed successfully but every time I try to add an app it says " “Sorry, an expected error has occurred” - exact same behavior as checkthisout’s

I found this on the github for the smartapp:

it looks like we can fix this by deleting the null phrase - now…HOW does one delete a null phrase!?