ZWN-SC7 Enerwave 7 Button Scene Controller

Bingo… That did it … I now have a new device.
I updated my controller to ZWN-SC7 Enerwave 7 Button Scene Controller .
Installed new smartapp & everything working well

Hats off to both beckwith & bravenel… Thank you kindly

1 question… In the configureation screen under advanced … It shows "Debounce time in milliseconds"
Should I do anything there ? or a better question… What does it do ?

1 Like

The default debounce will probably be just fine. Over time, SmartThings seems to change something in the infrastructure that affects timing and at times you may have to tweak this if multiple button presses get lost.

Great … can’t thank you enough :slight_smile:

Have this ZWN-SC7 controller working great… Thanks to all that helped.

I have an issue when I try to program my second ZWN-SC7 controller. When I try to configure it, the first ZWN-SXC7 gets overwritten. Do I need individual smartapps to run both of these units.

Yes the sc7 smartapp seems to just control one sc7…at least in my house. You would need multiple smartapps to control all of them…like RM does. At the moment I am using RM for them as well but it results in a lot of rules!

Thanks for your input Sean… You say a lot of rules using RM. … That is pretty much the last thing I would like “Lots of Rules” :slight_smile: … especially since I know nothing about RM.

The one unit I have running works well so far using the mattjfrank smartapp… I was hoping to incorporate the second unit and am looking for the easiest way to accomplish that.

Anyone have some suggestions.

At the moment I have tried installing another Device handler … ““mattjfrank : ZWN-SC7 Enerwave 7 Button Scene Controller”” for a total of 2 of these.

Also I have installed another Smartapp … ““mattjfrank : ZWN-SC7 Button Controller”” for a total of 2 of these.

When I try to configure the second controller, it does program just fine… but it disables the first original controller.

Surely there must be a way of having multiple controllers incorporated into this system but I just don’t know what I should try next to get them both working.

Help … Please

Hi Brian,

To use multiple SC7 devices you will have to add other copies of the smartapp but change the name of the app in the code. I have named my apps Foyer SC1, Living Room SC7 etc. This works for me. Hope this helps out.

1 Like

Sean

Helped immensely… Got them both going now … working like a charm
Thank you very much…

Quick question though… You mentioned using RM also. Is there any advantage to using it for this application ?

Brian

Rule Machine allows you to do a LOT more with the buttons. If you just need to turn on/off lights the basic app works fine. I’ve modified it a bit to add dimming etc. I use RM for all my other tasks but didn’t like having to scroll through like over 50 rules for buttons.

I’m still using Button Controller+ for most of my button driven automations for exactly this reason. It can be done in RM, but with 7 rules vs 1 instance of the app. The only ones I do in RM are ones that need to be in RM because they call some other Rule.

1 Like

I just want to thank Matt for his hard work on this, I love being able to use this to control phrases, toggle switches, and all kinds of things. Thanks again! Multiple switches is what I’ll be working on doing next. Nice to have a 7 button switch that you can use from multiple rooms to manipulate several functions. Why isn’t thing in the official marketplace yet!

1 Like

That’s just how the SmartThings architecture works. If you want to have two button controllers, whether it’s the SC7, a minimote, the SmartenIT toggle 3, or whichever, you have to install one copy of the smartapp for each individual device.

I just installed my SC7 tonight. Had a bit of a rough time pairing it with the hub. I actually had to move the hub closer to the switch temporarily. Once it was added, I added the SC7 SmartApp and started programming it.

Button 1 I set to toggle a GE switch. button 2 I set to toggle a Hue Bulb. I only programmed those two and hit Done. Button 1 works without issue. I hit button two, and all of the lights turn on and blink. Nothing happens with the Hue Bulb. I have tried reprogramming it via the Smart App and am not having any luck.

Has anyone seen this?

Note to new users, this is normal for initial pairing, especially if the unit is in a metal box/enclosure has to go thru several walls or blockages. Once up and running, the zwave mess will echo and help the device. Either move device closer or pair prior to stuffing in the box.

Thanks for confirmation on the setup. Any idea on why only one of the seven buttons work, though?

I have six of the controllers that work fine and one that behaves exactly like you describe. I have been too busy fixing automations/etc to look into it. If i have any luck I will let you know.

I just had the same exact thing happen to me. Do a couple of things. In your ST app open the SC7 under things, then at the top go to smartapps. Make sure you only have 1 version of the settings running. After that go back to the “Right Now” tab at the top and tap on “configure” on the right. This worked for me and caused ST to register the other 6 buttons.

Now, for the issue I am having and can’t seem to figure out. I saw mention of this way earlier in the discussions but then it seems like it went away for everyone. I am using toggle in order to maximize the use of these buttons. So here is may layout.
Buttons:
1: Toggle Dining room chandelier and sconces
2: Toggle Kitchen main and secondary lights
3: Toggle Living Room Display case lights
4: Good Morning Routine
5: Unlock front door (no toggle option for this, wish there were)
6: Lock front door (no toggle option for this, wish there were)
7: Open Living Room Motorized Blinds

Any button utilizing the toggle command will register 2 or 3 times when I watch the notifications feed, thus making them useless. I am OK with the few second lag at times, but is there any way to improve the toggle accuracy?

Thanks!

Usually just need to hit the “configure” button on the device screen and it will resend the config data to the device, may take a few tries… If only a button 1 issue, then you do not have a paring issue. The device handler used to automatically run the config script, but I recall last time I had to hit the button too, so something has changed…

The SmartApp has a software debounce in it to prevent the button presses from registering multiple times. Even though they show up multiple times in the notification feed, the SmartApp will filter them correctly. Just make sure you are using the debounce version of the app and you should be fine.