SmartThings Community

ZWave range poor compared with Zigbee

(Tim) #1

I have a ST door sensor and motion sensor in the garage and thought it would be nice to add some automation for the lights. Motion detected - lights on and then off after a period of inactivity. I bought an Aeon switch as it is listed as compatible. I rigged up some temporary power to pair the device, which worked ok. I connected it to the garage lights and it won’t work as it seems to be out of range. However, the ST door sensor is within 20 cm of the Aeon switch and that works fine. So, are Zigbee devices going to perform better at greater ranges from the hub than Zwave? Distance is about 15m.

0 Likes

#2

You have to be more specific on what you mean here. Why did you need “temporary power”. I’m pretty sure all switches require permanent power.

0 Likes

#3

Zigbee and classic Z wave have very similar ranges. Zwave plus is somewhat longer in range.

The usual issue is not the range of an individual device through clear air, but the number of local architectural obstacles and how many devices of the exact same protocol are available to pass the message along. Sometimes it’s a matter of a very specific obstacle and just moving a device two feet to the left will give it a clear signal again.

Since zigbee repeats only for zigbee, and the zwave only for Z wave, one person might have a set up with two switches and three motion sensors where the Z wave worked very well and the Zigbee didn’t, while another had a set up also with two switches and three motion sensors where the Z wave didn’t work at all but zigbee did, just depending on The message routes available for each protocol in that particular home.

One of the advantages of SmartThings is is that it can support both zigbee and zwave, but it does mean you have to be a little more conscious about where individual devices go.

Also, Zigbee is in the same band as Bluetooth and Wi-Fi, while zwave is in a different part of the spectrum. So Zigbee may get interference from Wi-Fi, while zwave would not. however, zwave could get interference from an old-style cordless phone or a Baby Monitor while Zigbee would not.

(All of the above is true whether we are talking about the UK or the US. The 2 Z Wave bands for the different regions are still quite close to each other.)

Garages and basements are notorious for being the most difficult rooms to get signal in and out of. Lots of concrete lots of metal, metal in different places depending on whether cars are present or not, all that.

The following FAQs may be of interest.

The first one generally discusses issues of range and the use of repeaters to improve signal transmission throughout the home.

The second one discusses zwave as compared to zigbee. This is from the community created wiki, which is very new, but hopefully will prove helpful.

http://thingsthataresmart.wiki/index.php?title=Z-wave_versus_Zigbee

0 Likes

(Tim) #4

To ensure a device pairs successfully, I believe it is a good idea to place it as close to the hub as possible during this procedure. For that reason only, I supplied 240v mains via a 13 A plug to the device just to power it during the pairing process. I disconnected it form the temporary mains supply, once paired and working, and then I disturbed the lighting circuit in the garage. I then conncted the switch into the lighting circuit, in its final position. I stood in the garage and operated the switch in ST to see if it would switch the lights on and off and it didn’t. The LED was flashing on the Zwave switch so I knew it was powered correctly. Operating the switch via ST, I could not hear the relays click over. I took the device out of circuit and reconnected it to my temporary mains lead again and then proceeded to walk around with the switch until it operated, which in this case was about 3 m away from where its final position would be. So in short, it’s out of range! I can’t be much more specific than that. To mitigate this I need to either knock down the garage and build it closer to the house or buy another z wave mains powered device that will repeat the z wave signals. The ideal spot would be half way between the hub and the new switch, however, that would mean the repeater is outside.
This brings me back to my original question. If two battery powered Zigbee sensors can operate successfully in the same location and at the same distance away from the hub then why can’t a mains powered Zwave device do the same.

0 Likes

#5

Although the SmartThings hub is one plastic case it actually has two completely separate controllers in it, one for Zwave, and one for Zigbee. So you are running two separate networks off your one SmartThings account. One for Zigbee, one for zwave.

If you’ve had a chance to look at the range FAQ, you’ll see that it shows you how the antennas are placed inside the case. They’re 90° to each other. So the signal from your hub is actually going out in two different directions, one for zwave, one for Zigbee.

So generally it helps to just think of them as two separate networks. If one of them is working, that’s great. If one of them is not working, work on that one and don’t worry about what the other one is doing

Could be any of many things. Including the exact position of the mains-powered zero device. Is it inside the wall? If so, there can be blocking materials between it and the hub. Is it inside a switch box? If so, that typically blocks signal in every direction except straight out. In some cases, people have to change the material of the front plate cover on the switchbox to let the signal get through.

What other devices do you have that are Zwave between this device and the hub?

1 Like

#6

Regarding where to have devices when you pair them:

With the older generations of Z wave, it was important to have them very close to the hub at Pairing. This is also true now for devices which pair in “secure mode”, generally door locks.

With Z wave plus, the newest generation, other devices can be paired “In place,” and this is generally the best idea.

However, if you do pair right next to the hub, that’s fine. After you then physically move it to its working location, you need to do a “Zwave repair” to make sure that it knows who it’s true neighbors are. This is a system utility. It is also covered in the range FAQ.

1 Like

(Tim) #7

I only have one other ZWave (not ZWave plus) device connected and that is a Fibaro dual relay to control the boiler On/Off , timer Enable/disable. It’s location won’t help the situation of poor reception in the garage.
I guess I’ll have to experiment with hub orientation to see if I can improve the situation. At the moment, the hub is as physically close to the garage as possible and only has one external cavity wall before free space to the detached garage. The location of the Zwave device is at the back of the garage where the side entrance is and the garage light switch. I could extend the wiring so that the device is located near to the front of the garage because from a walk round tests, it operates towards the front of the garage. A Zigbee device with the same functionality would probably work.
Anyhow, thanks for your reply.

1 Like

#8

My understanding from a teardown post that a community member did is that the antenna placement for the V2 hub is reversed from that of the V1 diagram in the range FAQ, but you can confirm that with support if necessary.

Let us know how it works out.

Here are the instructions for the Z wave repair in case you need those:

1 Like

(Tim) #9

After placing the hub in various orientations I came to the conclusion it’s probably got nothing to do with where I put the hub, more like poor reception from the Aeon Labs device. Without any modifications to the Zwave network, the only position I could get the switch to activate was at the front of the garage. This was not ideal as it would mean running some remote wiring to the device from the switch, 5 wires in total. This got me thinking that the switch has a very short antenna, so could this be improved. I attached a length of wire to the end and that seems to have done the trick. Back to basics- increase the size of the antenna if reception is poor!
This may not work in all situations, especially where it is not possible to have a piece of wire exiting a surface mount light switch. However, it’s in the garage so no problem.

1 Like

(John Rucker) #10

I think you just got lucky by attaching a “length of wire” to your antenna. A proper antenna has to be a specific length based on the wavelength and the impedance needs to be tuned to the radio’s output. I wouldn’t be surprised if the problem reappears fairly soon.

0 Likes

(Tim) #11

I realise I took a rather simplistic view by attaching a short length of wire and yes you are correct about the antenna being the correct length for the wavelength and it needs to be impedance matched. For full wave at the Zwave frequency (nearly 900MHz) it is approx 30 cm. The antenna on the switch must be 1/4 wave given its length. There must be some significant interference to reduce the range to 8 m but Zwave protocol does not mitigate interference quite as well as Zigbee and my Zigbee setup is not suffering the same.
I must have been lucky but it has helped and only time will tell. However, the alternative solution of installing repeaters outdoors, LV powered and IP 66 rated did not appeal.

2 Likes