Zwave Motion Sensors... not on edge yet?

I have 2x Ecolink PIR-ZWAVE2 motion sensors and 2x Enerwave ZWN-BPC ceiling mounted motion sensors. These 4x devices appear to be the only non-Wifi devices I have left that are not on new edge drivers. I’ve tried removing them and readding them to no avail. In Graph API they show up using the Zwave Motion Sensor DTH.

Anyone know what’s going on with these? Maybe they still need to get transitioned? Or are these devices perhaps incompatible? Or do I need to do something different?

Thank you!

It should be covered by the following Edge driver:

Note: after removing the device, you would need to remove any custom device handlers in IDE if that is what it grabbing. Then you should be able to pair to the Edge driver… and select Scan under Add device and not By Brand


Thank you!

When I first attempted to re-add this device (in an effort to get an edge driver), it does indeed grab a custom DTH: Enerwave Ceiling Mounted Motion Sensor by Adam Heinmiller. Since re-adding these devices, I’ve then had to go into Graph API and manually change it to Zwave Motion Sensor for better functionality.

I’ve just logged in to Graph API. I successfully deleted a different custom DTH, but not this one, as it gives this error:

could not delete: [physicalgraph.device.JoinFingerprint#1100982]; SQL [delete from join_fingerprint where id=? and version=?]; constraint [null]; nested exception is org.hibernate.exception.ConstraintViolationException: could not delete: [physicalgraph.device.JoinFingerprint#1100982]

No device is currently assigned to it though.

Any thoughts how to forcefully delete this DTH?

I see your note now after rereading… tomorrow I will remove all four sensors from ST, then attempt to delete the device handler. If that doesn’t work, I’ll reboot my v2 hub, then try again. I’ll report back

Thank you @jkp, your procedure worked perfectly.

To be clear for others that may come read this:
my older motion sensors were not on the new edge drivers, and my attempts to remove and re-add them didn’t work either. Turns out they were latching onto a custom device type handler (DTH) that will no longer be able to work under the new platform. Couldn’t remove this DTH either, since, though I had changed my motion sensors’ device type in the soon-to-be-defunct graphapi groovy ST website, it was still somehow latched to that custom DTH.

So, to resolve this, I:

  1. went to each motion sensor I had and removed them all from ST
  2. went into groovy graphapi website and only then could I successfully delete the custom DTH I had for motion sensors
  3. re-added each motion sensor using the app, select Add Device, Scan for Nearby Devices, then clicked the button on the device (or removed and replaced the battery for one of the motion sensor types) to get it to register while the app/hub did the scan.
  4. some took a few repetitions for step 3 to get to register again
  5. all, following this process, registered with a new edge driver afterwards, as made apparent by the fact that I could see the driver listed on the menu for each device in the app

Hope this step by step helps another!

Thank you again @jkp for getting me here!


So I guess the answer to removing the unwanted DTH is to actually fully remove any devices from ST that ever used it! Wow! Thanks for doing the research and writing it up!

1 Like

I’m not savvy enough with coding to help many folks here with their questions, but when i successfully troubleshoot, i figure this is my one small contribution to this community to share what worked for me. Glad if it can help someone!


Has anyone had success connecting Ecolink PIR-ZWAVE2 motion sensors with the PH drivers or any other? I cannot get it to report motion with the PH drivers.

Not I. But… the motion sensor doesn’t seem to appear on the list of supported devices.

This driver doesn’t support Ecolink motion sensors. I’m not sure why you’d think it would? Theres a specific list of Ecolink devices it supports:

I’m happy to consider adding support, but I don’t have a PIR-ZWAVE2 to test with, and other drivers are currently in process.