Zwave light switch unavailable

I had same issue. Updating device in IDE fixes the issue. Just open device and click update, do not change anything.

1 Like

Just turn off the device health in the app for now if you have your devices automated. Seem to work for me.

I’ve been having this problem for a week but the st app wasn’t aware (they showed offline in echo though, as they still do)

I think the firmware update did it, and really hope it’s fixed soon

I’ve turned off device health, it says it’s online now but can’t control the switch still thru the app

Reset the device…

I had the same problem. I tried everything from the ST interface, but had no luck. My issue came about after installing several more switches. Then the device became unavailable. What solved it for me was resetting the device by taking it out of the wall and removing the power; the neutral wire. Once I “reset” the device it has been working without issue.

Hope this helps.

Once a network problem occurs with a GE zwave switch, you often have to do a hard reset by cutting power at the circuit breaker and then restoring it. Not just using the air-gap. This is the only brand I know of that has this problem. Obviously you could get the same effect by removing the neutral and reattaching it.

Doesn’t mean that has anything to do with what caused the original problem that you’re seeing, but it is something to know if you have GE switches and you run into a problem that then you don’t seem to be able to fix.

It’s not just the GE switches. I have 3 different brands of Zwave switches including GE and i saw this issue with all of them randomly.

First it happened with a GE switch which had automation. The automation worked fine but i was not able to control it via the phone. When i excluded the switch and readded it back again it worked fine.

I started seeing different brand of switch unavailable now and turned off “Device health” as suggested above. and did a refresh and my switches are working good again.

1 Like

To clarify, I’m not saying that only GE switches have the original offline problem, just that sometimes GE switches require a hard reset that the other brands don’t after a problem occurs.

1 Like

This is very true. I have many z-wave switches but GE/Jasco is the only brand that required a hard reset to add it back most of the time. With unavailable issue we are having and GE/Jasco random drop-off. It’s very confusing so I usually do a replace with GE.


Turning off device health instantly fixed it for me. Thank you so much!!! This has been driving me crazy!!!

Just had every Z-Wave device go unavailable (about 25 different devices mostly switches & relays). No luck on any of the solutions mentioned on the thread, including, disabling device health, power cycling hub, physical reset and shutting down every breaker in the house, z-wave repair, IDE updates, and don’t really want to attempt to remove and re-add (it’s a ton of rules).

All zwave devices show failed to update mesh info.

Update: the majority of my zwave motion and door sensors are also not responsive. Oddly the front door is still somewhat responsive (and it’s further from the hub than most) But a good 15 other motion/door are not.

Any ideas?

Adding this to another post as well, as I’m hoping someone else finds this as useful as I did…

I reached out to support and they helped me resolve my issue. Below were the exact steps. Took several tries, but everything is working now without having to delete any devices or rules. Note that per the steps below, it doesn’t actually add any devices in the “add a new thing screen” and the add device screen won’t update, it will continue to pinwheel and say looking for devices, but the already added device came back online for me after power cycling a few times. Hope this helps someone else!

Here are the steps:

"What I am going to have you do for any future and current offline devices is to perform a “rejoin” of the device. A rejoin basically tells the device to look for the best possible connection for that one device as opposed to the “z-wave network repair” which tells all devices to look. I wouldn’t do any more repairs at this point as that resets all the connections that this rejoin will repair.

Here is how to do a rejoin of offline or non-working z-wave devices:

First, put the Hub in inclusion mode. Do this by tapping on the “My Home” tab, going to the bottom of the “things” list, and then tapping on “add a thing”. While it is in this “looking for devices” screen, go to step 2.
On any device that is offline, please simply switch it on and off a few times. Start with the devices that are closest to the Hub first. This should get the device to show up again as online and should get it to find a new connection point to the Z-wave network. Please repeat this for any devices that fall offline or do not respond to commands. Make sure to not do a Z-wave network repair as it will break these new connections. Once finished rejoining a device, exit the “add a thing” screen and see if the device responds and is online after about 20 seconds. Note: you will not see any devices getting added on this “looking for devices” screen, it is simply used for getting the Hub in the right mode.
Go ahead and try that out for any of your offline or non-responding devices and let me know if you are having issues getting them back online."


This solved it for me. Thanks.

Let me get this straight… While the SmartThings hub is looking for new things, I turn the light switch on and off a couple times, right? Not the breaker to the switch itself?

Should the app give me any indication that it has built a new path for the switch? Or do I just do it a couple times then exit the “Add new things” search and assume it’s good to go?

The reason I ask is that when my switches randomly become unavailable/offline/not responding, every few days, usually just turning the switch on or off at the wall is enough to make it start responding to the app again, but they go non-responsive again in a few days.

I just can’t get my head around a home AUTOMATION/CONVENIENCE device that requires me to screw around with it every few days. That’s the opposite of automated or convenient. LOL.


I am experiencing the same issue with one of my new GE Zwave-Plus switches. The switch randomly becomes unavailable and a tap of wall switch brings it back to life. I have tried all of the troubleshooting and nothing permanently fixes the issue. I also have two other GE switches that never have an issue, Like Jesse17 said,
just can’t get my head around a home AUTOMATION/CONVENIENCE device that requires me to screw around with it every few days. That’s the opposite of automated or convenient. LOL

I’m having this issue as well with Multiple devices

1 Like

thanks, that indeed did the trick.

Just wanted to add my feedback. Doing the general device exclusion, then doing the “replace” also fixed my issue. Thanks!

I had a simlar issue with a GE Byjasco motion switch. With this custom device handler Jasco/GE Motion Switch 26931

I have a few of these switches using this same device handler but haven’t seen this problem with them.

I’m assuming something went wrong with a firmware upgrade.
Because this device was labeled with Device ID 11, found on my hubs website, but in the log i noticed alot of traffic from a device ID 33. so i went looking for it in the My Devices menu, but couldn’t find it. So I decided to run an exclusion and turned my Unavailable motion switch on off. I noticed that Device ID 33 was excluded. Then I rejoined the Motion switch, works fine now.

So to me this looks like a firmware upgrade somehow got this device assigned a new Device ID, but smartthigns saw it as a different Device ID, giving it an unavailable status.

I had a similar issue with a Lutron light switch. Flipping device health off and back on seemed to fix it.