Zwave devices showing only “Unknown action” in scenes/automations

Since the app change I’ve managed to muddle along - frustrated that I’ve lost a lot of functionality through webcore, but just about working around it. Now something has really changed.
When I go to existing scenes/automations many of my zwave devices cannot be edited and show “Unknown action”
When trying to set up a new scene they don’t even show in the list of devices.

Has something changed and how can I fix.
NB the devices themselves (fibaro dimmers, zw wall plugs etc) all show on the normal device list, all work and the scenes work. It’s just I can’t set up anything new.

Reach out to Smartthings support. I had an issue where all of my devices disappeared from any automation actions. They had to “refresh the backend database” for everything to show up.

I have noticed this problem today.

Also for a new automations lots of devices are missing from the list of things I can turn on/off or set as a condition.

I’ve tried rebooting my hub (v3) and doesn’t help.

So I’m assuming lots of people probably are having this!

Did you reach support and did they help!?

I’ve emailed them but not had a reply yet. If nothing today I’ll call them.

So you can’t call them.
I’ve now had three replies from Customer support. Each one asks me to fill out another ticket.
Some of my ZWave devices are now not connecting. Have run ZW repair repeatedly and keep getting “Could not delete old routes”/“could not assign new route”
Something has gone wrong - I wonder if they have started messing with device handler functionality and that’s screwing things.
If I had more confidence in my coding etc I’d be getting HomeAssistant TBQFH.

I am having the same issue … has anyone found a fix for this. This is only effecting my fibaro controller for the kitchen lights

Not for me. To be honest I’ve given up and started using homebridge to link my ST devices into HomeKit. Not convinced it’s any better but it’s working ok so far.
It must be something to do with device handlers but Customer Service seem clueless.

I’ve just noticed the same problem. Many of my scenes have disappeared from the IOS app, and when I went to create some replacements I find most of the necessary devices are not shown in the scene creator since they have “unknown actions” listed. WTF! Anyone get a fix for this from support?

Its just one thing after another with the new app. Haven’t they hear of running regressions before deploying sw “fixes”? Can’t wait for the groovy sunset with will surely force me to move to a different solution.

1 Like

I’m also having the same issue. A lot of devices don’t initially show up as choosable in the automation menu, but eventually most do (not sure why it takes like 15 minutes for them to eventually show up though)

But many of my devices still don’t show up in any automation menu (particularly my hue lights and Bond fans). I still have automations from before this problem that use the lights and fans and they continue to work, but in the automation settings, their action shows “unknown action.”

Everything was working a month or so ago. Anyone have a fix?

FWIW support emailed me that it is a known issue they are working on but no ETA for a fix. More support tickets if you haven’t already might encourage an earlier fix.

Just emailed support myself. I have probably 50 devices that are not being displayed and have an unknown action in my exiting scenes/automations!

A fix for this was released this week. Let me know if you are still seeing issues.

I’m still seeing the issue. My Cielo Breez Plus controller showed unknown action in my automations just now. Once I powered it on from the main SmartThings page it fixed the automations. Obviously that’s not ideal since it defeats the whole purpose of an automation if I have to trigger the device manually.

Just checked mine, something has changed but I’m still seeing issues.

My previously “missing” scenes have returned. But if I attempt creating a new scene I only get a small subset of my devices shown, presumably since the others are still tagged with “unknown actions”. And oddly, each time I attempt a new scene creation it seems to give me a different number of devices for actions. Finally, if I open for edit some of my “returned” scenes they show several devices with “unknown actions” in their action list. If I execute these scenes they do seem to work.

It’s still exactly the same for me. No fix yet.

I’m heartened to see others reporting this issue! If, when looking at my automations, I see a device with “unknown action”, then I know that I should not remove it. If I do, it will not show up in the list and will not be able to be added back again! This has proven to be true every time. The same applies for “unknown condition”, which I’ve also seen. Automations which already existed, work fine still.

I’m increasingly moving my time related automations to my linux system, using crontab and the smartthings api.

I’ll write a note to support and maybe yet another voice will help push them to fix this increasingly annoying problem!

Still not working…

It happened to me again just now and this time every device was broken. I couldn’t even specify “Device status” as a trigger for anything in a conditional. The option was completely absent from the menu. I restarted the app and a handful of them came back after a delay but most are still borked and the device status trigger only shows a few devices as options. Seriously considering abandoning “smart” things at this point.

This is occurring for me also. None of my automations are working, because they all look like this:

I also cannot create a new automation based on a device status. “Device Status” itself is grayed out. Is ST Support any help? Or is this a known issue we just need to wait for a fix on?

Hi, I’ve been having this same issue (noticed it in January).

  • Scenes show “Unknown Action” for devices
  • Devices don’t show up when trying to create a new Scene, so it’s effectively broken

I’ve been emailing Support and they said on 21 April:

“this is a known issue on iOS and this should be resolved in the next app update which we are expecting in the next few days”

Just checking to see if anyone here has found a solution or workaround? Will doing a factory reset and reconfiguring everything from scratch solve this issue?