ZW5 Lumens Signal


(Brian) #1

How can i change the default signal of the ZW5 in smartthings app to display lux value instead of tampered?


(Jimmy) #2

I assume you’re referring to the Fibaro motion sensor ZW5? Which device handler are you using?


(Brian) #3

How do I find that out? I added the device in the ST app. Here’s a snapshot of the dashboard.


(Jimmy) #4

Have you tried opening the battery cover and closing it back?


(Brian) #5

I haven’t but what should the default signal show? I realize the device can report lux, motion, tamper, temp. But how do I get lux to appear as the default in the ST app dashboard?


(Jimmy) #6

According to the default handler below, the primary is motion and tamper is secondary


(Brian) #7

which leads me to my original question, how can i get the lux value to display in the dashboard instead of tamper status? Do you know what i mean?


(Melinda Little) #8

In IDE, edit device handler code. On line 79, change 'main “FGMS” to 'mail “illuminance”. illuminance is the name of the lux tile. The main option indicates which one displays on the Things page. This should do what you are looking for. This is based on using the above posted device handler.

Update - I have the same device, primarily for lux reporting. So this was a great idea I could use. Updated my DH, now reporting lux! Thanks for the idea!!


(Brian) #9

@mellit7 I don’t have the device in ‘my device handlers’. I sync the device in ST app on ipad.


(Melinda Little) #10

I had to install the device handler code (posted above), in order for my device to work correctly. This is done through the website portal referred to as the IDE. It is not on your ipad app. If you didn’t have to do this, (which is possible, I’ve had mine a while), then it is a bit more complicated to make the change, and more involved than I can explain here. There is documentation that explains how to use the IDE and install custom device handlers. The code defines what is displayed on your ipad. The only way to change what is displayed is through a change to the code in the IDE. Sorry I’m not more help.


(Brian) #11

I published the code, it has the same DTH name as the standard type that comes with ST. First picture is of the current type, the second screenshot is the custom code…same name but appears at the bottom.

Fibaro_Motion_Sensor_ZW5_custom


(Melinda Little) #12

Oops, just reread your question. One at bottom is your version. Your handlers are always listed at the bottom.

Try using the self published option under version.

Or if that doesn’t work, change line 17, the name parameter, add your initials or something. This will make it obvious which one to select.


(Brian) #13

Appended ‘v2’ to the name on line 17 as suggested, it appears at the bottom of the type list. that helps distinguish. I’ll test later, good post, thanks for the help.


(Brian) #14

good call, lux is showing as the default signal in the dashboard.