ZOOZ ZEN72 Problems adding to S/T

Hello, I just added two ZEN72s to Smartthings. When ST added the device, I received a message saying it could not be added securely. I could skip this, but ST said some features are unavailable. The switch works, but when I open the device in ST, I receive a message that says, “This device hasn’t updated all of its status information yet. Check again later.” Also, I wanted to add these two devices to Google Home, and when I reconnect ST to it, these devices aren’t added. Does anyone have any suggestions as to how I can resolve that message and get the devices added to Google Home?

Need to know a little bit more info to point you in the right direction. Is there a reason you skipped the security rather than installing it with it?

Do you know if your devices installed with an Edge or a legacy DTH driver? If a legacy, we need to figure out why. If it installed with an Edge, please install the ST CLI and use the command “smartthings edge:drivers:logcat --hub-address=xx.xx.xx.xx” to get logging info from the driver for that device.

Yes, the reason is that when I scanned the QR-Code, ST said the device was not supported.

I do not know how to check if my devices are with an Edge or Legacy driver. How do I check this?

Easiest way is to click on the 3-dot menu on the device panel and see if you have a Driver option listed.

It says “Zooz Edge Drivers.” When you say " please install the ST CLI and use the command “smartthings edge:drivers:logcat --hub-address=xx.xx.xx.xx” to get logging info from the driver for that device." what do you mean using the command? I’ve never done this, so, where am I entering this command?

What channel is listed in the info about the driver? SmartThings or something else?

The ST CLI is a command line tool to interact with your hub. You install it on a computer (Linux/Mac/Windows) and then from a shell/command window use it to manage various aspects of your hub as well as get device, logging information, etc.

btw, all my legacy devices don’t have the “Drivers” information like these do. Should they?

So, eventually all the legacy devices will be migrated to Edge drivers by the ST team. Best to wait for that to happen because to manually switch them out you have to exclude/include them again and it can/will mess up your routines.

So, you have the community developed Zooz Edge driver which is good. If you added your devices by doing a Scan Nearby, I would exclude the devices and instead add them via the QR code. If you used the QR code to add them, we’re gonna need to get the logging info on what is happening when accessing the device’s panel.

Thanks, when I enter this command, “smartthings edge:drivers:logcat --hub-address=xx.xx.xx.xx” I assume you’ll want me to enter the actual hub address? If yes, how do I obtain that?

If you have a v2/v3/Aeotec hub, I don’t believe there is a way to see it in the app, but I don’t have one of those hubs. If you are familiar with using the legacy IDE website, I know it is listed there.

I do have access to the legacy IDE. I am signed in now and have ran the command. I assume after I re-add them with QR Code, it will create a log file? Where do I find this log so that I can upload it here?

You’ll want to be logging for the Zooz driver when you add the device. Once you’ve got it successfully added, then you’ll want to be logging while you access the device panel. If it gives you the message about “not updated all its…”, pull down on the device panel to refresh the device. Do that a few times. Once you have the logging info collected, cut and paste it into this thread using </> pre-formatted text option.

Where do I find the device panel? Do you mean to open the device on my phone somewhere?

That’s the panel that opens when you click on the device in the ST app.

okay, this time, I did not get that error, but, it’s stuck on a screen that says “Preparing”

Did you exclude the switch before re-adding it? How close to the hub is the switch? Is there any indicator on the switch that would show whether it succeeded or failed pairing?

Yes, I excluded it. The hub is 7 feet away from the switch. No other indicators.

I had trouble pairing my lock using S2 security unless it was literally right next next to my hub. Not sure what to tell you beyond that.

Locks include/exclude using a “whisper” mode with a much lower signal level on purpose. That way they are less likely to be picked up by a nefarious listening device during pairing.