Zigbee device issue

Hi. I have had several Centralite Zigbee in-wall light switches working perfectly in my house since day one of buying my ST hub. Yesterday, I added 2 new switches. Prior to pairing they worked fine. I could press the switches and the lights connected to them would turn on and off as expected. This morning, I paired both switches to the ST hub and after pairing them, only one would still allow me to press the switch to control the lights. They both paired fine and could be controlled via the ST app, but one was not able to be controlled manually (physical button press) any longer. If i defaulted the switch in question I’d regain manual control again. Pair it, lose control except through the app.

Sooooo, I figured maybe something was funny with that switch and I swapped it for another one I had. This time, the replacement switch worked manually AND through the app. I figured, problem solved! Not so much…about an hour later my daughter asked why the hall light switch stopped working (this one has been in since day 1 with no troubles). Sure enough, no manual control, but app control. So basically, I killed manual control of that switch by pairing the other!?

After some digging online I found someone else in a different HA solution had the same issue. Support for that product suggested “deleting the binding for that switch.” The customer stated they did and got it to start working again.

My question is, a)why did the first switch struggle with manual control, (b) why was the replacement able to pair and work as expected, and © why did pairing that replacement switch cause the hall light switch to fail for manual control? For what it’s worth, I was able to swap THAT switch for another one which paired and worked manually and through the app but THEN another Zigbee switch stopped manual control! Why are these switches knocking out other ones that were previously working perfectly?! Thanks!

If I had to guess, I would guess that the switches are confused and think they’re waiting for an over the air firmware update which is never going to come.

This would be because of a recent change to how SmartThings handles zigbee. The hub now broadcasts a message that it is capable of doing over the air firmware updates, even though it will only do them for a couple of SmartThings-branded devices.

This message in and of itself is causing some of the others zigbee devices on the network to start doing strange things.

Definitely report it to support.

You can read about the issues in the following thread:

Thanks for your reply! I just disabled OTA updates on the hub. Time to test again. Either way, I’ll report it tomorrow. @Tyler and @Aaron from support… heads up on this.

@JDRoberts this was not the issue. I defaulted and removed the switch from ST again to be sure I had local control (which I did), then paired it again to ST hub after disabling OTA…still no joy.

It may still be related to the update. A lot of different weird zigbee problems have occurred, including failures during pairing new devices. Hopefully support will be able to help.

After you turned off OTA, did you take the hub off of power (including removing the batteries) and leave it off power for at least 20 minutes while leaving your other zigbee devices on power? That’s also mentioned in the thread that I linked to. That will force the heal of your zigbee network and a re-sync with the cloud account. Some people have been able to successfully pair new zigbee devices after completing this process.

I was having a problem with zigbee devices falling off after the new firmware update. I did a 30 minute reboot previously and saw no improvement. Just tried again with OTA disabled and still no luck. Will I need to go and replace these or delete+re-add, or can I hope that they will come back on their own? How long till the repair kicks in and completes?

Yes. I just tried this. No luck. Unplugged and removed batts for 35 minutes, deleted the switches in IDE, defaulted them, re-paired, no local control!

OK, that’s very strange. I’d definitely talk to support. The only thing I can say is that unfortunately you are not alone – – there are a number of people reporting ongoing problems since the last zigbee update.

One small thing when you do talk to support, that may save you some time…

In smartthings, “local operation” has a very specific meaning, which is that the code is running just on the smartthings hub, and not in the smartthings cloud. You’ll find a lot of conversations about cloud operation versus local operation.

What you are describing as “local,” which means pushing a button on the device, is referred to in the smartthings environment as “manual” operation.

I just wanted to mention that because if you tell support that local operation isn’t working, they’re going to give you a bunch of things to do that don’t have anything to do with your real problem.

Manual. Got it. Thanks!

1 Like

As I sort of expected, ST support is blaming Centralite. What I tried explaining to ST support is that this was all perfect and working great until the latest FW update. Now, I’m chasing devices that stop working when adding other ZigBee devices to the network. So much fun!

1 Like

Tagging @aaron , he’s been tracking these issues.

Thanks. @Aaron if you’re reading this…I chat messaged earlier and submitted a ticket this AM around Zigbee issues. Last person I spoke with said my device isn’t officially supported and it’s an issue with the device. Well, I’m sorry but I don’t buy that. Things were PERFECT until this latest FW update. I’ve removed a bunch of Zigbee stuff today then added a few door/window sensors just now and I’ve lost manual control of a different lamp/appliance module that was previously working great. What’s going on here??

Another issue I’m now having is that these zigbee Centralite switches and modules WERE reporting state if manually controlled. Now, they don’t so it’s easy to get them out of sync with the app. This too was not the case prior to the FW update.

About four hours ago, my Cree bulbs turn on without warning, then stopped responding. I removed them and tried to re-add, to no luck. I also tried to add some spares in my warchest, without success. Very strange. I haven’t tried to add or remove any ZigBee devices for many many months.

Something obviously got wonked today and now I can’t fix it due to One ZigBee weirdness.

So there is no fix?

Did you ever sort a solution for this? I have the exact same issue and cannot seem to remedy. Over the years I’ve slowly replaced these centralite switches with Zooz, but it seems silly to throw money at something that is likely having a software issue.