ZFM-80US difficulty adding to ST

Hello. I have a Remotec ZF-80US dry contact relay I use to turn my fireplace on/off manually and via voice assistant. A few months back I noticed it entirely disappeared from ST and I am finding it impossible to reconnect. I tried Zwave utilities via the hub (delete/add), no dice. Can’t seem to get the hub to find it using all the different possible add device possibilities. Can’t seem to locate any driver for this either. Does that mean I can’t add it back to ST?

I’m stuck here… hopefully I can get this figured out before the winter! :slightly_smiling_face: Any help is appreciated! :+1:

Since it is a Z-Wave device you will need to exclude it before you can repair it.

In the Mobile App, go to Hub and open the tile. Click on 3 dots in upper right corner, select setting, Z-Wave utilities, and exclude.

If you’re interested in trying my driver that supports the ZFM-80 (consider it in beta just like the rest of the Edge drivers), please sign up here:

  1. Use the invite CStup Edge Driver Invitation
  2. Enroll your hub
  3. Click “Available Drivers”
  4. Click the “Install” button on Z-Wave Switch CS
  5. Take a screenshot of your existing configuration of your device Settings to replicate it on the new driver.
  6. If your device is still on a DTH you’ll need to exclude, then include it again. It should pick up this driver.
1 Like

Yes, I’m familiar with this. But the tile completely disappeared, and for the life of me, I’m unable to get a successful exclusion. Let’s just say the Remotec instructions I found leave A LOT to be desired. I can’t tell is it’s paired or not, and/or how to get it in exclusion/inclusion mode.

I installed the driver, thanks for letting me know. But if I can’t figure out how to reset this damn switch, it might just be in vain!

Exclusion directions I found on-line:

Control: Include or exclude the Fixture Switch Module from the existing Z-Wave home control network with your primary controller.

-Refer to your primary controller instructions to process the inclusion / exclusion setup procedure.

-When prompted by your primary controller, click once on the PROG button or external switch.

-The primary controller should indicate that the action was successful. If the controller indicates the action was unsuccessful, please repeat the procedure.

-Once the Fixture Switch Module is part of the network, the same basic procedure is used to add the Fixture Switch Module to groups or scenes. Refer to the primary controller’s instructions for details.

There is no PROG button on this switch. It’s just an on/off button trigger, with manual load control connections to a low voltage contact switch.

Which is why this is so frustrating. Toggling the only button on the switch, and/or my wall switch that’s also connected to it, does not successfully exclude (or include) the switch. I’ve tried probably 20 times and incorporate multiple presses/hold combinations using both the external switch and the manual button. No dice.

The instructions don’t include any button press sequences for pairing mode, so I’d think it would just be a single on/off button tap that would put it in pairing mode. That’s how a lot of the first gen zwave switches seemed to work from what I recall.

Maybe I should be asking about an updated zwave dry contact relay that would replace this! Sucks because I still have some ancient zwave switches quite old that I don’t have any trouble with. :face_with_symbols_over_mouth:

Have you tried doing this right next to the hub? Sometimes that makes a big difference.

This is possible. The device calls out in its manual that it supports NWI (network wide inclusion, meaning can include when in range of any routing device in the network not just the hub), but not all devices that did also supported NWE. This was especially common on pre Zwave Plus devices, which this one is.

Often people will move their non wifi hub (V2) with a long ethernet cable.

Should just be -

  • Put hub into exclusion mode
  • (see that the led is blinking to indicate so)
  • power up the device
  • press the on/off/prog button once.
  • Should see it exclude within a few seconds.

If you have another Zwave hub or USB stick you could also exclude it using that.

1 Like

Excellent advice! I moved the hub right next to it, and it excluded and re paired. Odd because it wasn’t that far at all from the hub’s permanent location. Maybe the metal firebox had something to do with it!

Thanks!! :pray:

2 Likes

another note for users trying to pair a z-wave device with an Edge driver: choose Add Device > By device type > Z-Wave

I added it via the scan for devices option, and it picked up no problem, and also the edge driver previously linked in this thread. Now working just fine, including voice on/off control.

Thank you all.

3 Likes

Turning on fireplaces for the winter and they use the ZFM-80. I installed your Z-Wave Switch CS driver and it works great! Any chance you can add support for parameters 2, 3 and 4 on the Remotec ZFM-80. I use this as a safety to make sure the fireplaces turn off after a certain period of time.
In case images don’t load:
Parameter 2 (0x02) is timeout period 0-240 minutes (default 0 - disabled)
Parameter 3 (0x03) is NodeID 1-232 (default 0)
Parameter 4 (0x04) Set relay if timeout: 0 = turn off (default)
1 = turn on


image