ZEN25 + ActionTiles = Hub Crash

I’m hoping @TheSmartestHouse and / or @tgauchat might be able to help on this one. I have 7 ZEN25 plugs attached to 14 pinball machines. I’m running ActionTiles on a Kindle Fire 11 in my basement. The panel includes the switch for each side of the ZEN25, along with the Power Consumption for each side.

When the pinball machines are off everything seems normal. However, as soon as I turn all the pinball machines on, the rest of my Z-wave network becomes unresponsive. I have devices that drop offline, changes don’t happen at all or take minutes to occur. It’s absolute chaos, until I turn off the pinball machines.

Keep in mind that I’m not turning off the ZEN25 plugs, just the machines attached to them. I did a little digging and found that when the machines are on, the log is absolutely flooded with sensor data coming from each side of all of the ZEN25 plugs. When the ZEN25 plugs are on, but the pinball machines are turned off, everything is quiet.

I’m tagging @tgauchat because IDE shows them all coming from ActionTiles. I’m not sure if it’s the ZEN25 sending the data, or ActionTiles requesting the data that causing the issue.

Here is what the log looks like when it happens.

Thanks to anyone that can help!

Your devices are noisy with regards to power and energy events. These events occur for all insignificant fluctuations in power consumption and spam your network and event log.

ActionTiles does not request any data from your hub. Your hub reports these events in real time to ActionTiles.

SmartThings Community forum is not our primary support channel. For any inquiries please contact ActionTiles support at support@actiontiles.com.

2 Likes

As @JDRoberts has frequently pointed out, Z-Wave (and ZigBee) are not designed for (nor tolerant of) high-frequency Event Reporting from individual devices or in the total traffic of multiple devices on the network.

Doors/Windows (Contact Sensors) open and close perhaps every few minutes or even only every few hours. Similarly for Motion Sensors … which even in busy areas do not report very frequently because all motion sensors have a “reset period” during which they maintain the “Active” State and do not report additional activity. Same for Temperature Sensors … you’d be living in quite a breezy place if the Temperature changed every few seconds.

Power draw, on the other hand, turns out to be extremely “noisy” - i.e., power draw of a pinball machine with all it’s literal bells and whistles and blinking lights, changes every few seconds, even if just by a few Watts. The firmware on some types of Power Metering outlets can be configured to not send a Z-Wave/ZigBee event packet unless a certain minimum amount of change has occurred and/or a certain time has passed since the previous message (a little like the “reset period” of a Motion Detector).

Unfortunately, SmartThings has not included setting reasonable thresholds in their Device Type Handlers initialization process (i.e., the sending of the “configuration” packet). This is true even for their own brand of outlets.

Our quick analysis revealed that: As much as 85% or more of Device Events in SmartThings are Power Draw report messages! Yes… 85%. ActionTiles filters these in the “ActionTiles V6 (Connect)” SmartApp so that our Cloud isn’t flooded with them. But apparently, SmartThings isn’t bothered with their Cloud being flooded. Imagine the costs they could save! :open_mouth:

However: It sounds like you need to be concerned that your Z-Wave Mesh Network is being overrun with these messages from your ZEN25 outlets.

I recommend doing some research into the Z-Wave configuration parameters available for this manufacturer/model. Hopefully there are parameters to reduce Power Draw reporting frequency. There are folks here in the Community (and/or SmartThings Support) who can then assist you to use a temporary Device Type Handler to push these parameters to each of your outlets.

2 Likes

@Spyderturbo007, these recommendations will help immensely. Zwave devices that are very chatty will bring down your mesh. Been there, done that.

@tgauchat, perhaps, but so far I haven’t personally been impacted by this for my Zigbee mesh. I’m at over 200 Zigbee devices, with over 50% of them reporting power, and the rest reporting temp, humidity, etc. The evenings are the quietest in terms of the amount of data flying around. The most I saw was when we had several visitors staying with us, and practically every switch/outlet was in use. We still experienced no degradation of the Zigbee mesh, device performance, or ST app responsiveness.

2 Likes

It’s interesting to hear that ZigBee appears to be more resilient when faced with this situation. That may be useful for Customers who wish to use a lot of power reporting outlets.

Of course, all of these power level report Events still have to be processed by the SmartThings Cloud which may not have a noticeable impact on individual Customers - but I’m still flabbergasted that their operations analysts have not found this to be a concerning amount of load when coming from millions of Hubs.

There may be some types of Events with similar high message frequency (at least from time to time). For example, when changing the channel or volume on a Smart TV … an Event Message is created for every tap of the Volume +/- button.

2 Likes

Try using WiFi plugs instead. As @tgauchat explained so well, zwave just isn’t designed for high frequency events. WiFi, however, is designed for continuous connection, and has no problem, which is why it can handle streaming audio and video. Or a setup like your pinball room. :sunglasses:

This one has a SmartThings integration and looks to be well-engineered.

Each has two controllable outlets, if that helps.

Otherwise the TPLink HS110 also has a SmartThings integration. @gutheinz should know if the energy reporting is exposed to SmartThings in the official integration. But only one outlet.

We’d recommend reducing the reporting frequency and increasing the reporting threshold for energy reports for all of the outlets that control your pinball machines since there seem to be a lot of fluctuations causing constant reporting. The new standard for Z-Wave is actually one report every 30 seconds as most frequent allowed unsolicited report and the latest firmware reflects that requirement. But for the first firmware release reports will be coming in according to the advanced reporting settings which can be all the time if energy jumps are frequent enough. If you’re having issues tweaking the advanced settings or would like to update the plugs, just get in touch with Zooz support and they’ll assist you with that quickly.

2 Likes

The TP-Link HS300 is a six output power strip with individual control of each outlet as well as power monitoring on each outlet. It includes surge protection and has 3 USB ports. 15 amp total for all outputs.

https://www.kasasmart.com/us/products/smart-plugs/kasa-smart-wi-fi-power-strip-hs300

I am guessing that neither the HS110 nor the HS300 official integrations support EM functions. If they do not, my unofficial integration is still available and supports EM functions. I am still addressing anomalies.

Dave

2 Likes

Thanks everyone for the detailed feedback and suggestions. I found the spot where I can adjust the reporting threshold. Upped the power threshold from 5 watts to 25 watts. The reporting frequency was already set to 2 minutes. I’ll give it a test this weekend when everyone is over to play.

3 Likes

Just a quick follow-up on this part. If I look at my log from above, I’ll see entries like:

debug Power: oldValue: 92.5, newValue: 92.9, delta: 0.4%, threshold: 15%

debug A sensor event occurred: [name:power, deviceId:477a26d2-7878-4a22-9fb4-1e744c9c7fa9, isoDate:2019-10-06T04:56:11.533Z, unit:W, Value: 92.9]

debug sending data to AT

If my power reporting threshold was at 5W, then why was this data sent to the hub? There are a bunch of them that were below the reporting threshold, but were reported anyway. Unless a few of the sensors just happened to hit the 2 minute mark at the same time? I guess I’d need to go through the longer text file log I have it that might be the case?

The device will report based on the time interval or reporting threshold whichever occurs sooner so to minimize the amount of reports, we recommend increasing values for both settings. Let us know what you find!

2 Likes