Zen Thermostat Battery Error

I am using SmartThings Mobile App version 2.6.0 (1412) and have the Zen Thermostat. On my Zen Thermostat I am getting a “Battery Error” with an indicator that the battery showing depleted on the SmartThings App (but not on the Zen Thermostat itself. This is with a fresh set of batteries and, other than this indication, the thermostat functions normally.

Has anyone else seen this error and resolved it?

Jim K

1 Like

I’m seeing it myself, but have not resolved it.

I bought the Zen because I didn’t think I could supply power, but I found the C wire tucked away in the wall. I’m half-tempted to just dig that out and re-configure it to be wired.

I’m using Amazon Basics rechargeable AA. I have not tried standard disposable batteries.

I am seeing the same error. The batteries in my SmartThings base had indeed failed so I replaced them. Did the same with my Zen. Error remains the same. Rebooted the app and rebooted the base. No effect. Have not figured a way to unlatch the error message.

same here, replaced new Duracell battery, error still there

Not that this helps you all, but I’m seeing the same error. I replaced the batteries in the Zen thermostat (which wasn’t itself reporting low batteries) and still I have the error.

I’m going to try deleting the device from Smartthings and re-adding it tonite to see if that resolves it. Would appreciate if anyone above has resolved the error that you post here!

Has anyone found a way to get around this? I can no longer control the thermostat via smartthings with this error?

I opened a case with support and I can now see the battery percentage.

FWIW, I still see the battery error 100% of the time, but I am not able to control the Zen thermostat. So, everything is “working” but the battery error still exists. I just ignore it, now.

Everything was working fine until I replaced my batteries a few weeks ago, then the battery error came back. I opened another case with Smartthings, they responded and checked a number of things and have now referred my case to Tier 3 support. Even with the battery error condition I can control the thermostat, I just have the Battery Error indicator.

Today - for the heck of it - I replaced my batteries with Rayovac rechargeable that I have and the battery percentage error went away. Duracell and Amazon Basic batteries were the other two that I tried, and those two brands did not work.

I am also considering having my furnace people wire up the C-wire the next time they come out for my scheduled maintenance.

Whoops, I meant to say while I still see the error I can NOW control the thermostat.

That’s really interesting that a different brand or type of battery would make a difference. No way this should be that sensitive!

Thanks for the update. I’d appreciate you posting again if you get anything interesting back from ST on the support case.

Dean - I will update this thread once I hear back from Tier 3 at Smartthings.

1 Like

This thing was eating batteries left and right for me, so I dropped it from ST for now, waiting on you guys to get a resolution before I re-add it.

I’m using rechargeable AA (Eneloop and Amazon Basics), but it was going through a set of batteries every 3 days.
Since removing it from ST just after Thanksgiving, I haven’t had to replace them.

Hi all,

A new device handler has been posted only a few hours ago here: https://github.com/SmartThingsCommunity/SmartThingsPublic/pull/2671

It changes the algorithm used to measure the battery remaining percent and it worked for me. I now have a 100% instead of a battery error.

I used these instructions to install the new device handler: FAQ: An Overview of Using Custom Code in SmartThings
You can change it in the IDE without having to remove the device.



YES!!! Thank you @routerhelp1

This worked for me. I’m back to 100% battery. I really appreciate you taking the time to post the fix and the instructions.

Happy New Year!


Awesome! I will be re-adding this to ST this weekend. Desperately needed with the negative temps.

Thank you for creating and sharing this device handler. I finally got around to applying this to my Zen Thermostat and it worked for me as well. I’m a newb when it comes to device handlers, and the instructions were very clear. Much appreciated routerhelp1.

What did support do it correct it? I have the same issue, and with winter coming up, want to ensure the Zen functions as it needs to!

I am not sure what the tech support people did, but I do know that the changes were made by SmartThings developers and not by Zen. My battery percentage is still working.

While I was waiting for SmartThings to complete their changes I did apply the device handler (customer code) as described by router1help… and that worked. I backed out the device handler/custom code once SmartThings fixed things.

Thanks. I’m going to test the DH today to see if it resolves my issue. Zen’s tech support suggested I remove and re-add the thermostat, but hoping not to do that.