Z-Wave Virtual Momentary Contact Switch stuck in "on" state

  • smartthings hub v2
  • GoControl Z-Wave Isolated Contact Fixture Module - FS20Z-1
  • wired in parallel with linear actuator to raise/lower a downdraft vent

A few days ago at 12:30am I woke up to hearing my telescoping vent for my stove top constantly actuating up and down. I have a zwave relay connected to the vent that is configured as a momentary switch. When the switch is pressed, it raises or lowers the vent, depending on the current position. Somehow, without any action by me, my smarthub decided to force the switch into a constant “on” state. The hub completely ignored my commands until I performed a reset.

First of all, how could this have possibly happened? I don’t see any way in which a momentary switch would be forced into an “on” state unless the hub just completely lost its marbles. Second, why did the hub refuse to respond to my commands?

Here is what the log reported -

2016-06-10 12:33:10.745 AM CDT
3 days ago DEVICE /physical switch on Range Fan switch is on
2016-06-08 6:16:54.352 PM CDT
4 days ago DEVICE /digital switch off Range Fan switch is off

Notice that is says the switch was physically actuated. But how could that have happened without me touching it? Does that mean the internal relay stuck on randomly? I am not convinced that is the case however, because I did not command it to do so, and my hub locked up and didn’t respond to my commands when I tried to reset it.

I would also be interesting in learning if anyone that has the GoControl Z-Wave relay has had them randomly fail into an “on” state.

Any help is appreciated.

1 Like

Did you ever get this figured out? It randomly happens to all of my virtual switches also.

Thanks, jd

No, I have not had any luck with a solution. Fortunately it has only happened once so far, but I don’t have a lot of confidence in my hub that it won’t happen again.

I have these on 3 garage doors and it’s randomly happened on all of them. Of course everyone in the house roll their eyes when it happens saying we’ve been hacked, which is crazy. If you find something let me know.

1 Like

I’m assuming no resolution on this yet… I have 3 but only 1 seems to be randomly failing. Mine started directly after a hub firmware upgrade.

Just had this problem yesterday… garage door momentary switch got stuck on. Guess what that does to my garage door? Opens it, and then auto-closes it after 1-2 minutes (as if you were holding down the button…) nearly on my car.

Any ideas on a workaround/safety? Ie if the momentary switch remains on more than 10 seconds, turn it off? Maybe I can do this with WebCore.

I actually did write a smartapp which checks to see if the momentary switch is on for longer than x minutes and sends the ‘turn off’ command. Today my switch got stuck in the on position - completely on the SmartThings software side, the actual hardware switch was behaving normally.

The result of all this is that every few seconds SmartThings would try to reset the momentary switch to off and actually re-activate the swtich which thought it was already off. Meanwhile every two minutes my app is doing the same thing. SmartThings continued to report the switch was ‘on’ the whole time.

I tried everything I could think of, but what finally fixed it was this:

In the SmartThings IDE, I changed the device type from ‘Zwave Virtual Momentary Switch’ to ‘Zwave Switch’ and back again. The default state of a newly initialized virtual momentary switch is off. Problem solved.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.