Z-Wave Smart Fan Control Custom Device Type

Hi ChadCK, tks for providing this St FAN Handler. It works perfect from ST App but when I ask Alexa to set to 30% it works but she answer back saying “I’m not quite sure what went wrong” if I change the Handler back to default “Dimmer Z-Wave” it works fine. Do you have any idea why she’s not recognizing the response back from the Handler?

I can get Alexa to recognize and perform “Turn on [Living Room Fan] to Low” and “Set [Living Room Fan] to High”, but I get the “I’m not quite sure what went wrong” response, despite the correct function taking place.

Now, she doesn’t have a clue what to do about Medium. No response.

This is a much better than the Dimmer device handler which defaults to installing. Thank you! For me, my fan doesn’t turn on until I hit 62% And, then it’s on low, which I believe is the last setting used. There is no getting it to differentiate between low/med/high. Though I think this is more of a fan challenge, and less of a device handler challenge.

Just seeing your post.

Alexa does not understand ‘medium.’ Low and high work by chance. See here (expand to see the full post) …

I just discovered the same thing by accident, that Alexa happens to understand Low and High (though her values are 10% and 99%, which are not what I defined in the Device Handler - clearly embedded values) but has no idea about medium.

That’s OK by me, really.

Has anyone looked at updating this device handler to comply with the new SmartThings “Blue” color scheme? I don’t quite understand what in the code drives the coloration, and this has the older green button when the fan is turned on. I have a couple of custom DTHs that have this issue actually and would love to understand how to fix it.

And also, it seems like despite everyone’s best efforts - the LED on this switch simply can’t be killed. Setting it to “always off” doesn’t work.

@jawn101 “Has anyone looked at updating this device handler to comply with the new SmartThings “Blue” color scheme?“

My handler is blue, and you can look that as an example to change yours. It’s really quite simple.

1 Like

Oh, great - will compare them. Where’s yours hosted? I scrolled back pretty far and must have scanned over the link to it.

Thanks!

Here you go up at post 36:

1 Like

Hi All,

I’ve been successfully using the old code, but now have changed to that mentioned by @johnconstantelo today, seems to be better.

My current issue: my old GE fan switch was fine, but I just installed a 2nd one in a different room, and it’s a newer model. The indicator light default is on when device is off. I want it on when device is on. I set it in the setting of the code mentioned above, but it will not take. API graph website has it the way I want: “indicatorStatus: when on”. And yet it is off, and the light remains on.

The new model is here: https://smile.amazon.com/gp/product/B06XTKQTTV/ref=oh_aui_detailpage_o04_s00?ie=UTF8&psc=1

The main difference is it is Zwave Plus.

Any ideas on how to force that damn LED light off?

Thanks!

Okay, I resolved it:

Tapping the top 3 times and the bottom once only toggles the LED to be where I want it.

Nevertheless, the new device seems to be ignoring the coding…

I’ve made a new DTH from this and @dalec’s KOF child DTH. It has the same look as @ChadCK’s but creates LOW, MEDIUM and HIGH child devices. With this change you will now have hidden switches addressable from Amazon Echos and Google Homes with those names.

I’ll be posting it tomorrow morning if anyone is interested.

3 Likes

I’ve created a topic for this new DTH

What would be the owner, name and branch for this code so I can incorporate into the IDE easier?

Here you go:

image

1 Like

Has anyone looked at doing a DH for the new 14287 fan switches than can use the double tap feature?

On my gardinier home collections fan, I can reverse the motor by doing as follows, since I don’t have the original remote. I bought one of these fans on eBay for 80 bucks with out the controller. So then I purchased the wink controller from home Depot, however those remotes don’t come with reverse button. Anyway, here goes.

With the fan off using the remote control, turn fan on, off, on, off. Wait… you will hear a click inside the fan. Now when you turn on again, it will go the reverse direction. Hope this helps someone…

Or if the fan is on already, turn it off, on, off, on, off. Then wait for the click… now it’s reversed…

Hello, trying to get this to work with GE 14287

Have you been able to get it to work?

Hi, very great thread and community. I am still trying to absorb all that info. So I have a Hunter Fan which came with a remote control (Light On/Off and 4 speed Fan control). I have one switch to control the fan then I use the remote to adjust speed and turn light ON/OFF if I want to keep the fan running. So I went ahead and installed few days ago [GE Z-Wave Plus Smart Fan Speed Control, 3-Speed, In-Wall, Controls Fan Speed ONLY, 14287] which work OK but I still have to use my remote to control the Light ON/OFF while the fan is running. I was wondering if there is a device handler similar to this that can allow me to turn on/off the light. Apologize if this is not the right thread but this is the closest device handler I found to what I need to replace the stock version I have when paired the GE switch with the smartthings hub

Thanks and hope my request is making sense