Z-Wave Plus with S2 NOT SECURE

I see. Currently S2 isn’t supported when using Scan Nearby. If you exclude and re-add the device from the device catalog rather than Scan Nearby, you should be prompted to scan a barcode or manually enter information. Doing one of those will allow you to add the device with S2.

thanks. I’ll try it again via the device catalog. Is the 4 digit number in front on the metal plate the PIN?

That is likely the date sticker. The DSK sticker is probably located elsewhere.

While the switches support S2 security, they don’t support SmartStart yet so there won’t be a code to scan anywhere on the product. The platform should be able to include them securely regardless unless S2 was only implemented for SmartStart devices.

Is the DSK listed on the device?

As illustrated by a Figure 1 in SiLabs’ whitepaper, the user needs to “Enter S2 DSK into
Gateway Interface”. In this instance, that means either scanning a QR code with the DSK info or manually entering the DSK information in the SmartThings app.

1 Like

If I am correctly remembering a recent Zooz switch pairing I did on my network… I picked the switch through the brand list while pairing and the switch was included securely, with the result in the IDE showing “ZWAVE_S2_UNAUTHENTICATED”. No DSK was used nor any QR code scanned.

1 Like

It only supports S2 Unauthenticated, which I believe means there is no DSK/QR code https://products.z-wavealliance.org/products/3192?selectedFrequencyId=-1

2 Likes

Good catch Jimmy. You are correct. I think the device in question is this one but it also supports S2 Unauthenticated.

From the Z-Wave General Info support page:

Note: Devices classified as Z-Wave S2 Unauthenticated will add into SmartThings without the need for scanning the QR code or entering a pin. These devices are still using a form of the Z-Wave S2 security protocol.

2 Likes

thanks all. i’ll try to exclude it and re-include it as a specific device w/o a pin and will let you know if it works.

1 Like

that worked. It did not prompt for a pin, and took a while to include. Here’s the data field:
image

2 Likes

To get S2 do you have to pair with the new app, or is the old app okay?

I tried to pair using the new app and it paired as a thing and not a dimmer switch.

Pairs fine with old app but S2 failed.

Does pairing with S2 provide any benefit over just being encrypted and secure?

Meaning is the bandwidth Increased or communications more stable?

Have to use the new app. I want to say S2 has better bandwidth utilization than S0, but I can’t remember where I saw that right now :thinking:

Remember though you can’t associate an S2 Auth device (switch) with S0 gear (most bulbs from what I’ve seen/tried). If there is a way I’d like to know? (Backwards compatible stated from S2)
“The “S2 Authenticated” class is used for all normal household devices such as sensors and light dimmers. The “S2 Unauthenticated” class is the least trusted class and is only intended for the most constrained controllers that, due to a limited user interface, are not capable of authenticating a node joining the network.”

1 Like

It doesn’t have better bandwidth, but it does have a more terse encryption meaning less data is transferred, meaning better battery life. So smaller messages, not better bandwidth. But the end result is still good. :sunglasses:

ECDH and AES-128 bit reduce Z-Wave Plus’ wireless data transfer; security communication now uses 66% less battery life.

3 Likes

Sorry to dig up an old thread, but it’s the first one that comes up on the search.

Does the V2 hub support s2? I just got a new switch and when trying to add it it asks for the qr code. I scan it, it “thinks” for a long while and then fails to add securely. I tired using the Pin as well and get the same issue.

yes, V2 hub supports S2. Are you scanning the QR code on the device itself or the box or manual that came with the box? I’ve seen before where the two QR codes were different and one of them was wrong. Tried the other and it works fine.

1 Like

The one on the device as well as the PIN on the device.

Well, I guess the fix for me was to wait 3 days and try it again. Go figure.

1 Like

I just set up 5 new Zooz switches today and they all failed. Some times they asked for the QR code, some times they did not, but they all say that S2 failed. I was scanning the QR code from the box because I actually didn’t see one on the switch. Has this been resolved?

It’s usually on the front plate of it. So its covered once you put the switch plate back on. It’s worth comparing the two though. And make sure you are pairing via the z-wave “brand” in the app.

1 Like