Z-Wave devices report but do not respond

I have v3 hub and I’ve noticed a z-wave issue recently. All of my z-wave devices will report status, but they will not respond to any actions from the hub via the app.

For example 1: Leviton Outlet reports ON status, but if I try to turn if OFF in the app, it doesn’t turn off.

For example 2: GoControl/Linear z-wave garage door will show open/close status in the app, but if I try to open or close it, either via the app tile or an automation, nothing happens.

For example 3: Schlage Z-Wave door lock will show open close and I get notifications when opened, but if I try to open/close it via the tile it does nothing.

Trying to repair the mesh shows this:


Which is interesting because not all the devices even show.

Actions I’ve tried:
-Power Cycling hub.
-Removing adding the Leviton Outlet back to the system. (I have not tired this with other devices yet.)

It almost seems like it has stopped transmitting and is only receiving.

Any ideas, thoughts, suggestions?

All devices will not show - only ones that have issues.

Those errors / issues would possibly explain your overall issue. You need a clean mesh before you can expect everything to work correctly. In those Failures - what is the EXACT display text for each.

If you look at each device with an error - and look at the routing what does it say.

1 Like

Thanks. I did plug in a Wink v2 Hub which I had added as a repeater. This seems to have resolved some of the issues with most of the devices. This Leviton Outlet is still an issue.

Here’s an odd routing…not sure what this unknown device is. It doesn’t show up in the device list:

THAT is a ZWave ghost and it is why you are having this issue…

In the IDE, create a new device of tyoe ZWave Device and manually set the network ID of thet device to match the one for your ghost in this case D2.

Save the device.

Close the IDE

Open the app and wait for your device to show up without a room.

Opeb the device you created and delete it. It will most likely complain yhen offer to forcs delete the device.

Its very important the delete is done from the app, not the IDE as the app will perform proper ZWave exclusion abd force remove the device. (this is the exact procedure being added as an auto cleanup item in the .37 firmware)

After its deleted go back and run another ZWave repair to finally clear the now deleted ghost iut of the routes.

1 Like

Thanks for the suggestion. It did not change anything. This particular device is a garage door opener and is using the @RBoy “Z-Wave Garage Door Opener with Switch Capability” DH. Maybe this is related to that or the way the GoControl door opening works with the local position sensor.

Do you have any other errors showing in that ZWave repair or did it come back 100% clean

The Zwave Repair showed no errors.

Obviously it is unusual to have a Wink hub as a secondary on a ST setup, and smartthings is known not to play well with secondaries…Were you having problems before you added the wink hub?

Also, do you have any other hubs or subhubs added to this network? I have seen subhubs show up as “unknown device“ in the past.

The Wink hub only functions as a Zwave repeater, nothing else.

Looks like a ghost device which can disrupt the mesh comms. See this topic for more details:

1 Like

Thanks for this additional information and link. Here’s the thing, the network repairs just fine:

But, this still remains…

Then, following the remove ghost device, the first time at the delete the ghost device it says complete, but doesn’t actually remove it. Then I run it again and get to the Force Delete option.

Then, after the new repair:

and
ghost remains

D2 is 210 decimal. Do you have that many zwave devices? Is it possible that it’s a virtual device that you defined as being a zwave device?

1 Like

also, how long did you wait before checking???

I ask because, the IDE is more like a freight train - than a sportscar. It’s not realtime. Some things take up to 24 hours before you see any changes.

1 Like

Wait for what, specifically?

Let’s just say, I was thinking more along the lines of a Plaid Tesla than Union Pacific.

1 Like

I believe I have a total of 3 Zwave devices + the one that has been a problem + the unknown device.

OK, then it’s very likely that the unknown device is either a virtual device or a proxy device. Because you wouldn’t have gotten anywhere near that device ID, they are given out in sequential order (one, two, three). The numbers don’t get reused until you get all the way up to 255 and then they start over again. So maybe you got that high with various failed pairings, but I’m guessing not.

Once upon a time, although this no longer happens, subhubs On the Samsung connect Wi-Fi system would show up as an unknown device with a weird device number.

So I’m thinking maybe, just maybe, this is an artifact from having joined the Wink hub to your network. If that’s the case, you won’t be able to get rid of it, and it will probably always show in the path with the wink hub. But I don’t know for sure. I don’t know anyone else who’s tried to use a wink hub in the manner you are.

The best way to test that would be to remove the wink hub. Then if the ghost device is still there, create a virtual and remove it. Then add the wink hub back and see if the unknown device comes back also.

1 Like

Specifically, the routing entry on the device in the IDE - usually takes 24 hours to show changes.

1 Like

It sounds like your go control has lost it’s connection with the hub. This is a common issue with this model. Try to realign the antenna direction and hit the reset button once or power cycle and then then run a z-wave repair. If that still doesn’t restore the connection you’ll have to exclude and re pair it.

1 Like

There is no antenna to realign on this model.