Z-wave devices losing communication with hub

I have three zwave Honeywell thermostats that keep losing communication with hub and random older Honeywell zwave wall switches, the old ones with the air gap switch. Newer wall switches without air gap are fine.

What’s wrong, seem to be a issue with older zwave devices. Reason why we need zwave firmware updates. my guess is this has been caused by a z-wave firmware (stack) update on hub.

Same problem, when i try to on device repeatedly (in classic app) device eventually responds but after 10-20 minutes. However when i press physical button on device, its status gets updated immediately. What it has with firmware? It looks like someone filters out requests from app. Disgusting inaction from incompetent support as usually. Also app logs still me out and wtf still no dark theme?

things started to improve once I responded on forum. Clearly … someone is doing somethig … to hack system?

Did you check events log?
On some z-wave plugs I see message “Not responding” and in device list they show up as INACTIVE although they are powered and LED light works on them.
They worked fine just hours ago.
What to do?
Remove and readd?

I’ve been noticing the occasional z-wave device, like utiltech siren or first alert smoke CO2 detector, falling off, but within a couple of hours they are back.

just lost three switches this morning… nothing on logs, attempt to do a repair and all i get is hub is not responsive… so i air gaped the switches and they eventually came back.

I’ve not had problems with my first alert smoke and carbon dioxide detectors. knock on wood!

I’m having Z-wave problems with devices randomly going online and offline.

I am very rapidly losing confidence in this platform.

still continues with four or five devices per week, add a yale door lock to the mix this week.

Lost another 5 switch’s, all says unavailable but still works, but report as unresponsive…

My Honeywell thermostats, for about the last 6 months, lose communication with the hub daily. The are routed direct to the hub. They use to be rock solid.
Seems like older firmware devices keep dropping off network, probably do to a firmware upgrade to the zwave radio…

Zigbee devices are rock solid.