Yale YRD256 Zigbee connected to SmartThings Hub but App show nothing for control

I’ve paired Yale YRD256 Zigbee with my SmartThings WiFi Hub and both devices are separated 4ft apart. Paired almost instantly as confirmed by both the voice prompt of Yale lock and also screen of SmartThings app.

However, when I open the App and click on the device “Thing” (I didn’t rename it), there is nothing inside.

I have tried :

  • Factory reset SmartThings WiFi Hub
  • Factory reset Yale YRD256 ZigBee (three times)
  • Changed batteries
  • Unpaired and Re-paired numerous times

Firmware versions of both devices are :

  • Yale YRD256 : v4.2.00c
  • ZigBee Module : V261
  • SmartThings WiFi Hub : 1.7.20-25

Any ideas are helpful!


Remove, the lock, exclude it and reset the lock once again. Install the SmartThings Classic app and install the lock with it. See if it works, if not report back.

Hi jkp,

Thanks for the tips. Just tried to use ST Classic, same problem. Instantly paired but also showing “Thing” and nothing can be done when click on icon.

Please help!


Login to IDE at https://account.smartthings.com and go to My Devices and look for that device named Thing and see what what device handler is being assigned to the lock, it would be in the type field.

Hi jkp,

Thanks a lot, it works. Apparently both ST and ST Classic App recognized the Yale lock as type = Thing, I’ve edited it, changed to “Yale Lock” and it works ok now.