SmartThings Community

Yale Smartphone Alarm System integration

yale
dth_security
project_security

(Mark C) #165

Yale had some issues recently, might need to pull the power and batteries for a few miunites. the “system.panel.offline” is the message from the web site, ie the pannel is not connected to the internet/thier site.
Try using the yale app to see if there are any messages or if it works.

these are the code message of what smartthings is trying to do, not the responses from the API


(Ash Stokes) #166

Thanks Mark,

The Yale app itself works fine, shows the hub online etc, can arm/disarm it from the app, just can’t from the website. Yeah their maintenance last week was horrific, apparently my account got migrated onto a difference server which was why they said I no longer had access to the site… whether that’s true I’m not sure, but I’ll try completely dropping it’s power and see if that gets anywhere


(Mark C) #167

mine went down for a few days (wouldnt arm trough smartthings) but just left it and its all working fine now. let me know how you get on


(Ash Stokes) #168

Yeah unfortunately still the same, dropped the battery and power, confirmed it was off through the app and brought it back on, working through the app still but still “System_Panel_Offline” on the web :frowning: I tried logging in through it’s local IP as it presents pretty much the same screen (can see it once access denied) so I imagine I could edit the handler with the local IP/authentication but Yale won’t give it out.


(Mark C) #169

have you tryed logging out of yale in smartthings and logging back in? come to think of it i think i changed my password around that time, so had to reenter details

how did you find the local ip, how did you try to log into it


(Ash Stokes) #170

Yeah, I try logging in from ‘https://www.yalehomesystem.co.uk’ on my laptop too and get the same error. I saw from my routers UI, knew what LAN port it was plugged into and managed to get the IP assigned to it, then just browsed like you would a normal routers IP and it came up with basic authentication, I tried guessing a few default ones and was going to try and brute force it but I have no idea of the user so it’d take ages going through two wordlists, Yale responded when I asked though and said it was just for engineers/developers… which seems stupid since it’s a local UI and you’ve bought their product, not like your renting it and yet it’s just got the exact same tabs as when you login using the URL at the top.


(Mark C) #171

this is what i get… are you diddfent?



(Ash Stokes) #172

Nope, that’s the same I get going to ‘https://www.yalehomesystem.co.uk/’ after logging in


Then if I try and arm it it comes up with this:

Yet the app works fine and shows the hub online… the local IP looks a bit different to that but same tabs e.g. ‘controller, control, devices etc.’


(Mark C) #173

ive not tryed arming, but log and settings work ok for me, do they work for you?


(Ash Stokes) #174

Nope, you can access it but the latest entry in the log was the 22nd (when it stopped working in ST), whereas before you had a log entry for nearly everyday from arming or periodic tests, I’m thinking maybe they have migrated my account to a different server that doesn’t have access to that URL anymore, just the app, as I know they said they were trying to discontinue the URL. :pensive:


(Daniel McDougall) #175

That website doesnt work for anyone anymore you need to connect to it using a post, look for a chrome add on called post man and see if you can connect to it with your login details that way.

I have tried bruteforcing that local up screen many many times to no avail.


(Mark C) #176

strange mine is working fine web & smartthings


(Ash Stokes) #177

Ok thanks mate, you got any guide for post? not familiar with this add-on unfortunately…

Yeah I’d made a start and came back with nothing


(Ash Stokes) #178

Worked it out, am I doing something wrong? Still getting ‘system_panel_offline’ from the API.

If you get it accessible through the API in POST, how do you intergrate that with the ST handler?

Cheers,


(Daniel McDougall) #179

Hmmm, I’m at a loss.


(Edward Heathcote) #180

did anyone fix this?


(Mark C) #181

try https://www.yalehomesystem.co.uk/homeportal/api/panel/get_panel_mode
see if you can get the status befor trying to “Set_Panel_Mode”


(Ash Stokes) #182

Yeah ran that through post and seem to still be able to get the status:


(Ash Stokes) #183

Although saying that I then armed it through the app and re-ran the POST and it still showed as disarmed


(Mark C) #184

Looking at your 1st pic, how are you defining/sending the cookie: token?

def token = login(token)
def paramsArm = [
uri: “https://www.yalehomesystem.co.uk/homeportal/api/panel/set_panel_mode?area=1&mode=arm”,
body: [id:settings.userName , password: settings.password],
headers: [‘Cookie’ : “${token}”]
]
httpPost(paramsArm) { response -> // Arming Function in away mode
reply = response.data.message
log.debug “AA - response = ‘$reply’”
}
if (reply != ‘OK’){
log.warn “$device - AA - Status ‘$reply’”
state.mode = reply
runIn(60,refresh)
}
else {
state.mode = ‘Armed-Away’
}
logout(token)
log.info "AA- Status is: ‘$reply’ - mode ‘$state.mode’, "
sendEvent(name: “mode”, value: state.mode, displayed: true, descriptionText: “Arm(Away) System - ‘$reply’, mode - ‘$state.mode’”)