Yale Smart Lock move to NEW Smartthings?

bluf - Not able to fully move existing smart locks from device handler/old Smartthings to new Smarttthings “Smart Lock Guest Access” and be able to see/update door lock codes.

I have several Yale Real Living Zwave smart locks (YRD220) that I installed, connected, programmed nearly 7 years ago using Smartthings original app. If I remember correctly, I set up the lock and installed the device handler for Yale, and used the trusty “Door Lock Manager” to set up 10 codes for the family/friends to access. It worked great for a long time, then the old handler was discontinued - but still worked mostly (notifications stopped).

With the move to the new (device handler-less) Smartthings, the locks still “work”. - I’m able to see, lock, unlock each lock from within Smartthings App, I’m even able to use the manual door codes that were originally set up years ago.

Problem I have now is, while I can enable the “Smart Lock Guest Access” app, AND I’m able to lock/unlock each lock from the client, I am unable to READ or CREATE/Manage any new codes in the lock.

When I go in the client, do “Invite Guest”, enter Name, new code, and select which lock, when I press the “Create Code” button, I get the spinning dialog and message that says “Creating lock code…” after about 40 seconds, I get “Something went wrong” … while creating the lock code. Try again.

HELP!?!

  1. I NEED to be able to CREATE new codes, as well as manage old if possible.
  2. Has anyone any experience bringing this lock into the new smartthings?

Suggestions? Thoughts?

If the lock is still using a default or custom DTH, then SLGA isn’t going to work for programming codes. You’re going to have to migrate it to an Edge Driver. It should be migrated by the ST team at some point, but if you need to make code changes now, you will have to do it yourself.

First, while your lock will be supported by the stock ST lock Edge driver, there are some bugs in that driver and some missing features. I would suggest installing the beta version of the Z-Wave Lock PH driver from @philh30. In particular, it fixes a problem with lock code names being reset periodically and it exposes lock codeName for use as a trigger in Routines.

Next, if you have Routines that are using your lock, you need to decide if you can live with those Routines being deleted if you exclude/include your lock to switch the driver. If not, there are a couple of options to keep them from being deleted such as creating placeholder virtual devices you can add to the Routines temporarily.

In order to migrate from the custom DTH to the Edge driver, you will need exclude your device from your network and then go into the IDE and delete the custom DTH. Once you do that, you can add your device back to your hub and it should pick up the Edge driver you installed. You can check if the Edge driver is picked up by going into the device’s detail panel, click on the 3 dot menu, and see if the Driver option appears. If so, then it’s on Edge and you can see which driver is installed and switch drivers if necessary.

Your programmed codes are still going to be in your lock and will not be deleted and will still work. When you first go into SLGA, the code names will be based on the slot number, i.e. Code 1, Code 2, Code 3. You can give them friendlier names that will stay in SLGA unless you change drivers as the code names are maintained by the driver.

Hopefully this doesn’t sound too complicated and feel free to follow up here or via DM if you need any assistance.

2 Likes

Bruce… you ROCK!!

That worked “near” perfectly. I was unable to install the Z-Wave Lock PH driver from @philh30, opened the link, tried to install the driver and just got the spinning dialog. I was able to remove the devices, the old DTH, and reconnect the devices, they show up and I see the codes (as you noted Code 1-n). I will try the SLGA and see if it experiences the bug that you noted.

THANKYOU THANKYOU THANKYOU!!
(Im embarrassed to say how much time I wasted searching, trying to debug this).

1 Like

Glad it’s working for you now. Not sure why the driver invite didn’t work for you. I just checked it and seems fine. I’d try again later and you can switch drivers if you get it installed.

2 Likes