Yale Assure SL won’t pair (Zigbee)

Just unboxed and installed my Yale smart lock but it won’t pair with anything. Direction don’t tell much. I am able to get to the needed pairing mode in the locks interface but nothing will find it. These are the services I’m attempting pairing it with.

SmartThings Hub
Amazon Alexa
iPhone Yale App
Xfinity Home

All services are said to support this lock which is why I went with this one. Any tricks to maybe do a reset on the lock? I tried removing the batteries and the zigbee module but nothing changed. Originally, it seemed SmartThings found a “thing” but later saw this deceive to be not connected, so I deleted it.

Reset the lock, and when it finds it as a Thing you’ll need to change the DTH to Zigbee Lock.

Also, what model specifically?


which hub do you have? which app are you using? how close is the lock to the hub? have you tried resetting the lock?

1 Like

What’s the full model number? That device comes in a couple of different variations.

Also, as a zigbee device it will only be able to pair to one coordinator. So it can pair to an echo plus or to the smartthings hub or to the Xfinity home, but not all of those at once.

If you pair it to SmartThings you will also be able to use it with echo voice commands. I don’t know if that’s true for Xfinity or not.

But you won’t be able to use it with both Xfinity and smartthings, you will have to choose.

It sounds like you probably had an unsuccessful pairing with one of those three coordinators and so, as others have suggested, you will have to first factory reset it, then pick the one coordinator you want to use, and get it paired to that one.

You would have the easiest set up with echo plus, but the fewest feature controls.

Also, I may be mistaken, but I believe that the Yale app only works with the Bluetooth version of the lock, which will not work with either Xfinity home or smartthings.

If you need instructions for resetting the lock and it is indeed a zigbee model, they are on the following page:

The instructions in the user guide from the manufacturer are on the page which is called “feature programming“ and it gives you a chart to follow. The function you are looking for is “exit the network“ which removes the coordinator information from the lock.


Ok. Is that done from the SmartThings app? I’m using the newest app and a V3 hub.

How do I change the DTH? There isn’t any options for me in the app. Sorry I’m a bit new to this.

Thanks JDRoberts. That was very helpful. I imagined I would use it with Xfinity home but after I was just able to pair it with that, I noticed I can’t set a routine and have it lock the lock like I wanted to. So I’m now thinking I’d like to use SmartThings as my coordinator as I believe I can accomplish this task with SmartThings.

1 Like


login to IDE at https://account.smartthings.com and choose My Devices from the menu. Find your Thing in the list and click on the display name, click Edit at the bottom of the screen, in the type field click on the pull-down menu and find/select Zigbee Lock then click Update at the bottom of the screen. Go back to the ST app, you may need to refresh it and try your lock


doesn’t allow me to change type

is there an Edit button at the bottom of that screen?


Yes. Thank you! Let’s see what this did.

Hi Mark,

Sorry I didn’t get back to you last night. We had some pretty bad storms come through and I needed to work with ST support on a hub problem I had before calling it a night.

Did you get the DTH changed, and is it working?

Thank you. So yes, I managed to get it working and now also showing in Alexa app as well but I’m not sure its full featured. I can ‘‘lock and unlock’’ but I’m unable to rename it from '‘thing’ or able to set a routine to lock it at night automatically. Maybe it’ll just take some tinkering around in both apps.