SmartThings Community

Xiaomi Zigbee Door/Window Sensor, Motion Sensor, & Smart Button Device Type [beta]

dth_motionsensor
dth_remotes
dth_sensors

(Eric M) #21

I have posted the device handler for the motion sensor.


#22

Thanks a lot Eric. My sensors should be here within a couple of weeks. I will then test them extensively.

If they are stable and even better if you could fix the battery status issue, you may save a lot of people a lot of money.
Aside from the cost, the Xiaomi branded sensors (especially the door one) are very small and good looking.


(Udit Batra) #23

Anyone try these sensors with v1 hub? Any success there?


(Eric M) #24

They do not currently work on v1 hub. They drop off the Zigbee network after about an hour of inactivity. This used to be the case with v2 as well until the 2/29 update. So, it is possible that a firmware update could fix it on v1 too.


(Eric M) #25

I am completely dumbfounded by these sensors. I have been using the SmartButton, Door Sensor, and Motion Sensor for over 1 week without any issues at all. Yesterday, I went to add another Smart Button and noticed afterwards that the three original devices didn’t seem to be responding. Tried to rejoin them all and now they are dropping off the network after an hour of inactivity.What the heck?

After some testing, I was even getting what seemed to be battery reports from them. Sorry to get everyone’s hopes up, but it seems I still don’t have these sensors figured out. :frowning:

Will post back if I make progress.


(Udit Batra) #26

That sucks, hope you make some progress.


#27

Oh man, this is bad news!!

Please keep us posted. My sensors (thank God, only three of them) are on their way to me.
Maybe a better (not as cheap) option would be to use the Orvibo sensors that are Zigbee HA compatible and should therefore work out of the box.

Thanks again for trying.


#28

My Xiaomi sensors just arrived. I will begin testing today and get back to you.


(Rob Stokes) #29

I got a sensor delivered yesterday. I can confirm that mine also drops out after about an hour.
Hub firmware version: 000.014.00032
Let me know if I can help test anything!


#30

Hi @erocm1231,

Hope you are doing well. I have just connected two door and one motion sensors.

Motion sensors reports motion and then gets stuck at motion. Is there a way to resolve this!

Also, door sensors have a configure button that does not do anything.

I will provide feedback regarding the stability of the connection in a few hours,


#31

After leaving the door sensors alone for about 5 - 6 hours I can confirm they are still connected.


(Marcus) #32

I also just received a button and a door/window sensor. I will report if and how long they stay connected :slight_smile:


#33

And just like that all three sensors of mine got disconnected.


#34

UPDATE: After 10 hours the sensors are working again. I have done nothing in the meantime. Did not reset and did not re-pair them to the ST hub. Any ideas what is going on @erocm1231?


(HONGTAT TAN) #35

I got the 3 sensors delivered yesterday and can confirm they drop connection after about an hour. Tried reset/repair, no luck.

Is there any way to integrate/hack the Xiaomi gateway?


#36

UPDATE 2: It seems that they again lost connection.


(Marcus) #37

i can also confirm disconnect of Button and Window Sensor. Didnt use them for 2 Days… coming back home and they do not work anymore…

Will try it now with Pollster & hourly refresh… lets see if this works.


#38

This is a good idea. Let us know what happened.


(Marcus) #39

Nope… lost connection over night… maybe 1h is not enough… will try it again with 10minutes.


(HONGTAT TAN) #40

I tried with Pollster, 5 min interval, doesn’t work.