Xiaomi Zigbee Door/Window Sensor, Motion Sensor, & Smart Button Device Type [beta]

to help search github does anyone know the exact name of the file?

Can you confirm what you are looking for?

Are you looking for the SmartThings DTH for the Xiaomi Temp Sensor?

yes the generic temperature handler that rave assigned to the xiaomi temp/humid sensor

@EICide @a4refillpad just created another Xiaomi DH. This time for the temp and humid sensor post on this is here [RELEASE] Xiaomi Sensors and Button (beta)

hello All,

I just got my first Xiaomi door sensor today. Having trouble decoding from the thread how to pair. Do I also need a Xiaomi plug? Could someone please list out the steps? I am not seeing in ST logs any debugs on the sensors

thank you
-b

Manually add the contact sensor DTH from the post right above yours (here: [RELEASE] Xiaomi Sensors and Button (beta)). After that, go into add a device in the SmartThings app so it’s waiting to pair. Move within a foot or two of your hub, and use a pin to push the button on the sensor every second or so until it finally shows up in the app. Might take 10 seconds. Might take an hour. No rhyme or reason, but it should pair eventually. The battery reading won’t show up for awhile in the device UI in the app.

2 Likes

Note that I’ve had good results by pressing and holding for three seconds until it illuminates then pressing the butting repeatedly until it pairs.

3 Likes

I have jusr received one of these but it doesn’t want to pair.
Anyone else got one of these paired.
If so, is just by persevering with the button push.
{I’m talking about the humidity sensor btw}.
EDIT. Ah. Think I found how to do it. Post 745.
EDIT 2: That didn’t work. Blast…

You pair exactly how @brumster described in post 745.

1 Like

Thanks @a4refillpad
I’m not seeing anything with ‘catchall’ in it.
I can see zwave start etc.
Sorry to labour the point but should I see something that says ‘catchall’?
EDIT: The catchall has appeared. Horay.
EDIT2: All configured and paired OK. Temp and humidity quick to react.
Great little device and more importantly, great DTH.
Thanks @a4refillpad for you work in providing DTH for all the Xiaomi range. Your a star.

2 Likes

thank you @paulmike3, @brumster. It worked perfectly after few tries.

1 Like

Big big big Thank you 452 post read and now it’s work THANK :smiley:

1 Like

Just an update, on the beta 17.10 and existing sensors are working ok (except for one that dropped a few days ago), but for the life of me I can’t get new sensors to connect. Not seeing a catchall in the IDE either.

Make sure you provide feedback to the beta folks about this. Hopefully we can prevent them from breaking these sensors by alerting them when the beta changes things.

1 Like

I’m on the beta and have added 4 contacts with no issues…

1 Like

Are you seeing the catchall? Not seeing them on any of my new sensors.

Yes, that’s the only method i use to add devices.

Interesting, let me try again this evening and see what happens.

I added a Temp sensor yesterday. Didn’t see a catchall at my first few attempts and gave up.
Then tried again and it appeared OK in the events.
Perhaps keep persevering.

I just use the method of clicking in a maniacal manner for a while then look in the hub event for the last catchall. Normally I see quite a few using this method and I pick the most recent one. For contact sensors it’s even easier to tell if it’s paired properly. If you put it close to the magnet and the led lights up then it’s an indication it’s not in a paired state. Time saving tip!

1 Like