Xiaomi Yeelight RGBW E27

dth_lighting
requires_server

(George) #202

Thanks, appreciate your work here!


(Craig Inskip) #203

Hi Guys,

Forgive me for sounding completely new as I have just ordered a ST hub and am checking out some of the integration of some of the stuff.

I have setup my IDE account and created the DTH from the code listed by Simon.

I assume then I head to create a new device, and use the DTH as the device type.

Am i right in thinking that the “Device Network Id” is just the IP address of the Yeelight?
(Trying to setup the light strip)

Thanks very much


(Simon Tether) #204

Device Network Id can be anything you like.

Once setup, goto the app and select the device and the click on the cog in top right

Enter your IP there

Cheers


(Craig Inskip) #205

Thanks Simon. Havent actually got my ST hub yet so will let you know how I get on when it comes. :slight_smile:


(Craig Inskip) #206

Just a quick update:-

My ST hub came the other day… Set it all up and got the yeelight into ST with no issues.

Thanks for all your hardwork Simon.


(Simon Tether) #207

Glad it works for you.


(Gareth) #208

What sort of response time is everyone experiencing? I can control the device but it seems very delayed - sometimes responding immediately and sometimes in a matter of seconds. Just trying to understand if this is a local issue or just the way it works at the moment.


(Simon Tether) #209

Yes i noticed that delay too, nothing I could do to speed it up. If I control the yeelight directly with packet sender it is instant sonmust be the smartthings cloud delay ?


(David Jacobs) #210

Very slow for me too. DEfinately seconds maybe up to 5 secs


(Arthur V) #211

Thank you! this is great! finally got rid of IFTTT delay and it even works with the new connect app…


(Pardal) #212

Nice work! But the delay is crazy…


(Simon Tether) #213

Yes, I have tried everything, if you watch the logs and wait until the parse gets a response (which is 5-10 secs), it works right away. I’ve posted in the developer’s section to see if anyone can help


(Arthur V) #214

I’m using it mainly as on off and theres no delay… changing colors is taking ages tho…


#215

Hi, i’m trying to add a yeelight Color bulb but i can’t connect with success.
I just installed the SmartThingsYeelight_DTH.groovy with success, then i added a yeelight device. Right after, i opened the app and added the IP, and after that trying to turn on or turn off the light, it says that is turned Off/On, but the light remains On (if i tried to turn off) or Off (if i tried to turn On)

I’m doing something wrong?


(Ryan) #216

Im also getting the same thing as @Ifoliveira. The yeelight app did have me update the firmware. Maybe new firmware broke something? Edit- turned on lan control to get it to work duh…


(Ryan) #217

In the yeelight app, click on the light and on the bottom right is a little arrow symbol. Go in there and turn on lan control.


#218

Missed that too :slight_smile:
It works now :slight_smile:, thanks @Hofrya .


(Murdo Macleod) #219

Hi, I’m very new so please excuse my general ignorance. I have actually managed to get the device handler/smart app into the smart home app, it’s listed as Yeelight On and Off and with the LAN on in the Yeelight app I can successfully control 1 Bulb.

So how exactly do I go about controlling the other Yeebulbs I have?

The smart app doesn’t seem that intuitive I had thought I could just copy what I have working and change the bulb IP address to get the 2nd bulb under control but can’t see how to do that


#220

If i understand, you need to add more devices (repeat the process for each one)


(Murdo Macleod) #221

Thanks for that :slight_smile: that’s exactly what I need to do (doh) I 'm finding this quite a step learning curve but am picking it up slowly.