Wyze Cam as motion sensor HELP

In the new app, trying to accomplish this. Made a standard Virtual Switch to allow IFTTT to use camera motion to turn the Virtual Switch ON, but I’m not having any luck turning it OFF when motion stops or even after a certain amount of time after the switch is set to ON. “Timer” setting within the virtual switch settings seems to be a one-time event, based on the actual current time, so that’s not working. Any help would be appreciated.

I don’t believe wyze exposes an inactivity trigger for its cameras, does it?

But you should be able to use smartlighting in the new V3 app to set up a “power allowance“ rule for the virtual switch so that it automatically turns itself off after X number of minutes. Then it would turn on again the next time wyze reported a motion trigger to Ifttt.

Don’t know if that helps or not.

2 Likes

They don’t expose camera’s motion or sound inactivity, only activity. They do both with their sensors, but not cameras. That “power allowance” rule, is that part of the device’s options and settings? In this device, I can see Timer, Power On and Power off. The last 2 are basically useless in this application since they turn this switch on and off at the pre-determined time.
The Timer, I thought, could be set to 1 minute, for example, to turn it off, but it’s not doing that. It seems to start count-down from the time I set that timer, not from the time the device was turned on. Plus, the new update broke the custom timer setting time selector. Minutes disappear as soon as the wheel is moved to select 5, for example.

“Power Allowance” Is an automation that you create in the official “ smartlighting” feature. You pick the device that you want to turn off and then you can set a fixed period of time like 15 minutes or three minutes or anything down to one minute. After that, every single time that you turn that device on it will turn itself off after that amount of time.

Start by choosing the three line menu in the upper left of the beginning screen.

Choose Smartapps.

Choose smartlighting.

Choose new smart lighting automation.

Choose your virtual switch.

Choose “turn off.“

Then for “trigger” go all the way down to the bottom of the selections and choose “power allowance.“ Then you’ll be able to set the number of minutes.

This will be the end result:

3 Likes

Ah, I’d never find it myself. Learning more every day. Thank you so much!

1 Like

We often say smartthings is very powerful but not very discoverable. :sunglasses:

True. Now, how do I cut the time delay between Wyze Cam motion and Virtual Switch reaction down from current 6-9 seconds? Is there a polling interval setting?

That’s in IFTTT, and there’s nothing you can do about it. :disappointed_relieved: Some people find it’s longer than others. Some find it varies a lot from day to day. At my house it’s a pretty consistent eight seconds, which sounds similar to yours. So it’s just a question of if that fits your use case or not.

I was going to replace my garage Motion Sensor with the Wize Cam that’s mounted next to it, and use just the Wyze Cam motion , but that 8-10 seconds (more at times) is way too long. I have a routine that closes the garage if the garage is open AND if no motion detected for 5 minutes. That 10 extra seconds is a killer here… ST reacts to motion present 10 + seconds AFTER motion has ended. Oh well, it was worth a try and I learned something new. :slight_smile:

1 Like