WorksWith / Centralite In-Wall Dimmer

dth_wallswitch
dth_lighting

(Brad) #1

Picked up a WorksWith In-Wall Dimmer from Best Buy when it was on-sale. It is just a repackaged Centralite in-wall dimmer. In fact, “WorksWith” appears to be owned and operated by Centralite from what I can tell. This device type should work with any other repackaged Centralite in-wall dimmers. I believe they are the Azela model that you can find on their website.

http://www.bestbuy.com/site/workswith-in-wall-dimmer-switch-white/1474036.p?id=1219498404350&skuId=1474036

Once the dimmer pairs with the SmartThings hub the buttons stop working on the paddle to turn on and off the light. Instead it sends a button pressed message to the hub and the hub is responsible for replying to the dimmer to turn it on and off. I also could not figure out how to differentiate between pressing the up or down paddle or how to have it dim from the paddle. I am not sure it is even possible. It just sends the same command back to the hub no matter what you press or if you press and hold. So my device type just turns the light on or off depending on its current state. It does dim just find from the SmartThings app.

It also does not report or take in the brightness level correctly. 39% is the max. I adjusted the device type to compensate for this, so everything should dim correctly and the dim level is reported correctly back to ST.

The dimmer is a little pricey at Best Buy right now. But I have a feeling these may get discounted again, so I hopefully this helps out someone in the future!

I have the fingerprints set, so if you publish this device type prior to discovery it should discover it just fine. Otherwise, it will be reported as a “Thing” and you will need to go in and switch it.


(Lighty) #2

I picked up a few of these. Thanks! How do I add this?


(Kavery3141) #3

I really hate to bump this thread, but I had a question about fade rates on these dimmers. I used your handler, and it pairs up and works fine. I’ve always noticed that with these dimmers, if you use them as standalone, you can hold the button and the light fades up until you release. Once you pair it up, it seems to just be a hard level set on the dimmer scale. I was wondering if anyone may know how to modify this to fade to level. As it is now, I have one rigged to motion in the kitchen, and when it is very dark, you kind of get a jolting effect when the light kicks on to 50%, rather than a nice fade up. If anyone has any ideas on how to tell this thing to fade from 0, that would be effing awesome. Thanks


#4

I don’t know if this model supports ZigBee transition values, the GE ZigBee dimmers do not. I too did not like that it would not fade so I wrote a handler that would simulate the fade on/off. Since it is not native, manual presses of the switch do not fade and the current dim level of the switch always goes to 0% when off. If you are willing to live with those caveats you can try my DTH below.


(Kavery3141) #5

Awesome. Thanks for the reply. This Centralite doesn’t seem to like it. It still just pops on and off, but I see the fade simulation in the app. I’m a noob and not a programmer, but tend to learn enough to be dangerous. I’ve been sucked in pretty quick. I’m going to study the differences between the two handlers and play with it. Again, much appreciated. I have 9 of these things that I acquired and had lying about. I’m glad that I found your DTH to even make them work at all.


(Kavery3141) #6

wait, it works…i set the time to 15. The only thing now is the max 39 issue, but frankly, that’s not a biggie. I’m really just automating that light for motion. Not feeling like a paparazzi jumped out and shot a camera flash off in your face is amazing. You are my hero tonight. Much appreciated.


#7

Not sure what that issue is? Glad it works for you.

Oh, one other thing. If you choose to go with a different DTH later, you’ll likely need to reset your switch as this DTH sets the turn on to value which will mess up native DTHs.

Lastly which I should have mentioned, you should also try the native GE Link DTH. It supports the transition optional ZigBee attributes. If the CentraLite does support those values, that DTH will work better for you.


(Kavery3141) #8

This dimmer reports 39 value when it is really at max 100. The OP had written piece in to account for it in his DHT and have it read correctly in the app. Minor annoyance. The light still works correctly.Thanks again.


#9

As a note this may cause a problem with my DTH. If you just turn off the switch, then turn it back on (do it twice to confirm) it will likely only turn back on to 39% instead of back to 100%. That is an annoyingly strange bug.


#10

You’d need to turn this section

if (event.name == "power") {
        if (device.getDataValue("manufacturer") != "OSRAM")  {       //OSRAM devices do not reliably update power
            event.value = (event.value as Integer) / 10             //TODO: The divisor value needs to be set as part of configuration
            sendEvent(event)
        }
    }
    else {
        sendEvent(event)
    }

Into something like this

if (event.name == "power") {
        if (device.getDataValue("manufacturer") != "OSRAM") {       //OSRAM devices do not reliably update power
            event.value = (event.value as Integer) / 10             //TODO: The divisor value needs to be set as part of configuration
            sendEvent(event)
        }
    }
    else if (event.name == "level") {
        if (device.getDataValue("manufacturer") == "CentraLite Systems") {       //CentraLite devices do not reliably return level
            event.value = (event.value as Integer) * 2.56        //TODO: The divisor value needs to be set as part of configuration
        }
        sendEvent(event)
    }
    else {
        sendEvent(event)
    }

I’m not sure if that will work. Just a guess.


#11

This would fix your slider bar back to 100%. Also I see why this bug exists. CentraLite apparently uses 0-100 as their values when spec states it should be 0-255. 100 divided by 256 = 39%

Edit: You are right. If you make the change I have above things will break. Just use my original DTH and you should have no issues other than the 39% problem. If I have time I can incorporate the code above into my DTH but additional changes would also need to be made.


(Kavery3141) #12

yeah, i tried it and it gave me errors. I like studying it though. It works as it is. If you end up playing with it I’d be glad to have it. Your DHT definitely made a world of difference in how pleasing the light comes on from that motion trigger, especially when your eyes are adjusted to dark. It kind of made you dizzy. :wink: