(Working ) Smartthings Hot Tub / Aquarium / Whatever water sensor

Hi all, not sure how much use this will be to anyone but thought I’d share.

I’ve been trying to sort this out for around 2 years (on and off!) and I’ve had several failures and a bit of wasted cash. Recently I thought I’d take another crack at this, and after having had discussions in several threads, a few pm’s and a bit of trial and error, here’s the result.

So to be clear, this consists of (currently) 3 temperature sensors (there can be 1 to 4), mains powered, with accurate temperature reporting every 20 seconds (default). The purpose of this was to find a way to check out the temperature of my hot tub, to improve an existing project of mine to heat the water by gas. I wanted to be able to view the hot tub temp remotely, and also have more control over setpoints i.e. wanted to have a ‘maintenance temp’ mode along with a ‘cozy temp’ etc. Possibilities are literally endless via smartapps.

Side project summary :

  • 12v DC adaptor
  • Inkbird ITC-308S Dual Relay Digital Temperature Controller Thermostat for Heating & Cooling Device Pre-wired Sensor Probe (ITC-308S + 12" stainless long NTC sensor)(https://www.amazon.co.uk/dp/B01AWA2PQY/ref=sspa_dk_detail_2?psc=1)
  • ^ Connected to a smartplug
  • 12v water pump
  • tankless water heater
  • 14KG propane tank

Switch on the smartplug, this powers the thermostat. Thermostat is programmed to activate its heating socket if the temp is below 39 degrees. DC/pump is connected to the heating socket. So hot tub too cold? Pump sucks water from tub, into tankless heater, which ignites and warms existing warm water spitting back into tub. Process continues until its probe shows at least 38 degrees. To prevent a constant cycle of checking/heating, the smartplug is controlled via smartthings.

Problem with this system ? Temperature can’t be monitored remotely. Setpoints need to be set locally on the thermostat.


I tried using the old ziplock / multipurpose sensor in the tub. The reaction time is way too slow and the reporting period is far too long. The tub would visibly reach 39 degrees and the multipurpose sensor was still reporting 26 for half an hour plus. I tried buying a fibaro fgk variant, and just never really had much luck. Plus it’s really expensive at around £40 for the battery powered sensor, and I think it might have only been designed to take one probe (might be wrong). Anyhoo, never could get it working.

So here’s the list of components needed:

Pretty much £50 in total, along with a cheap plastic box from screwfix and some of those terminal strips for convenience (the wires on the fibaro are incredibly small) image

Assembly and software felt a bit hit ‘n’ miss. the important thing to remember is that all the hardware must be connected BEFORE the fibaro is powered up and added to to your smartthings hub. Consider that if say, you set it up with one probe only, install it all and get it working, adding another probe is not just a case of connecting another. I found I needed to power down, remove it from smartthings via the app and force remove. Then I needed to follow the fibaro reset procedure to set back to factory defaults…

Universal Binary Sensor - " Reset "

  1. Disconnect the power supply.
  2. Press and hold the B-button.
  3. Connect the power supply while holding the B-button.
  4. Wait around 10 seconds.
  5. Release the B-button.
  6. Disconnect the power supply.
  7. Connect the power supply again.
  8. After few seconds the device will be reset .

…then add the device again by following this method:

  1. Click ‘add device’ to set smartthings hub into pairing mode.
  2. Power on the fibaro
  3. quickly click the “b” button (there’s only one) 3 times.
  4. Wait for it to add.

This for me was the most clumsy part, there’s no indicators on the module at all. I often cancelled and retried. Eventually the device would show (it only ever took a minute or 2) and I could save/pair it. Shows up as a ZWave Device Multichannel.

Once this is done, need to then log in and change the DTH to this one by cjcharles . Here’s the thread ([RELEASE] Fibaro FGBS-001 Universal Binary Sensor (UBS)) and here’s the github link (SmartThings/Fibaro FGBS-001 UBS at master · cjcharles0/SmartThings · GitHub).

Once the device is using the new handler, you’ll see the screen in my third image near the start of the post. I found at this point I almost gave up again, as the temperature reading still weren’t showing. It seems a poswer off/on was required before things would start working for real, although your mileage may vary).

Anyhoo, this is all working now and I’m very happy with it. It feels like after a hell of a lot of searching, reading, asking, the solution’s actually very simple.

I wish I’d been able to read this thread myself 18 months ago.

Enjoy !


now you can finally relax in your tub

good notes.

1 Like