Wireless Sensor Tags Integration

Unfortunately, I haven’t been very happy with the WST to ST response times lately. Last week I put in a different motion sensor in my kitchen to cut down on the lag.

The ST motion sensors are battery hogs. I have a few others. I’m now happiest with the big, ugly Ecolinks. They are really fast and the batteries last forever.

The WST come in handy when you need motion detection at a distance. They transmit so far. . . I have one in my garage controlling some LEDs. I couldn’t get a zwave or zigbee signal in there. . …

That is great, thank you. Are you still liking the other tags for leak, temp, etc?

I have about a dozen WSTs. I really like the data they provide. They do work for ST integration, but the motion detection can be a little too laggy. ST in general isn’t exactly snappy. . . . .

I’m using one of the WST sensors to trigger a fan in my server room if the humidity gets too high. I have another controlling the leds in my garage. I just wanted the main kitchen light to be more responsive.

I’ve got three WST’s that I’m using to monitor the temp and humidity in my humidor. I then use WebCoRE to turn on smart switches to regulate the temp and humidity. I also get a daily notification from ST that tells me what the temp and humidity are. Overall I’ve been happy with the tags and have been using them for just over a year.

I just ordered a hub and some tags. Are you using the original code or the recently updated code from above?

I am using the original code with a device handler that I modified. It’s been work flawlessly for over a year. Cheers!

Hi, I started using a pro tag to monitor a wine cellar. It’s been working well with ST but I’m wondering if there is a way to increase the decimal on the temperature value received in ST. Right now it’s only reporting round temperature with no decimal and given the potential level of precision from the tags (stated at least), it’d be great to be able to adjust this. What are your thoughts?

I’m sure it can be adjusted somewhere in the device handler code. Not sure exactly where though. Maybe someone with more coding experience can chime in.

I looked at the device handler code and cannot figure it out. I’m wondering if the value sent by the wirelesstag is just an integer and therefore the decimal cannot be pulled from st.

Would love to hear you guy’s opinion?

I see this thread has been a little dry lately. I have been using the temperature sensors and they work really well for that. And, as others have mentioned in this thread, you can’t beat the distances.

What I can’t seem to get is the battery level of these things. In the Smart Things hub and this code, it doesn’t seem to match what the actual battery level is. I have had a couple of these sensors battery go dead and I didn’t find out about it for a couple days. I use Smart Rules and I would like to set up a rule that monitors the battery level and when it goes below a certain level, I get alerted and I can change the battery.

Anyone else seeing this behavior with the battery level reporting?



I have followed all the setup instructions to the t ,a couple times now. When I try to add the app in the ST interface on my phone it says “something`s wrong we can’t load your screen right now” it has a retry button at the bottom but it just gives me the same error and adds a new nonfunctional instance of the Wireless Tags (connect) to ST. What the heck am I doing wrong? Please help! Thanks

Through the SmartThings IDE, make sure you enable oauth for the SmartApp. Go to the SmartApp then click App Settings then scroll down until you see OAuth. Click it then click Enable OAuth in SmartAppo. If you haven’t done this already, you’ll get the error you are seeing.


I’ve been using the Wireless Tags/Smartthings Integration for a couple of years now - with great success! Lately though the Motion sensoring/acceleration capability has stopped working for all my devices (IR sensors and Sensor Tags). Temperature, Humidity, Light on/off still works perfectly.

Has anybody experienced the same or knows how to fix it?

I’ve try a factory reset of my Smartthings Hub, deleted/re-established the link between Smartthings/wireless tags account, reinstalled Wireless Tags SmartApp and DeviceHandler but nothing works!

Any help appreciated, thanks!

Best Regards

Sorry to bring this thread back from the dead, but I just got some wireless sensor tags and I would also really love to be able to see a temp with decimal point in the Smartthings app.

@asmuts or @swanny do you know if that’s possible? Thanks for sharing your work on these device handlers!

Yes. I changed mine when I first implemented it:

return celsiusToFahrenheit(celsius).toDouble().round(1)

1 Like

That seems to work, thank you!

In the setup instructions you say to create a new device “type”. Is that the same as a New Device Handler or is that just creating a New Device?

See the community FAQ on custom code. It will explain the terminology used and the basic process. (The topic title is a clickable link)

I have three WSTs (2 humidity/temp sensors, 1 moisture sensor) and the WST hub. They’re all hooked up and working fine. I’m using them along with IFTTT to control a room humidifier. But now I’d like to make use of the ST integration to control some other stuff. I’m having problems getting the tags added into ST. I’ve read the community FAQ several times, but am still puzzled. Here’s what I’ve tried to get them into ST:

  • In the ST IDE I created a new smart app copy/pasting swanny’s (and asmuts) code as instructed here and in the FAQ, turned OAuth on for the app, and published it to myself.
  • In the IDE I created a new Device Handler from the published code.
  • In the ST iOS app (I’ve tried both the Classic and new apps) I add the newly created WST smart app. I can see it in my list of smart apps (on the phone), then tap on it. It asks me for my WST login credentials, then seems to log in fine (it says I’m connected). I grant access, say OK and it says my WST account is connected to ST. Great. Then in the next step it asks me which WST devices I want to add. It lists my three devices and I’ve tried selecting all three, or just one. When I tap Done to go to the next step, I get and error: “Something went wrong…” in the New ST app, or “An unexpected error occurred” in the classic app. I’ve tried deleting and recreating the smart app in the IDE, killing the iOS app and restarting it - to no avail.

I’m wondering if my mistake has to do with getting the device handler associated with my actual tags. In the FAQ under Using a Custom Device Handler it says I should already have the devices added into my ST account. But how do I add them? When I try to add a device in the iOS app, the tags don’t show up after a scan (in either the new or classic apps). And I can’t add them manually because WSTs aren’t in the list. The community FAQ suggests, for devices that don’t show up in a scan, creating a dummy device in the IDE, assigning it a unique Device ID, then assigning the WST handler to it. I tried that, but how does that actually get associated with one of my WSTs?

I’m missing something here, and probably a few brain cells. Help appreciated!

4/20/20 Update

In case anyone runs into a similar issue, I checked the error log in the IDE. Turns out it couldn’t find the motion DH. I hadn’t installed it because I don’t have any WST motion sensors. I installed that DH, and now all if fine.

1 Like

Hello Swanny. Are you still available for questions about your Wireless Tag Integration with SmartThings? I’ve attempted to use your code but there seems to be a couple of errors within the code and it will not allow me to continue past the first part of your instructions. Thank you!!! - Bill