Wireless Sensor Tags Integration

Can you tell me where I can find your updated code? Thanks

Hi Richard,

A real shame that there have not been many updates. Think WST have had changes on their side that could be updated at thins end but this is way above my understanding. I am actually trying to move away from them at the moment. Just trying to find a nice suitable (tiny) replacement for my letterbox tag which can pair directly to ST. Going to use WST as a backup system completely separate from ST.

Anyway, here are the latest DH’s, well from what I can find…

Oh and as a FYI you can search GH for accounts etc. Many on here use the same UID.

1 Like

Hello @asmuts - i wanted to check in and see what kind of response times you see on the motion events? Would you still recommend going the custom smartapp route for these devices? How many seconds does it take from walking into a sensor to the event posting in smartthings?

Thanks!

Unfortunately, I haven’t been very happy with the WST to ST response times lately. Last week I put in a different motion sensor in my kitchen to cut down on the lag.

The ST motion sensors are battery hogs. I have a few others. I’m now happiest with the big, ugly Ecolinks. They are really fast and the batteries last forever.

The WST come in handy when you need motion detection at a distance. They transmit so far. . . I have one in my garage controlling some LEDs. I couldn’t get a zwave or zigbee signal in there. . …

That is great, thank you. Are you still liking the other tags for leak, temp, etc?

I have about a dozen WSTs. I really like the data they provide. They do work for ST integration, but the motion detection can be a little too laggy. ST in general isn’t exactly snappy. . . . .

I’m using one of the WST sensors to trigger a fan in my server room if the humidity gets too high. I have another controlling the leds in my garage. I just wanted the main kitchen light to be more responsive.

I’ve got three WST’s that I’m using to monitor the temp and humidity in my humidor. I then use WebCoRE to turn on smart switches to regulate the temp and humidity. I also get a daily notification from ST that tells me what the temp and humidity are. Overall I’ve been happy with the tags and have been using them for just over a year.

@seeharrison,
I just ordered a hub and some tags. Are you using the original code or the recently updated code from above?

I am using the original code with a device handler that I modified. It’s been work flawlessly for over a year. Cheers!

Hi, I started using a pro tag to monitor a wine cellar. It’s been working well with ST but I’m wondering if there is a way to increase the decimal on the temperature value received in ST. Right now it’s only reporting round temperature with no decimal and given the potential level of precision from the tags (stated at least), it’d be great to be able to adjust this. What are your thoughts?

I’m sure it can be adjusted somewhere in the device handler code. Not sure exactly where though. Maybe someone with more coding experience can chime in.

I looked at the device handler code and cannot figure it out. I’m wondering if the value sent by the wirelesstag is just an integer and therefore the decimal cannot be pulled from st.

Would love to hear you guy’s opinion?

I see this thread has been a little dry lately. I have been using the temperature sensors and they work really well for that. And, as others have mentioned in this thread, you can’t beat the distances.

What I can’t seem to get is the battery level of these things. In the Smart Things hub and this code, it doesn’t seem to match what the actual battery level is. I have had a couple of these sensors battery go dead and I didn’t find out about it for a couple days. I use Smart Rules and I would like to set up a rule that monitors the battery level and when it goes below a certain level, I get alerted and I can change the battery.

Anyone else seeing this behavior with the battery level reporting?

Thanks,

Cliff

I have followed all the setup instructions to the t ,a couple times now. When I try to add the app in the ST interface on my phone it says “something`s wrong we can’t load your screen right now” it has a retry button at the bottom but it just gives me the same error and adds a new nonfunctional instance of the Wireless Tags (connect) to ST. What the heck am I doing wrong? Please help! Thanks

Through the SmartThings IDE, make sure you enable oauth for the SmartApp. Go to the SmartApp then click App Settings then scroll down until you see OAuth. Click it then click Enable OAuth in SmartAppo. If you haven’t done this already, you’ll get the error you are seeing.

Hi,

I’ve been using the Wireless Tags/Smartthings Integration for a couple of years now - with great success! Lately though the Motion sensoring/acceleration capability has stopped working for all my devices (IR sensors and Sensor Tags). Temperature, Humidity, Light on/off still works perfectly.

Has anybody experienced the same or knows how to fix it?

I’ve try a factory reset of my Smartthings Hub, deleted/re-established the link between Smartthings/wireless tags account, reinstalled Wireless Tags SmartApp and DeviceHandler but nothing works!

Any help appreciated, thanks!

Best Regards
BRS

Sorry to bring this thread back from the dead, but I just got some wireless sensor tags and I would also really love to be able to see a temp with decimal point in the Smartthings app.

@asmuts or @swanny do you know if that’s possible? Thanks for sharing your work on these device handlers!

Yes. I changed mine when I first implemented it:

return celsiusToFahrenheit(celsius).toDouble().round(1)

1 Like

That seems to work, thank you!

In the setup instructions you say to create a new device “type”. Is that the same as a New Device Handler or is that just creating a New Device?