SmartThings Community

Wink 2 Hub failed after update, how is SmartThings with:

I think the motion sensors are too slow to be useful for things like turning on lights, but the contact sensors have been working great for me. I’m using my own DTH and my own SmartApp so they’re not running locally, but they still turn the light on within 1 second.

To answer your original question, you can see which devices are running locally by logging into your IDE and going to: https://graph.api.smartthings.com/localDevice/list

Even if your device is shown as being able to run locally, it will only run locally if you’re using the SmartApp Smart Lighting and possibly SHM.

Thanks for getting me to look at Smart Lighting. It had a feature I was looking for, that of turning off a light when motion stops. I also like the way it consolidates the actions.

But I don’t see any local devices listed on my local device list. Now I think it may be because they care Cree bulbs. However, I have another location where I have GE Link bulbs, so I am hoping they will be local there. This is all new to me. Why would Cree bulbs not be local when there is no Cree hub?

SmartThings won’t provide a complete list of which device handlers run locally or explain the logic behind why some do and others don’t.

The GE Link bulbs run locally by default, but to get the Cree bulbs to run locally you have to use a different DTH.

I know that you used to be able to use the “SmartPower Dimming Outlet” DTH with the Cree bulbs to get them to run locally, but I haven’t tried it in a while.

The url to your local device list depends on which server your account is on so it could be any of these urls:

https://graph.api.smartthings.com/localDevice/list

https://graph-na02-useast1.api.smartthings.com/localDevice/list

https://graph-eu01-euwest1.api.smartthings.com/localDevice/list

1 Like

The go control motion sensors are not very good for turning on lights… They are very slow.

I used the iris motion sensors from lowers all over my house… The ones in the purple boxes.

They respond very fast and timeout is about 15 - 20 seconds.

  1. GoControl sensors are not fast to detect motion. You can only judge speed by the time the sensor’s light comes on and then the response to the motion.

  2. You can use the Cree bulbs with the GE Link device handler and they will work locally. Here’s a list of devices and handlers known to be local: FAQ: CONFIRMED: Local Processing - Working Device Handlers

  3. SmartLighting and Smart Home monitor are the only locally executed smartapps. I would try and keep everything local if possible.

  4. If you are using a device handler for the motion sensor, it won’t be local. Use the AEON multi device handler and it will be local.

Thank you. My GoControl sensors appear to trigger a light on almost
instantaneously. But your comments lead me to believe that I cannot use GE
link lights ‘out of the box’. Is this correct? I need to prepare for a Wink
to ST transition with GE link bulbs at my second location.

yes, you CAN use GE link bulbs right out of the box with ST… They are just buggy… that’s all. some users have had them randomly drop off the mesh and become unresponsive…

but, when they work, they work great

That is good news. The reason I was worried is because I did not see GE Link in the list when adding a light bulb manually like I did for Cree. If I did want to add the GE Link manually, which was what I needed to do for Cree (or perhaps I was not patient) what would I select?

Thanks for your response. I now have my home migrated to ST and am planning my cabin which has the GE Link lights.

just go to the bottom of your things list and click add device

Thanks, I will. What would happen if I selected Cree for GE Link, just curious? Some posters here have said the drivers are interchangeable.

I’m pretty sure all of your bulbs will blow out

After a while in here, you will understand @bamarayne’s sens of humor. As a matter of fact, I suggest you add the Cree bulbs, and then go into the IDE and change the handler to a GE Link. They will work normally and act locally in your hub.

2 Likes

Mr bad… They won’t actually blow up

Errr. it is too late. I threw them out and put in regular LEDs :slight_smile:

1 Like

I was planning on doing this (when I figured out how), but now that I have six of them at my house with FIOS they are really speedy. They turn on almost instantaneously with either GoControl motion detectors or the GoControl magnetic switches. But I do want local control in case of a network outage.

I did not mention it because I did not want it to go to his head, but I did appreciate “@bamarayne’s sens[e] of humor” :slight_smile:

2 Likes

Well, this is pretty cool. I went into the IDE and published the GE Link driver for myself. When I get home, I will take one of my spare Crees and test it.

Thanks for the help.

I edited a Cree bulb to use the GE link device and it shows up that way in the IDE and works, but it does not show up in the…/localDevice/list

Any ideas? Also, it appears that in the IDE my hub is not recognized until I edit my location. Then all of it shows up.

That shouldn’t happen. Did you use a custom device handler? If so, which one?

Are you on the correct shard?