Will we have an edge lan driver to control wled?

I believe it is possible. I don’t know if auto-discovery could be supported as these bulbs don’t use the standard multicast port. I’d have to see if the Edge platform would support the port they use. If not then the IP addresses for each bulb would have to be configured by the user, which would be painful! And they’d all have to be static.

I don’t have one of these bulbs, so would have to get one first to test with.

Please find out how many other folks here would be interested in this: Post Requests for Edge Drivers Here (community-created)

@TAustin

Hello, thanks for the attention to reply!

I have a few yeelight products (first generation warm/cold white light, bedside lamp 2 and screenlight bar) and I can test them if I wanted to try developing.

As I understand it, the port they use is 55443.

About configuring manually, I don’t think it’s a problem, given the great gift of local control…

And about static IP, I think almost every router has this option these days. Here in the case practically everything is with static IP.

Is there somewhere I can get more support for this edge driver? I have tried to set it up but my led strips are not responding.

What is your settings?

Hello - Sure, @w35l3y or I can help you. Let us know what your settings are and what exactly do you see in the mobile app?

Do these help?

I from what I was reading this should be the setting.

Make sure to have:

  • API enabled in the wled settings
    • I am not finding this settings. I think this is always enabled.
  • hub ST and wled at the same network
  • unformatted and trimmed text in the Path preference
    • if you copied it, certify that you copied from somewhere that doesn’t accept formatted texts, like notepad. This is very important. Otherwise, formatting will also be copied and Path won’t work properly.

I’m having issues with the WLED driver as well. Trying to turn them on from the ST app does not work. Whatever it’s doing kills the WLED server as well, as the WLED app won’t turn on the LEDs after attempting to do it via the ST app. A WLED reboot resolves this.

The IP is accurate. I left the path at the default as per the instructions.

@TAustin

Sam issue here, can you please assist.

Hi there,

I just installed the edge driver and experiencing a few issues. I can turn on the light strip using smartthings but anytime I want to change the effect, I get a webserver error.

I was wondering what version of WLED was this driver developed for? I would like to install that version on my esp board to see if the drivers acts differently / better.

Many thanks!

I am getting the same error

Hey Guys,

I have recently started developing my own edge Driver for WLED. If youre having Problems with the other one you could try this one. Currently it only supports the basics: On/Off, Color, Brightness and refreshing. I am currently trying to get presets to work though. But until the “Scenes” Capability gets fully implementet by the Smarthings Team, the solution is probably going to be a bit janky.

If you’re Interested you can check out the driver on Github. I’ve added all instructions to use it and all current and planned features there.

1 Like