Why is my setting in "SmartLights" app not working

I want to ensure that SmartLighting turns on lights when I get home after dark. For some reason it does not work for me.
Here is my scrnprnt of the set up:

Did it ever work? If so, you are may be affected by the post-update gremlin that has been impacting scheduled events in SmartThings. It was posted earlier today that a fix is in place. To resolve existing scheduled events that aren’t working, change the trigger time, save it, then set it back to what you actually want and save it again.

If this is a new automation, then check the “Recently” screen in the mobile app to see if presence for Edgar and/or Tanya were actually detected, Before I got my wife an ST presence sensor, she used her iPhone for the purpose. If her phone was in her purse (versus lying in the cup holder or on the passenger seat), presence sensing was very iffy. Having too tight a geofence circle can also be an issue if the phone’s GPS calibration is off.

You might want to kill the “only during a certain time” part, it has been known not to behave as expected. If you tag it to a “night mode” and set the mode to night at sunset it should work as expected.

Yep, it worked for a while and it stopped working for the past few days.
Did they push update to the V2 without my knowledge? Shouldn’t I accept the new changes and agree to update? If so, I have not seen update request coming to me.

Updates are pushed out. You can subscribe to maintenance messages here: http://status.smartthings.com/

You can certainly subscribe, but that doesn’t mean you will be notified when the poltergeist is near your home.

Very true, but at least there wouldn’t be updates pushed out "without their knowledge"
For best results, assume the poltergeist is always near. The trick is knowing when he’s being mischievous :smile:

Loool, that’s true!

I have not been able to get timers or schedules to work reliably in V2. so you are not alone. Wait a couple of months and see if they finally fix it by then.

Haha, nice :smile:


Unplugged my HUB last night, waited about 30 seconds and plugged it back in - reset is done.
Still having issue this morning with my “Morning” routine (which is very simple: At 7am turn on lights and heater and change hub to “home”, that is it). It did not kick in as it was doing last week. So something in the new update must have crashed it. On top of it, now, it is delayed in recognizing my phone being home. Got home last night and was disappointed that my routine did not kick in and door was not open for me. However, after about 5 min home it finally recognized me being home and of course opened the door and did the rest of the routine.

I have to ask, I know is obvious but you took at least on of the batteries out when you unplugged the hub, right?

Mine worked for this exact scenario. Haven’t tested lately.

Has failed 3 nights in a row for just sunset trigger. I need to open a support case… So lazy…

The funny part is, I deleted a trigger and it ran last night. It’s nowhere in my smartapps list yet it still ran. I think they have a huge pile of bugs and problems with the new stuff and are not admitting it.

Super Late to the Party… Howeverrrr, i noticed that you have 2 Android devices that [when present] should trigger your lighting routine… I’ve seen this issue many times before… Please be sure that you have the presence trigger set for Either/Or Each of the 2 Android devices. If the trigger is set to “Both” Android devices, then the Automation will ONLY trigger when BOTH devices are present at the location… Not when ONLY 1 of the 2 devices arrives… Alternatively, you could setup 2 separate automations for each android device… in this scenario, you could have different things/lights/events trigger that are unique to each android user… again, sorry for the late reply… hopefully all is well by now, if not… hope this helped. Cheers! :sunglasses: