Why Am I Constantly Being Prompted to Re-Login in the Android Mobile App?


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #1

I have a number of Android devices that have the SmartThings Android mobile app.
All of them have been logged into (i.e. so they should always be ready to go whenever I pick them up and want to go see what’s happening in ST).
All of them have worked (and do still work once logged in) just fine until now (i.e. the past couple days or so).

Now, for the past couple days or so, on one of them, when it’s been a while (not sure if it’s minutes or hours or what), I go to open it, and it flashes the previously opened screen quickly and then instantly flips over to the login screen.

I log in, and everything works just fine (until I find it needing to be logged back in again).

Now…to make sure we’re not just dealing with a time-out or something, I have it set up on my virtual machine (BlueStacks) as well, and even though I hadn’t gone in there for weeks, I just opened it, and it went right in…no login prompt. So, that just to say, it’s not about a time-out, and it’s NOT about whether or not I’m allowed to have it logged in on multiple devices or not…because after opening it in BlueStacks and mucking around a bit, I went to the one on another Android phone and it also opened right up without a login prompt.

Anybody know what’s up with that?

Thanks. :slight_smile:

p.s. If this thread doesn’t find a fix shortly, I will start a support case, but I wanted to check-in here first, just in case this is a known issue with a simple Community-known fix.


(Convinced ST will never be unbroken…) #2

Try clearing data and cache for the app on the offending device.


(Andrew) #3

I’m having this issue too. I’ve tried clearing the data and cache on the app, but still the problem persists. This is a very annoying bug.


(Ken Do) #4

This is a vexing issue. It just started a couple of months ago.

If they can’t get this fixed, I need to move to another system. I will not, WILL NOT be forced to key in my eMail and password every single time to turn on and off my outside lights. Its faster to walk downstairs and flip the switch.

I don’t need a couple of hundred dollars of no-longer-functioning electronics for this.

Please offer a fix for this, soon.

Also - while we’re at it… lets figure out how to let me delete old or replaced devices. I hit delete or ‘remove’ - it never leaves the screen. I have half my screen filled with devices I’ve renamed ‘dead’ or ‘old’… as I can never remove them.

This was an awesome system until the log in issues.

Thanks