When I Disarm SHM, some of my Hue lights turn on!


(James Napier) #1

Hi All,

I’m having a weird issue with the Secure Home Monitor in that when I Disarm it (or it disarms because of an event), it switches on some of my hue lights. These appear to be the lights that I have selected in the "Alert With Lights’ section of the security configuration.

I’ve tried rebooting the ST box and also the Hue box. I’ve also removed the security configuration and re-created it. None of which has helped.

Is this some sort of bug?


(Tim Slagle) #2

I sent this to our SHM product manager.


#3

I’m having the exact opposite effect. I have my ‘Good morning’ routine set to turn on certain lights. The trouble is, once the routine gets to the “Disarm” portion, it turns OFF the lights. I’ve created a separate routine that only sets the SHM to the ‘Disarm’ state and any lights as you mentioned that are in the “Alert with lights” section turn OFF. Removed them from the “Alert With Lights” and now everything is fine, but no lights when the alarm goes off :frowning:


(Juan Risso) #4

Hi James,
Definitely a bug. I will submit a correction today and we will deploy as soon as we finish testing.
Thanks a lot from bringing this up :slight_smile:


(Ben) #5

I have had this problem on and off for a couple of months. It started just before the platform issues started. I would get Alert with lights whenever SHM disarms either by routine or manually. Sometimes the lights came on. Recently they don’t come but might switch off if they are on but the log shows Alert with lights. I removed SHM for a while and used custom rules. When I went back to SHM the problem returned. Support told me it was a known issue. Removing SHM then reinstalling stopped the Alert with lights for a week then it came back. Just reinstalled SHM again problem gone away for now.


(Brian Diehl) #6

Mine was doing this exact thing last week but has since corrected itself.

It was doing it whether it was disarmed via the keypad or my presence sensor.

Only 2 of my lights were coming on, and they were coming on red which is how I have them set to go if there is an intrusion detection. I have 3 color hue bulbs that are set to go red. I checked specifically to see if the third one was coming on and it was not.

No alerts were being sent, so it wasn’t registering an intrusion. This happened both going from Armed (Stay) to Disarmed and from Armed (Away) to Disarmed.


(jhoff80) #7

Same thing here. It’s happened on and off for 6 months, and the only fix is deleting and reinstalling SHM. I contacted support about it over the weekend, hopefully it gets fixed soon because it’s been obnoxious.

It actually almost seems like SmartThings is remembering the state the lights were in right before the last alert (a false alarm that I immediately dismissed) went off, and now is setting the system back to that every single time I disarm SHM.


(jhoff80) #8

Meant to update this. I was told by support that it’s basically a known open issue with Hue bulbs and Smart Home Monitor. The support rep implied that it had to do with the “Alert with Lights” function, so I removed that part of it.


(James Napier) #9

Great, Thanks. Roughly when do you think it will be resolved - and will I need to do anything in order to receive the fix?


(James Napier) #10

Yes I think you are on to something there jhoff80. I really hope they fix it soon as I don’t like being woken up by my bedroom lights coming on at 7:30am every morning when my SHA goes into Disarmed mode.


(Juan Risso) #11

It should go out on Thursday and there is no need for you to do anything.


(James Napier) #12

Top man. Thanks :slight_smile:


(Juan Risso) #13

Hi James,
Just checking if everything is working ok now.


(Shelley Powers) #14

This is why I disabled SHM. So you’re saying this specific problem has been fixed?


(Juan Risso) #15

Yes, I fixed last week and it went live on Thursday. Please let me know if it worked :slight_smile: