What happened to Button controller app?

One by one I have been having issues with my mini-motes. Button #1 isn’t working on this one, button #3 long press isn’t working on that one etc. I noticed a while ago that when I tried to open the app it would give me the dreaded " sorry but there was an unexpected error " red flag. At the time everything was giving that flag or the " you seem to be having connection issues" so I just chocked it off and went on.
So today I decided I would go through and reprogram them all. Well the " Sorry,but an unexpected error" flag is still there, the only option available once I select which button controller is to remove the app. I even tried to install a fresh instance of button controller and had the same results once I chose which mini-mote to program.

1 Like

Tagging @slagle

I opened a support ticket , but thought maybe somebody had a suggestion since a fresh install didn’t fix it.

Which Button Controller app are you using… the ST version? Try using this Button Controller Plus to see if that helps? @bravenel did the Button Controller+ which greatly improved on the ST version. It can’t hurt. Also It seems I have gotten several status issues from ST so maybe that is the problem as well.

1 Like

I second the same problem.

I have Minimote and I have installed Button Controller app some time ago. I didn’t use Minimote for a pretty long time, because usually Alexa takes care of light management. But when I tried to use Minimote today it didn’t work, so I tried to find Button Controller app to check what is the problem, but I didn’t find it neither in the Smarthings app nor in IDE. It simply disappeared. When I tried to reinstall it from the MarketPlace it allowed me to choose Minimote on the first step, but on the next step it gave the same “Unexpected Error” message. What has happened with the app? @slagle, please find out.
Anyone can obviously use other community apps for Minimote control, but the beauty of Button Controller is local processing and not everyone need the cloud to process every button push to turn the lights on or off.

Email support,. I can’t remember exactly what they said the issue was, but they fixed it right up and all 4 were restored and working fine again.


In addition to the button app, you can use an instance of the smart lighting to read minimote button presses.

I have a minimote velcro’ed to the wall with button one mapped to turn on light and button 2 mapped to turn off light.

I use 2 buttons instead of one button with the toggle option, to help ensure reliability and reduce any potential latency with smart things recognizing the current state of the lights the minimote is controlling.


Any luck with this? I have the same problem. Multiple devices (Android, iOS), tried to configure Button Controller, Button Controller +, etc.

Regardless, I get the “Sorry, but there was an unexpected error.” message any time I attempt to advance the configuration beyond the first page (where you select the device and any time/mode restrictions).

I have removed device, app, etc. so many times I have lost count. No matter what I try, I get the above message. Any ideas?

As I said, email support about the problem it was an issue on their end and it has to be fixed at their end.