WeMo Insight Switches

I’ve heard terrible reviews around the iot world, even with official integrations. There’s just something happening in the background with their API that just hangs up. I have no technical details to support that but I’ve even heard from an IOT podcast the show host reprimanding Wemo for their performance. Even the native app gives me crap on a regular basis. But alas I have two so I try to use them. Try being the key word.

Know what you mean. I’ve been yelling at Wemo cust support for days now for their shady advertising that you can use IFTTT. My recipes fire somewhere from 30 min to never. They finally promised me a beta version of the firmware but we have been playing phone tag for 3 days now.

I tried their phone support once and they never called back. I called back about them not calling back and they said ok sorry we’ll call you back and failed to a second time. It was then I realized I was really on my own. I can’t recommend avoiding them enough…

I am learning my lesson. Was happy I can “officially” turn my lights off with Alexa using Wemo & IFTTT and not hacking my way into it, but doesn’t seem like I have a choice. Wemo switches are useless, expensive and did I mention useless?!

Does seems to be but i guess you can use you router to assign an IP…

Really can’t get this sucker working anymore. It stopped working a week ago. I completely wiped my Wemo’s, I reinstalled both the SmartApp and the Device Type… I guess they’re useless finally…

If you guys can activate the debug mode when editing the app:

Then go to Live Loggin https://graph.api.smartthings.com/ide/logs I could help figure it out but I’m gonna need some info.

1 Like

I actually switched over to using IF (IFTTT) and virtual switches. 4 recipes per switch.
Wemo on -> virtual switch on.
Wemo off -> virtual switch off.
Virtual switch on -> Wemo on.
Virtual switch off -> Wemo off.

1 Like

I went the same route. Virtual switches to match the wemo state, but kept the wemo in ST and polling the state with pollster. Was trying to turn on and off Lutron switches via Amazon Echo. Well that has changed since Echo now works with Wink. So I dust off my Wink hub and still use the virtual ST switches to tie my Caseta from Wink.

@zzarbi Nicolas, thanks for trying to help! I attempted yesterday to install your app @ device. I finally got the app to discover my insight switches but I couldn’t add them. Here is the error I get. Any thoughts?

9df6c89f-b097-4c8f-a1d4-0fb598138e2d 9:16:58 AM: debug Dicovered insight switches
9df6c89f-b097-4c8f-a1d4-0fb598138e2d 9:16:58 AM: debug Executing lan discovery urn:Belkin:device:insight:1 on Home Hub via sendHubCommand
9df6c89f-b097-4c8f-a1d4-0fb598138e2d 9:16:58 AM: debug REFRESH COUNT :: 105
9df6c89f-b097-4c8f-a1d4-0fb598138e2d 9:16:53 AM: debug Dicovered insight switches
9df6c89f-b097-4c8f-a1d4-0fb598138e2d 9:16:53 AM: debug REFRESH COUNT :: 104
9df6c89f-b097-4c8f-a1d4-0fb598138e2d 9:16:47 AM: debug Dicovered insight switches
9df6c89f-b097-4c8f-a1d4-0fb598138e2d 9:16:47 AM: debug REFRESH COUNT :: 103
9df6c89f-b097-4c8f-a1d4-0fb598138e2d 9:16:42 AM: debug Dicovered insight switches
9df6c89f-b097-4c8f-a1d4-0fb598138e2d 9:16:42 AM: debug REFRESH COUNT :: 102
9df6c89f-b097-4c8f-a1d4-0fb598138e2d 9:16:37 AM: debug Dicovered insight switches
9df6c89f-b097-4c8f-a1d4-0fb598138e2d 9:16:37 AM: debug REFRESH COUNT :: 101
9df6c89f-b097-4c8f-a1d4-0fb598138e2d 9:16:34 AM: error groovy.lang.GroovyRuntimeException: Ambiguous method overloading for method java.lang.String#.
Cannot resolve which method to invoke for [null] due to overlapping prototypes between:
[class [B]
[class [C]
[class java.lang.String] @ line 67

Is that all the log? Can you do this:

  1. Open Live logging on Smartthings
  2. Clear all the log item
  3. Open Smartthings App
  4. Open Wemo Insight app
  5. On Smartthings live loggin, select Wemo Insight Connect
  6. Select a device
  7. Click Done
  8. Click Done

And copy paste the log here

I just tried to install this today and got Failed to save page: firstPage after selecting my WeMo Insight and clicking done. Is this a compatibility issue with the V2 hub?

same issue for me. no way to add my wemo

I’d like to start by saying a big thank you to Nicolas for writing the WeMo Insight handler. I just got my SmartThings hub v2 today and was excited to get it working with my insight switches, but I ran into the same problem that others have reported on the thread, Failed to save page: firstPage, when adding devices.

I have made a small change to the code which fixes the problem, and was able to get my insight switches working fine. I have submitted a pull request to Nicolas so hopefully he will integrate the fix or solve the problem a different way. Until then, anyone who is interested can see the modification at https://github.com/john-paulsmith/smartthings/commit/5fa259114222511ae5190caf6c396f75f1fa7e13#diff-068b3907d28f9ed31f7a0a1e30299f21


1 Like

The SmartThings v2 hub works with the Insight switch out of the box. I eventually went to add my regular Wemo Switch using the built in option, and it detected and added the Wemo Insight Switch as well. Try that out!

1 Like

I added the switch, but I’m having difficulty with the Smartthings iOS app accurately showing the current state of the switch (for both light switch and insight switch)
Just recently I lost all functionality for the insight switch, any one else having this difficulty?

I’ve basically given up on ST integration with wemo. What I ended up doing was going directly against the api with a script on my Mac (in conjunction with tha HAM Bridge). I’m basically using this to turn on, off and get status of my lights. It does require a static ip though but I find it very reliable.

It used to work but now it seems that whenever I try to add my switch I get the usual “Unexpected Error Occured”.

Now, there is now uninstall button in the smartapp… is there any way to uninstall this without having to ask the support to do it for me?

If you want to create a pull request, I’ll get yout code merge in. I haven’t bought the new HUB… which explain why I haven’t run into this issue.

I finally fixed it, the bug was in the device type. For some reason something the hub send empty data to the device. @john-paulsmith correctly identified the problem.
Code: https://github.com/zzarbi/smartthings/tree/master/wemo

PS: I changed the namespace of both device/app to avoid issues with wemo