Wemo Dimmer Switch

Were you able to resolve this? I’ve added the smartapp as well but unable to discover my wemo dimmers.

I’m using the copy and paste method but having the same issues you had with my dimmers not being discovered. Can you point me to the repository you used? Any other information you can share? Should the wemo dimmers already be paired in the app to get discovered or reset?

I’m having trouble detecting my dimmers as well. I have both the app and device type setup but can’t detect anything when I open add a thing.

Just make sure you didn’t have any past attempts/devices in your device-list that match the mac-address of the devices you’re looking to discover.

Hi kris2k2:

Thank you for your hard work to get wemo dimmer to smartthings. I am a newbie so please telle me where I did wrong. I don’t know how to fork so I use copy and paste.

  1. use copy and paste method to add your dimmer codes from https://github.com/kris2k2/SmartThingsPublic/devicetypes/kris2k2/wemo-dimmer-light-switch.src to My device handler section
  2. copy and paste your Source: https://github.com/kris2k2/SmartThingsPublic/smartapps/kris2k2/wemo-dimmer-light-switch.src to My Smartapp section. Both are published.
  3. I went to smartthings app and go to Add a Thing but it can’t find anything.
  4. I went to automation and select add a smartapp and select add a smartApp select WEMO dimmer light switch, it just keep refreshing but didn’t discover anything.
  5. I also tried to manually add switch by use the MAC number for the dimmer switch which is discovered by the smartthings hub in its event log. But it only stay at on position and won’t be able to control the dimmer.

Please help me.

Thanks.

1 Like

kris2k2, are you referring to the things or smartapps device list? What do I need to do to clear this so it will re-discover?

Hi: I finally get it working by doing the Repo method. Update Setting, add Kris2k2, SmartThingsPublic, Master. Then select from REPO, update and publish. Magically it works now. Going to automation in the app and it quickly discovers the dimmer and add it to My Home section. Thanks

Kris2k2, zzarbi are the real MVPs! Thanks guys this is awesome. Am having some issues after a day or two of connectivity with the switch being non responsive. It’s quite odd, I’ll have to take a look into it more but I’ve noticed once it stops responding, it never responds again until I do a soft reboot of the dimmer switch.

So what I assume is happening is that the Wemo Dimmer is getting a new port via upnp which is not being relayed to smartthings as the device quits responding quite often.

Hi: I have a question on how to set the dimmer level without turn on the dimmer. If I use “set level” function it actually turn the dimmer on. Is there a way to set the level according to the time of the day without turn the lights on?

I am really having no luck with this. I have one WeMo dimmer working with the WeMo app. It is on the same network that the SmartThings hub is on. I downloaded both the SmartApp and the Device Driver from the kris2k2 repository. I have created the appropriate SmartApp on my mobile app but when I run it and it searches for devices it never finds anything.

Do I need to do anything on the WeMo side to make it work?

Here is a screenshot combining the two screens. It shows that the SmartApp has modified code, but it is just a whitespace difference (that I didn’t actually make funny enough).

Just FYI, copy and paste method doesn’t seem to work. I was having the same problems as you and was unable to add kris2k2’s repository for a few days because I kept receiving an error. I was successfully able to add the repository a couple days later. I reinstalled the smartapp and device handler and everything worked smoothly.

I’m new to this but have other Smartapps working. Can you please detail the REPO method you used to update the code?

Did you ever obtain instructions on how to make the dimmer switch discoverable in ST after adding the code? I have the same issue as you

I tried the copy and paste and it didn’t work so I was able to do the repo method and get it to work. Below are instructions for those who might still be trying to figure out how to get this to work.

  1. Go to your computer browser and log into your smartthings account. https://account.smartthings.com/
  2. You have to create a GitHub account and allow GitHub Integration in your smartthings account.
  3. Set repo to Kris2k2, SmarthingsPublic, Master.
  4. To create your device handler: In smartthings account, click [My Device Handlers] menu option on top of the page, then click [Update from Repo]
  5. Select the devicetypes [Wemo Dimmer Light Switch] from the list of devices.
  6. Check the Publish checkbox and click [Create].
  7. to create your smartapps handler: In smartthings account, click [My SmartApps] menu on the top, then click [Update from Repo]
  8. Select the smartapps [Wemo Dimmer Light Switch] from the list of smartapps.
  9. Check the Publish checkbox and click [Create].
  10. Now go to your smartphone and start the SmartThings app.
  11. Don’t add things because it didn’t work for me. What works for me was going to the [Automation] at the bottom, chose [SmartApps] tab, then choose [SmartThings Labs], you should see [Wemo Dimmer Light Switch] select it and it will automatically discover the dimmer switches. I had a problem discovering one of the switches but by turning it on and off, the app was able to detect it.

Hope that helps.

2 Likes

Also, Belkin’s Alexa skill was a pain to try to get to sync with Alexa. In fact, I was never able to get Belkin’s skill to work. Once you get SmartThings to work, it is much easier to get the SmartThings skill to work on Alexa. All the dimming functionality works great.

I added the Wemo skill today to Alexa and it synced up with no issues :slight_smile: I was asked to turn on a Wemo device and Alexa showed that device and asked if I turned it on, I responded yes and all my Wemo devices synced to Alexa.

@jkp - It’s great that you are able to get the Wemo skill to work. I tried probably 8 times and got 10min lock out 4 times with all the MAC addresses of the different Wemo devices I have w/o success. I’m glad I was able to get the Smartthings to work with the Wemo dimmer so at least now I can use Alexa to control it.

Still no go. My two dimmers will not connect. Could it be because I have a new mesh router or when I changed my router? They connect fine up to Wemo APP.

While Kris2k2’s code works well for attaching your Wemo dimmers and getting Smarthings to recognize them, after a few days you will notice that they stop responding. This is because for whatever reason Wemo likes to update the port they communicate on. If this isn’t caught then the hub ends up sending messages out in to the ether. I wrote a fix for it based off of Kris2k2’s code. You can grab it here: https://github.com/meatheadmike/SmartThingsPublic. Hopefully he’ll merge in the PR at some point down the road.

2 Likes