Welcome code error "you are not authorised to perform this operation "


(Rakesh Jhilmit) #1

Hi everyone I just bought the smart things hub and was following the steps to get everything working but after I created the account it keeps giving me an error after I enter the welcome code. I bought this new from amazon. Any help would be greatly appreciated. Thanks.


#2

Have you emailed support@smartthings.com?

Also, have you tried exiting the app, closing it, and trying it again?

If all else fails, get a hold of support, they can help.


(Rakesh Jhilmit) #3

Hi thanks for the reply. I did try restarting the app and even my phone but no success and I emailed support and am awaiting a response.

Thanks.


(Rakesh Jhilmit) #4

Hi guys

Just an update support replied with the following

" Hey there,

Thank you for the pictures. I went ahead and created a location for you, so let’s get that Hub claimed:

Open SmartThings app and tap Menu
Tap the Gear
Tap on the map and adjust your geofence following the steps outlined in the article, How to edit Location settings
Scroll down and tap “Add Hub"
Input the code, XXXXXX
That should do it. Let me know if you hit any snags or have any further questions.”

and everything works now. Haven’t had much time lately so hopefully this can help someone else in a similar situation.