Weird error - platform or just me?


(Stephen Jones) #1

I’m trying to write a new app, but I keep getting the same error that makes no sense at all.

com.google.common.util.concurrent.UncheckedExecutionException: org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
script14559369036652059347334.groovy: 27: unexpected token: ) @ line 27, column 6.
def () {
^

Line 27 is not what the error message says it is. Now even if I try code that works from another app or create a new app, I get the same error. If I try to delete any of my new unpublished apps, I get an error saying I can’t because it’s installed by a user, which it certainly is not.

Is it just me? Is there a platform issue?


(Stephen Jones) #2

I figured out how to delete my apps. I had to remove the location from the app.

The error above is still occurring no matter what, however.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #3

Can you please share the entire source code if you would like possible help to reproduced and/or debug? …Thanks.


(Stephen Jones) #4

As mentioned above, the source code doesn’t matter. ANY new app I try to create gives the same error, even without any code at all.


(Stephen Jones) #5
`/**
 *  test
 *
 *  Copyright 2016 Stephen Jones
 *
 */
definition(
    name: "test",
    namespace: "BodaciousDrake",
    author: "Stephen Jones",
    description: "test",
    category: "",
    iconUrl: "https://s3.amazonaws.com/smartapp-icons/Convenience/Cat-Convenience.png",
    iconX2Url: "https://s3.amazonaws.com/smartapp-icons/Convenience/Cat-Convenience@2x.png",
    iconX3Url: "https://s3.amazonaws.com/smartapp-icons/Convenience/Cat-Convenience@2x.png")


preferences {
	section("Title") {
		//nothing
	}
}

def installed() {
	log.debug "Installed with settings: ${settings}"

	initialize()
}

def updated() {
	log.debug "Updated with settings: ${settings}"

	unsubscribe()
	initialize()
}

def initialize() {
	//nothing
}
`

(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #6

I’ll double check this code, but it probably is “just you” :confused:.

I presume you’ve emailed Support? They can check and clear your account of any corruption.


(Stephen Jones) #7

Thanks for taking a look. I will contact support during their chat hours tomorrow, I was just wanting to see if anyone else was having the same issue more than anything.

[off-topic]I’ve been having fun with SmartThings since I got my hub a couple of weeks ago, but I’ve got to say it does seem a bit buggy at times. Hopefully Samsung continues to invest heavily in and improve this product. They seem to have a decent market share, but they could loose it really quickly.[/off-topic]


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #8

Yup… Unfortunately, it is quite frequently unstable and that can be understandably very discouraging.

Ww don’t have access to any detailed bug / feature tracking, and just know that some bugs have been around for… years. Overall, each iteration is a few steps forward and a few back… Hopefully the former is bigger than the latter.