WebCoRE issues with Lifx

webcore

(Andrew Nichols) #1

I’ve recently gotten started with WebCoRE and I have been loving it! It’s extremely powerful for programming my smart house but I have noticed significant issues when interacting with Lifx bulbs. For example, I have a simple piston that when my porch door is opened, I want to turn on 2 of my outside lights for 3 minutes. When the piston runs, only 1 of the lights is turned on, but then it never turns off. Can someone please help me understand why Lifx bulbs work so differently than any other device controlled by SmartThings?


(might be my fake name?) #2

Try this. This one works for me. I use it for my front door with my lifx bulbs that are outside.

Create a restriction for your time aspect. Instead of making it part of your condition. Get rid of “changes to” and make it “is”.

If you are familiar with importing pistons, you can import mine and just change the parts that need to be changed. Import by using the import code.


#3

They work no differently than turning on / off any other device. Without troubleshooting this, the one thing I noticed is that you have two sets of Do Tasks. Your Then statement should contain both Bulbs (with RGB 1 and 4) with one set of Do Tasks to Turn On, Wait and Turn Off.

One other thing to Note: With LIFX bulbs because they are Wifi, they can drop off the Network when out of range. (I have 6 Minis outside and from time to time, one or two of them fall off the Network and can’t be accessed).

If you want to use the Piston above that Eric posted above and being able to activate a scene directly from your LIFX app, this will help:


(might be my fake name?) #4

I’ve found that assigning my lifx bulbs static IP addresses has helped with them not turning on or off as well.


#5

I added an Access Point in the garage so that they are always in range now. That for the most part solved my drops. :slight_smile:


(jkp) #6

Another piston for you to try if you want…

I can see your piston timing out on the contact changes to open after about 20 seconds. I changed the task cancellation to Never in the piston I posted. I also cleaned up a few things you put in, such as the time is after sunset - that is the same as “all day” so I figured you only wanted it during the night. You should also consider using presets for times instead of using variable ($sunset), etc

a good resource to utilize is the webCoRE community forum for example pistons and also lots of advice when needed.

I hope this helps :slight_smile:


(Andrew Nichols) #7

Hi all, thanks for the replies, I think I have some things to try out to move forward now. @WB70 the reason the bulbs are in async Do tasks is because previous to taking this snapshot, both of the bulbs were in the same Do task with no difference. The snapshot I uploaded was simply the last state of the piston I was in trying to troubleshoot it.

In terms of range, the bulbs are 10 feet away with no walls in between so I know the range isn’t an issue. I also ensured the bulbs were connected to the network as both Lifx and Smartthings were able to control the bulbs by manually turning them on/off.

@jkp Time is after Sunset works totally fine and doesn’t activate all day, I shouldn’t use preset times as where I live the sunset ranges from 430pm to 10:50pm throughout the year. I should make my statement like yours though for next winter when the sun doesn’t rise until 8:30am but it’s a bit of an edge case since we’re not going into the backyard in the morning.

I appreciate the help on this topic but I’m not sure if this is a bug in WebCore or not, it seems like the “turn on” and “turn off” command for Lifx bulbs are not working properly and instead the community has found workarounds like IFTTT and Lifx Scenes.


(steve grout) #8

hey guys,

I’m not sure why you’re having an issue with Lifx bulbs. I only have one of them (RGB) and have no issues with it at all in both of the WebCoRE Pistons that use it.

The first is a simple toggle the light off and on a few times when the front door is opened (a few other conditions such as SHM mode etc in there) which works flawlessly.

The second one alternates the light between 2 colours, swapping every 5 seconds for a period of 30 seconds, if the back door is left open for more than 10 seconds. If the door is closed then the light resets to its previous state before alternating the colours. I did this because the kids were constantly leaving the back door open. Now it annoys them with the light changing to dark green and purple in the room the Pc’s are in, if the door is left open, it never seems to be open any more

There is one more but that just switches the bulb off when SHM is activated.

Hope you get the issues resolved.


#9

The LIFX Scenes isn’t a workaround for anything. It’s an enhanced feature to be able to directly set lights using predefined scenes created directly in your LIFX app within SmartThings versus wanting to create Scenes using SmartThings half baked Scenes functionality. People with Hue and LIFX have an advantage in being able to use this functionality from Scenes created in their own apps which is convenient and simple.

My reply wasn’t posted to resolve your issue. It’s another solution for turning your lights on together with predefined values and since someone gave you a sample Piston that had that alternative, I gave you the link to my FAQ in the event you wanted to take advantage of that inherent functionality that is already pre built into WebCoRE (specific to LIFX).

I have never had any issues turning on and off any LIFX bulbs via Routines, Smart Lighting, or Pistons (as long as they were on the network) :slight_smile:


(Robin) #10

Not sure why only one bulb turns on (maybe related to asymc / two Do’s, maybe not) but the problem you are seeing which them not turning off is very simple.

The trigger ‘changes to’ only stays ‘true’ for about 10 seconds after the change event, it then reverts to false and is cancelling your waits.

Use ‘IS’ (are) open instead of ‘changes to open’.

Alternatively… the logic might be better if you keep the light on until after you close the door again.

IF
time is after sunset (btw, use the preset not the variable, when selecting sunset)
AND
any of x y or z’s contact are open
THEN
with both lights
Turn on
ELSE
with both lights
wait 3 minutes
Turn off.