Wayne Dalton WDTC-20 Thermostat work with ST?


(Luis Rodriguez) #1

Hello,

I wanted to know if anyone has this thermostat working with ST?

Z-Wave® Enabled
Thermostat
For Model WDTC-20


(sidjohn1) #2

If you already have it, I’d just try to pair it and see, it could just work. If not, here’s s is a list of compatible devices.


(Tim Yuhl) #3

I have one of the WDTC-20 thermostats and it works fine with ST.


(Luis Rodriguez) #4

Thanks, I got it working on my wink but am thinking to get the ST…


(Luis Rodriguez) #5

I just tried to add WDTC-20 to ST and it shows up as a light switch? Any ideas?

Luis


(Tim Yuhl) #6

This thermostat has a special compatibility mode (see page 27 of the instructions) that joins it to the Z-Wave network as a binary switch. If you hold the bind button down for 4 seconds and then release it, you will join the network in compatibility mode. I think that is what has happened in your case.

I think that you have two options:

  1. Remove it from the network and try re-adding it. During the join, press and release the bind button (don’t hold it down).
  2. If you are familiar with the developer’s IDE, go into it and try changing the device type to a Z-Wave Thermostat.

BTW, if you are familiar with the IDE, you might want to try a custom device type. I am using the “Better Thermostat” device type that was authored by twack. You can find it if you do a search.

Good luck!


(Luis Rodriguez) #7

I left it as a light switch, then went into IDE and changed it, no data its all blank?

Luis


(Luis Rodriguez) #8

I got it working with the Better Thermostat!


#9

Anyone mind taking a noob through this? Even just touching the bind button adds this as a switch. I don’t know how to change the device type or mess with IDE yet. Pretty happy that In 2 days converted the whole house over from Vera with only this and one other device out of almost 100 not functioning properly.


(Tim Yuhl) #10

You can try removing the device and re-adding it to the network again. Do you see the 3 vertical dots on the top right of your screenshot? That brings up the “Edit device” menu and that has the remove button.

When you re-add it, follow what I said in my post above and make sure that you don’t hold down the bind button.


#11

Tried that several times. It gets recognized as a switch, even with a short tap. How do I change the device type?


(Tim Yuhl) #12

If removing it and re-adding it didn’t work, then the only other option is to use the IDE to change the device type.


#13

Exactly. How do I do that?


#14

In case anyone else is wondering how to change a device type, go to https://graph.api.smartthings.com

Log in, then find the device you want to change. Click the “edit” button and then elect device type you want to change to. After selecting “Thermostat” in this case, it worked fine.


(Grant Newland) #15

I have a WDTC-20 and ST hub, the thermostat discovers as a switch but you can edit the device type from the dropdown list, choose z-wave thermostat as it’s the only one where on/off for heat and cool work. Temperature sliders are tricky but also work. There is no control of the fan mode, only reporting.

From Alexa, you can only set the termperature or raise/lower it but not ask its current value. Alexa has no mode on/off commands.