WAPIRZ-1Z Monoprice Motion sensors suddenly appear to have additional features

Looking forward to it! :pray: :pray: Thank you!!

Not sure if this also related to drivers, but anyone has the Fibaro Flood Sensor?
I also been using 6 of them for around 10 yrs, all been working fine, until recently, they start randomly say moisture detected then back to normal. maybe once a week for few days, definitely nothing as frequent as the monoprice motion sensor.

I also just realized my Virtual Switch through IFTTT to control my iRobot Roomba is no longer working… :neutral_face:

You may have to re-register ST with IFTTT. I got a notification on Monday that ST changed the way it connects with IFTTT with its API. You have to reconnect the service for it to use the new API and keys.

Hi, I tried last night, unfortunately it seems like IFTTT treats Smartthings a PRO user feature. Even with only 2 applets, it requires me a $5/mo fee…

Seems like the entire field of smart homes are changing for the worst (compare to how it was 10+ yrs ago)


1 Like

Most things that you can do with Ifttt you can now do with free Alexa routines, if that’s of any help. I canceled my Ifttt last month, there was nothing there that I couldn’t do in another way. :thinking:

4 Likes

I agree with @JDRoberts I have been able to replace IFTTT with routines in Smartthings, Google Home and Alexa. The only thing I run in IFTTT is an email notification when an item is added or removed from my Alexa shopping list. This uses my two free applets.

1 Like

Oh they broke almost every zigbee device you can think of. Sensors, lights even brand new matter devices.
Will they admit it? :pensive: No

Hello, once you have ‘added support’, what must we do to get them working. I’m just a normal user of ST and have no clue about ‘updating drivers’, ‘excluding devices’, and all this other jargon. Kind of liked it when you just add devices and go from there. Everything keeps changing in ST and it’s so frustrating. I’m constantly wasting huge amounts of time dealing with the ‘upgrades’. Anyway, enough complaining. could someone provide explicit instructions as to how to fix these Monoprice devices once the drive is updated?

@csstup Thank you, Corey! I have a couple of the original ZWave sensors (not ZWave+) branded as GoControl and am looking forward to testing this driver. My understanding is the device was sold under a number of brands, including Linear, GoControl, and Monoprice–hopefully with few differences in messaging protocol…

Yep, they’re all identical too. So it will work for all of them.

2 Likes

I have the driver ready for beta testing by a few more people. If you have one of the Linear WAPIRZ (or its clones from GoControl or Monoprice) PM me if you’re interested.

4 Likes

Thank you @csstup . I will love to do the test it out if possible.

Sorry for not knowing, but I have Monoprice Door/windows, Garage Door & Motion Sensor. And I am not sure if they are considered clones of Linear WAPIRZ?
If they are, I will love to test the beta driver!

These are the Monoprice Sensors I have (circled in red)

The WAPIRZ is a passive infrared (PIR) motion sensor. Door/window contact sensors, and garage door devices are different models from different device classes. So only the motion sensors are potential clones in this case.

2 Likes

@JDRoberts is correct about the motion detector, of course.

Although off-topic for this thread, the WADWAZ Door/Window sensors from Linear/GoControl/Monoprice, et.al., shown in your photo seem to work fine with the stock SmartThings “Z-Wave Sensor” Edge driver. They use the legacy ZWave non-secure network connection. I have four of these in service at two locations/hubs and they behave okay.

1 Like

I’ll test it as well. I would represent the ‘median user’ out there (i.e. ‘non-expert’) and would need some pointers as to how to load it up.

1 Like

Same for me. The only issues I am having is the Motion Sensor, Door/Window Sensors are ok.

1 Like

I’m looking forward to it, thank you! I have 7 of those motion detectors and it keeps saying there’s a fire in my house. Not cool!
BTW, I’m looking at the advanced users interface and no longer see a section to install drivers. I’m hoping you can enlighten us to how you can install the driver you’re creating.

All edge drivers are installed in the same way. It’s different than the old DTHs, but it’s actually easier. :sunglasses:

The edge Driver author will give you a “channel link” and you just click on that. ( if they have an author thread in this forum, the invitation link is usually in the first post of that thread.)

That will take you to a webpage where you can subscribe to the channel and select the individual edge drivers from that channel that you want downloaded to your hub.

Then, you just wait, and the driver will be automatically downloaded to your hub. It usually only takes a few minutes, although it can take longer.

You can read more details and how to see which drivers are on your hub and all that in the community FAQ:

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

2 Likes

Hello, I went to what I think is your Channel. Is this the correct driver to test?

  • NameZ-Wave Sensor PH
  • DescriptionSupports a variety of HomeSeer, Ecolink, FortrezZ, Monoprice, and Zooz Zwave sensors.
  • Permissions
    • zwave: Enable full access to Z-Wave actions

Thanks,

Dan

No, thats not the correct driver. Once a couple beta testers confirm its okay I’ll release the details.

Thanks!